Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD with assorted stop codes

14 Jul 2010   #1

Windows 7 Ultimate 64bit
 
 
BSOD with assorted stop codes

Hiya.

After about 50 attempts at installing Windows 7 Ultimate 64-bit to a newly built computer, I finally got it installed, despite all the "source file unavailable" messages and random BSODs, and ran it rock solid stable for about 6 hours last night. When I turned it on this morning, however, I was met with a BSOD upon loading my desktop with some error messages relating to various programs that I didn't have time to read. This, coincidentally, occurred on my previous fresh W7x32 install the day before, too.

I got home from work today and fired it up, just to see what would happen, and each time it loaded to desktop, I got hit with a BSOD, each time with different stop codes, ranging from "reference_by_pointer" to "system_service_exception". I ran the windows memory diagnostic on the RAM I have in my system now, and it showed that I had an error (though wasn't kind enough to tell me what kind and on which module...) I ran the test again on each module and each time the test showed negative on errors, so I put both sticks back in, but this time in the second bank, to test - surprise surprise, the test shows errors.

Having had the computer warmed up now for a few hours, it seems to be fairly stable, and I'm running memtest on the pair of DIMMs as we speak. The tests are so far showing negative on errors.

I'll upload the stack dumps as soon as it's finished testing the RAM (I'm on my laptop atm) but in the meantimes, what are your initial thoughts? Chipset errors on the motherboard that stops it running correctly in dual channel mode? Dead RAM? Any help would be appreciated.

Thanks,
Dave.

System spec: AMD Phenom II 955 3.2GHz, 4GB Geil Black Dragon 1333 RAM (2x2GB), Asus M4A88TD-M EVO/USB3 motherboard, 1TB SATA Samsung HDD, 2x LG DVD-RW (IDE), Asus 5770 ATI graphics card and a 700watt PSU.


My System SpecsSystem Spec
.

14 Jul 2010   #2

Windows 7 Ultimate 64bit
 
 

Okay, after running memtest within windows for an hour or so, 100% tested showed 0 errors. Quite why windows memory tester is returning errors, but memtest isn't, is beyond me, but there you go. I'm attaching my stack dumps with this post - hopefully that'll help someone diagnose the issue.
My System SpecsSystem Spec
15 Jul 2010   #3

Windows 7 Ultimate 64bit
 
 

Another couple of hours running stable last night after it'd warmed up, I turn my computer on this morning and I get a "spooler subsystem app has stopped working error" on boot, then a BSOD with a 0x19 bad_pool_header stop code about 5 minutes later, while idling on desktop.

I'd be willing to bet that once it's warmed up a little, it'll be stable all day.

Still no ideas?

Edit: And one more BSOD for good measure. This one with a 0x24 stop code, citing ntfs.sys in the main body text.
My System SpecsSystem Spec
.


15 Jul 2010   #4

Microsoft Window 7 Professional 32 bit
 
 

It sounds to me that either Ram or hard drive problem.
From the crash dump you uploaded, I can see different stop codes, memory was blamed in most of those as well as ntfs.sys which is hard drive controller drivers.

Have you overclocked anything? if so, please reset to default setting.

What version of memtest have you used? Do you use memtestx86+ to test your ram? If so, what version
Memory Diagnostics <--You might want to check that to see in detail

I would suggest you to do disk check and Hard drive diagnostic (downloaded diagnostic tool from the manufacture's site):
Disk Check
HD Diagnostic

BUGCHECK SUMMARY:
Code:
BugCheck 18, {0, fffffa8006045e70, 2, ffffffffffffffff}

Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+46451 )

Followup: MachineOwner
---------
BugCheck 4E, {99, c8228, 3, c8227}

Probably caused by : memory_corruption ( nt!MiBadShareCount+4c )

Followup: MachineOwner
---------
BugCheck A, {fffff680003f8a90, 0, 0, fffff80002ca11e2}

Probably caused by : memory_corruption ( nt!MiAgeWorkingSet+1c2 )

Followup: MachineOwner
---------
BugCheck A, {fffff680003f68c8, 0, 0, fffff80002dd9e37}

Probably caused by : memory_corruption ( nt!MiCaptureAndResetWorkingSetAccessBits+97 )

Followup: MachineOwner
---------
BugCheck A, {fffffa800d967e92, 2, 0, fffff80002095bf5}

Probably caused by : ntkrnlmp.exe ( nt!NtWaitForWorkViaWorkerFactory+4e4 )

Followup: MachineOwner
---------
BugCheck 3B, {c0000005, fffff80002ded000, fffff88002980fd0, 0}

Probably caused by : Pool_Corruption ( nt!ExDeferredFreePool+174 )

Followup: Pool_corruption
---------
BugCheck 24, {1904fb, fffff88007beaa68, fffff88007bea2d0, fffff800020aa516}

Probably caused by : Ntfs.sys ( Ntfs!NtfsFullDeleteLcb+45 )

Followup: MachineOwner
---------
My System SpecsSystem Spec
15 Jul 2010   #5

Windows 7 Professional x64
 
 

Please remove Comodo for the time being.

Replace with Microsoft Security Essentials (anti-malware) and the Windows Firewall.

Enable driver verifier: Using Driver Verifier to identify issues with Drivers
My System SpecsSystem Spec
15 Jul 2010   #6

Windows 7 Ultimate 64bit
 
 

Okay, just a few updates.

The first thing I did when I got home this afternoon was to attempt to run Windows - this, as expected, resulted in a BSOD. I then ran Memtest86+ on both sticks in their original configuration, and found no less than 60,000 errors from test 4 onwards on the first pass. I then proceeded to test each stick individually in each slot, with each test returning no errors whatsoever. I've just finished running a test again on the original configuration with both sticks in, and guess what? No errors after 2 passes. I'm about to boot into Windows and check stability and I'll let you know what happens.

ttran, to answer you questions:

I originally ran the windows memory diagnostic from the boot menu - I assume it's the most recent version to my copy of Windows 7 Ultimate, which returned harware errors but wasn't more specific. After that, I ran a program simply called memtest from within Windows and returned no errors at all.

I've run chkdsk and although it did turn up a few orphaned files etc, these appeared to be from the system not shutting down correctly on any of its numerous BSODs, and I couldn't see anything critical in the results. I attempted to run the Samsung HDD utility this evening, but it failed to run, citing:

"Cant open CD driver CD001. SHUCDX can't install

your ram drive is loaded at c:
Out of memory error
Bad command or filename"

So I haven't gone any further with that for now. I am also not overclocking anything, and running everything at stock settings, with memory voltage and timings by SPD.

Jonathan_King: I'll remove Comodo and run the driver verifier tomorrow, after I've conducted a few more tests - I don't want to eliminate too many things at once in case I miss the issue altogether.

I'll run another memtest tomorrow on a cold boot (as the system seems to run stable after a while) and see what happens, and then I'll run it overnight to check again.

At the moment, I'm stumped as to whether it's the motherboard, RAM or CPU (seeing as the memory controller is on board with AMD chips?) Indeed, I may have to RMA the lot and leave them to figure it out.

Thanks, both of you, for your help so far.
My System SpecsSystem Spec
16 Jul 2010   #7

Windows 7 Ultimate 64bit
 
 

Upon running memtest86+ again when I got home from work today on a cold system, I'm so far at 6,000+ errors from test 5, 6 and 7, with test 8 still to come.

I am geniunely stumped. No errors on a warm system, yet tens of thousands on a cold boot. I'm pretty much ruling out Windows or HDD errors here, though you're welcome to disagree.

Dry joint or bad soldering on the motherboard maybe? I could do with pinning this problem down to a specific piece of hardware to avoid RMAing the whole damn kit and kaboodle.
My System SpecsSystem Spec
16 Jul 2010   #8

Windows 7 Professional x64
 
 

Try increasing the RAM voltage slightly. That's all I can suggest.
My System SpecsSystem Spec
16 Jul 2010   #9

Windows 7 Ultimate 64bit
 
 

I've also started a new thread at Memory issues with Asus M4A88TD-M Evo/USB3 - AnandTech Forumsin an effort to spread the net a little wider and get some input from the hardware crowd. Feel free to offer any sagely advice with regards to what they say.

Thanks again.
My System SpecsSystem Spec
16 Jul 2010   #10

Windows 7 Professional x64
 
 

Thanks for the link. Would you mind posting back here if they can solve the issue?
My System SpecsSystem Spec
Reply

 BSOD with assorted stop codes




Thread Tools



Similar help and support threads for2: BSOD with assorted stop codes
Thread Forum
Solved BSOD, stop codes: F4,7A (Almost Constant) BSOD Help and Support
Solved Getting Random BSOD with different stop codes BSOD Help and Support
Solved BSOD, new rig, getting multiple STOP codes BSOD Help and Support
BSOD - various stop codes BSOD Help and Support
BSOD 0x000000D1 and 0x0000000A stop codes. BSOD Help and Support
BSOD with various stop codes - need help with minidumps BSOD Help and Support
BSOD (Various stop codes) BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33