Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Site Running slow?

16 Aug 2010   #1
Anthony

Microsoft Community Contributor Award Recipient

MS Windows 7 Professional 64-bit SP1
 
 
Site Running slow?

Anybody else suffering slow browsing on Seven Forums?
My System SpecsSystem Spec
16 Aug 2010   #2
Tews

64-bit Windows 8.1 Pro
 
 

Loads fine here...
My System SpecsSystem Spec
16 Aug 2010   #3
z3r010

 

No problems here and the servers look normal.
My System SpecsSystem Spec
16 Aug 2010   #4
steve-pressman

Windows 7 Ultimate 64 - OEM Service Pack 1
 
 

All good here no problems at all


Steve
My System SpecsSystem Spec
16 Aug 2010   #5
Anthony

Microsoft Community Contributor Award Recipient

MS Windows 7 Professional 64-bit SP1
 
 

Yeah it seems to have picked up now, must have been DNS.

Thanks
My System SpecsSystem Spec
16 Aug 2010   #6
Solarstarshines

Windows 7 Home Premium 64bit sp1
 
 

im flying over here never had any problems with this forum except when im trying to look through my phone at work cause of no signal in the building but this site has been great on the speed
My System SpecsSystem Spec
15 Jun 2011   #7
panais

Windows 7 Ultimate 64bit SP1
 
 
slow sevenforums browsing

I tried everything clear cashe,cookies dns but when i start browsing seveforums is slow almost freezing.
With other sites its just fine.
Any idea?
Edit:Its ok now.
I dont know the exact reason but after more cleaning,restarting etc everything is back to normal.
My System SpecsSystem Spec
15 Jun 2011   #8
pparks1

Windows 7 Ultimate x64
 
 

^ Could have just been an internet routing problem too with your ISP that cleared up during your cleanup. . Glad it's all sorted for ya now.
My System SpecsSystem Spec
Reply

Thread Tools



Similar help and support threads
Thread Forum
Yahoo and other site loading WAY SLOW
I am SOOOO new to Windows 7. I am the IT support person for a company which had no intentions of moving to Win7 yet, but our CEO got a SONY laptop with Windows 7 home Premium 4gb on the motherboard, 64bit OS When we are trying to brows the web we have no problem with Google but Yahoo comes up...
Browsers & Mail
Running real slow / shut down slow
Hi i have a Eee Pc Asus laptop that is running real slow could someone help me please thank you i ran a farbar scan if that might help Scan result of Farbar Recovery Scan Tool (FRST) (x86) Version: 19-07-2013 Ran by Ma (administrator) on 21-07-2013 16:25:23 Running from E:\ Microsoft...
Performance & Maintenance
slow switching between web site links etc
For about a month now I have this problem with really slow switching between links. For instance on this web site 01-17-1955_13058 Hond op de step | Flickr - Photo Sharing! On my husband's computer I can switch between pictures as soon I click on "next" while on my computer I have to click several...
Browsers & Mail
internet site lookup slow
everday i am facing this issue when ever i try open some site for first time firefox keeps looking for site almost 15-20 seconds but later same site loads super fast, i tried using open dns / google dns but no use, tried dns flush etc command found on google still no luck, hope to get some solution...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App