Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: All your base :)

13 Apr 2009   #1

windows 7077
All your base :)

[ame=""]YouTube - All Your Base Are Belong To Us[/ame]

This is for those who may never have seen this b4
My System SpecsSystem Spec
13 Apr 2009   #2

Windows 7 Professional 64-bit

yeah classic.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Base System Device
I have recently installed my Toshiba Satellite a665-s6904 with Windows 7 Professional x64. When I went to use it, I had several devices that couldn't be found and now my computer is incapable of doing anything. I even tried to plug in the Ethernet cable and I still can't get online. How do I fix...
Hardware & Devices
Locking down a base computer
I'm currently trying to lock down my base computer from my friends and was wondering what are the best ways ways on doing it?? When I mean locking it down I mean as far as accessing the data on the computer. I have quite a bit of computer knowledge but I'm like everyone else, I don't know it all....
General Discussion
base designs and websites
I like the simple style, so I picked the contrast nr. 1, changed a few things and am now using it. But using this style breaks websites when viewed through Firefox . It seems as if background images just won't be displayed at all. Why would this be happening? As an example, there's this page...
Themes and Styles
Base System Device
ACER / ASPIRE 5270G, recently changed from Vista Home to Windows 7 Ultimate N. In Device Manager...> Other Devices.... There are Two Base System Devices & One Unknown device are highlighted with yellow icon. Problem are 1. my laptop camera not detecting 2. Bluetooth not working 3. pre-built...
General Discussion
base system device
In device manager under 'other' there is a yellow Based System Device. I try to update it and it gives me a error "no driver found". I got to dell and download the Richo chipset. I try to insta1l and I get this this error, "You have to run the 64bit version DPInst.exe on this machine." So I put...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:33.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App