Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Game "hardware cursor" disappears after changing text size

07 Dec 2011   #1

Windows 7 Home Premium x64
 
 
Game "hardware cursor" disappears after changing text size

I'll start out here by stating a problem I finally solved and then my question:

For months now I've been fighting that my hardware cursor disappears in World of Warcraft on my home theater system and time I switch modes to full screen and sometimes even in windowed mode and the reason for this is apparently due to me setting my display text size to 150% or 125%. I did find via some searching WoW customer service forums that if I set it back to 100% (default) OR 149% customized, my hardware cursor works again. I'm going to leave it at 149% because I really do need the larger text size on my HDTV and using 149%, I don't have to change back to normal, log out, log in, then start my game.

I'm glad I found this solution - but my question is, WHY is this an issue on Windows 7? Why does 149% work??

I did some searching and couldn't find any reports of this on XP - and as far as I can remember it only started happening to me when I upgraded my XP to Windows 7. I'm hoping Microsoft recognizes this as a bug and will fix it someday.

Thanks in advance!

My System SpecsSystem Spec
07 Dec 2011   #2

Windows 8.1 ; Windows 7 x86 (Dec2008-Jan2013)
 
 

This has to do with DPI scaling. Technically, when you change DPI different images should be used (higher DPI - higher quality image).
150% probably is that border where image should be changed. Likely, in your case that image is missing or somewhat corrupt (or might be a Blizzard's bug).

But Microsoft knows about problems with scaling. In Windows 8 Dev. Preview, at least in Metro part of it, scaling is done in a different way.
My System SpecsSystem Spec
07 Dec 2011   #3

Windows 7 Home Premium x64
 
 

Thanks for your answer - now that you explain it, I'm betting the problem is Blizzard's because the cursor is obviously a custom cursor. From what you say, if they don't have the right DPI, then it won't show. I'm going to search through their files and see if I can find their cursor image and mess with it (just for the fun of it). Not that I really need to "fix it" since I do have the "149%" solution - but I just really hate blindly fixing things and not know the logic behind it.
I'm guessing this DPI scaling was new and/or different in Windows 7 -vs- XP? I swear I never had this issue in XP.
My System SpecsSystem Spec
.


Reply

 Game "hardware cursor" disappears after changing text size





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:31 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33