Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Run window does not display font correctly with custom visual style


01 Nov 2013   #1

Windows 7 Pro x64
 
 
Run window does not display font correctly with custom visual style

Hello everybody.

I recently applied a custom VS on my computer, and also changed the fonts system wide. My issue is that while I did manage to customize and change the font on the run window as well, it doesn't display like I expected. Basically, instead of the font being very light grey on the theme normal dark grey background, I find myself with the font being black on a font-only white background. See here:

Name:  issue2.png
Views: 13
Size:  5.1 KB

Also, for some reason all the apostrophes in Windows menus ( at least in right click menu on desktop and control panel ) disappeared. I know this is not because of the font itself, because I use it on Firefox as well and there's no issue there. Here's a pic I made to explain to the VS author:

Run window does not display font correctly with custom visual style-issue.png

When I asked the VS author, he told me he had no idea why this any of this is happening either.

Thanks in advance to whoever tries to help me.




My System SpecsSystem Spec
.

02 Nov 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Welcome to the Seven Forums

Post a link to the theme and I will look at it.

How did you change the font system wide?

What font did you use?

What language are you using?

Jerry
My System SpecsSystem Spec
02 Nov 2013   #3

Windows 7 Pro x64
 
 

Hello, thank you for your time. To answer your questions in due order:

I use the Deshou VS theme ( link here : Deshou VS by Ravmunken on deviantART ).

I changed the font by editing the registry (the Fonts and FontSubstitutes keys in HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion). I removed the Segoe UI values, and replaced every font but Arial, Courier New and Times New Roman fonts with mine.

My font is HaxrCorp S8.

I'm using french.

-------------------------

So, I did figure out why the apostrophe isn't showing up : Windows use the (Alt+0146) apostrophe for its menus, dialogs, etc, which my font does not have (it just have the classic ' apostrophe).

I'm currently trying to edit the font to include it (because it's much easier than to edit every single system file to switch apostrophes) , but it is harder than I anticipated.

So the only issue left is the run window issue.
My System SpecsSystem Spec
.


04 Nov 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Good to hear you got the font straightened out.

I downloaded and tried to fix the run window and for some reason it will not fix, the theme maker has done something that is preventing it.

Sorry
Jerry
My System SpecsSystem Spec
05 Nov 2013   #5

Windows 7 Pro x64
 
 

No trouble, thank you for trying to help me out.
My System SpecsSystem Spec
06 Nov 2013   #6

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

You're welcome
My System SpecsSystem Spec
Reply

 Run window does not display font correctly with custom visual style




Thread Tools



Similar help and support threads for2: Run window does not display font correctly with custom visual style
Thread Forum
How do I create a Visual Style from scratch? Copy Window's Aero theme? Themes and Styles
"Flie open" window doesn't display correctly General Discussion
Visual Style Window Trouble Customization
Looking for a simple visual style - and willing to pay for it Themes and Styles
Windows 7 visual style help Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:27 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33