Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Address bar in Aero theme just disappers for no reason.


08 Jan 2014   #11

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

It's a virus, sure it was a mistake

A Guy

My System SpecsSystem Spec
.

08 Jan 2014   #12

Window 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by A Guy View Post
Interesting the explorerframe.dll is responsible for those buttons. I know you ran SFC, but have you tried replacing explorer.exe, or explorerframe.dll

Extract Files from Windows 7 Installation DVD

A Repair install may also fix that. I assume the /verify will show the same files as /scannow?

A Guy
I re-installed the file explorerframe.dll from the Win7installer.iso file, which I have on my HDD on a separate data partition. That went without any problems, although I had to take ownership of the *.dll file. However the problem with the back-and-forward buttons loosing their history is clearly not solved; at *each* booting of the computer the history of the back-and-forward buttons is gone. I did not re-install the explorer.exe because I think is not going to solve the issue with the history of the buttons.

As for the sporadic disappearance of the address bar and search box, logging off and back on from the Windows account restores the address bar and search box---that is at least faster than rebooting the computer. I've done a test by consecutively rebooting the computer 10 to 20 times after each other, without running any apps in between. In my case the disappearance of the address bar and search box is really sporadic and has nothing to do with any apps doing whatever---also the address bar and search box of the control panel window disappeared a few times.

On my Asus computer I got 2 (TWO) Windows 7 HP SP1 system partitions. My everyday work account, which is a clean install from Digital River, and another up-to-date Windows 7 partition from Asus which I call the OEM version (and full of bloatware which I never needed). The OEM I almost never use but its handy as I can boot into the OEM version and do operations on my clean installed system partition.

Now I noticed that the OEM Windows 7 version has exactly the same problem as my work Windows 7 clean installed version; that is, address bars and search boxes disappear sporadically and the history of my back-and-forward buttons is always gone too after rebooting.

I cannot get rid of the impression that the problem of the disappearing address bar and search boxes, and the loss of the history of the back-and-forward buttons has little to do with damaged ExplorerFrame.dll and Explorer.exe files, as those files are probably not damaged at all. (Note that >sfc /verifyonly did not come up with any corrupted file(s), all files were intact.) If those 2 files would've been damaged, then logging off and on, or rebooting, would not have such a healing effect on the problem, and probably the frequency with which the problem would occur, in case of damaged ExplorerFrame.dll and Explorer.exe files, would be higher than what it is now, so meaning probably more systematic than sporadic.

The only option is clean re-install I think.

j
My System SpecsSystem Spec
08 Jan 2014   #13

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

I agree, loading of the files is the issue. Almost like a webpage that only partially loads without a refresh. And odd problem when not very infrequent. You could try a repair install if the next step would be a fresh install anyway. A Guy
My System SpecsSystem Spec
.


Reply

 Address bar in Aero theme just disappers for no reason.




Thread Tools



Similar help and support threads for2: Address bar in Aero theme just disappers for no reason.
Thread Forum
Out of sudden , aero theme it switches to basic theme General Discussion
Aero Theme visually similar to Classic Theme Themes and Styles
Windows 7 Home Premium basic theme is slow but aero theme is fast? Performance & Maintenance
Aero Theme/Aero system files Crashed.. basic theme only.. plzz help.. Themes and Styles
How to place theme under the Aero theme section Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:43 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33