Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Address bar in Aero theme just disappers for no reason.


02 Jan 2014   #1

Window 7 Home Premium 64-bit
 
 
Address bar in Aero theme just disappers for no reason.

I got the Aero theme set as desktop environment on my Win7HP SP1 64-bit computer. The problem I have has nothing to do with the setting [Full file path in title bar] in Folder Options, as this is only valid for the Windows Classic theme.

In Aero, the (breadcrumbs) address bar, all together with the search box and the forward/back buttons, sporadically disappear in only ONE of the (File) Explorer windows; see attachment/snippet.

Address bar in Aero theme just disappers for no reason.-folderpathgoneinfileexplorer1.png

The other File Explorer window(s) remain(s) intact. Then again, in a few other occasions, the address bar disappeared in ALL Explorer windows; see second attachment.

Address bar in Aero theme just disappers for no reason.-folderpathgoneinfileexplorer2.png

In those cases the search box was initially present; I think I had the same problem before too with no search box at all enabled in the Explorer windows. The problem with disappearing address bars usually manifests itself right after (re)booting. However, when opening a new Explorer window, all seems OK and the address and search box are present.

Could that be a bug? What can be done about it? Sometimes I disable/re-enable the Search facility and all is back OK, but I have to say this is not a very elegant way getting the address bar back in Aero.

I ran the command >sfc /verifyonly but there are no problems with the Windows 7 system.

I've spent a lot of time already Googling the Internet, but unfortunately I haven't found any elegant solution yet.

I hope I can get the problem sorted out from your responses.

Thanks
j




My System SpecsSystem Spec
.

04 Jan 2014   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

This is not an unusual bug going way back. Usually described just as you do. I don't think I've ever seen a specific fix beyond the sfc /scannow, which obviously won't apply to you. Is this problem happening frequently enough to test via a Clean Start?

Troubleshoot Application Conflicts by Performing a Clean Startup

This would at least confirm if it is a conflict. Since it is random, and only sometimes on one of many explorer windows, it will be hard to track this down.

A Guy
My System SpecsSystem Spec
05 Jan 2014   #3

Window 7 Home Premium 64-bit
 
 

The problem with the disappearing address bars is definitely sporadic. At first sight, there is no 'easy' systematic behavior which might make it easy to analyze or debug the problem. I'm afraid you're right, it'll remain a troublesome bug where its appearance is driven by many underlying 'glitches'.

The 2 Explorer windows in my last screen shot are back normal, at the moment when writing this reply. Rebooting the computer sometimes solves the problem, but not always.

Forgot to mention earlier, in [Folder Options > View] the box [Restore previous folder windows at logon] is enabled. So at (re-)boot all my folders are restored.

The problem appears only for Explorer windows that are opened right after, or maybe during, the (re-)booting process of the computer. There are no problems for any Explorer windows being newly opened by the user or any app after the boot process has completely finished.

I cannot get rid of the impression the problem is caused during, or by, the boot process. Maybe the boot order of particular system files has something to do with it.

I was not really looking for a solution tacking the root cause of the disappearing address bars, rather I was hoping to find a bit more elegant Explorer windows 'reset' procedure, than switching off and on the Search facility or rebooting the computer all together.

I wonder if the problem still persists under Win8 or Win8.1

j
My System SpecsSystem Spec
.


05 Jan 2014   #4

Win-7 Home Prem 64-bit 7601 Free SP1
 
 

I would expect a rouge security suite or virus something is tagging windows search as a risk,
What security suite do you have installed ?
Review Jacee’s instructions to run Adwcleaner here,
Ignore the title of the thread,
Instant Savings App


You can use these free tools to see if they find anything,
Manually Update them before running full scans,
Try not to use your computer while the scans are running, (one at a time of course).
Uncheck the box to Activate the Free trial from the final install options,
http://www.malwarebytes.org/products/malwarebytes_free
http://www.superantispyware.com/?tag=SUPERANTISPYWARE
This one is the longest up to 4 hours, the others are only about 45 minutes,
http://www.microsoft.com/security/scanner/en-us/default.aspx

Post any text reports from the scanners for more suggestions,
Cheers.
My System SpecsSystem Spec
05 Jan 2014   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Well, more elgant then your methods, but will of course close all open explorer windows

Explorer - Add "Restart Explorer" to Desktop Context Menu

A Guy
My System SpecsSystem Spec
06 Jan 2014   #6

Window 7 Home Premium 64-bit
 
 

I use Norton Internet Security, latest release. Never had any problems with it. I also use CCleaner very regular to clean up all crap. I'm not sure if Windows Search has anything to do with it; I think I had the problem before with Search not at all enabled.

As for killing and restarting explorer.exe, I'll consider that option if problems start occurring again because all is OK since several days, even more than a week now.

I'll try to do the scans this eve or later.

Thanks, j
My System SpecsSystem Spec
07 Jan 2014   #7

Window 7 Home Premium 64-bit
 
 

I scanned the HDD using Instant Savings App and Malwarebytes , both said there was no malware.

SuperAntiSpyware managed to find in an old archive on the data partition (so not in the system) one file that was considered as malware named as:
Virus:Win32/Induc.A

Microsoft's Security scanner did find one piece of Adware described at:
Adware:Win32/OpenCandy

My Norton Internet Security, on the other hand, found out more than 25 tracking cookies, which are usually never a problem as I run the CCleaner very regular.

So, concluding, I think it is very unlikely that any malware is responsible for the sporadic disappearance of the address bar.

Something else I forgot to mention in my first post, is that the history of the blue-colored back-and-forth buttons in the top-left of any Explorer window disappear after (re)boot. After (re)booting the computer, the Explorer windows (including the address bar and the search box) get restored to the state as they were in previous session, except for the history of the back-and-forth buttons; those buttons are then both gray-colored. Going back to a higher level in the folder structure can only be done by clicking the appropriate level in the address bar, after which the history in the back-and-forth buttons seem to start building up again in a correct manner.

j
My System SpecsSystem Spec
07 Jan 2014   #8

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Interesting the explorerframe.dll is responsible for those buttons. I know you ran SFC, but have you tried replacing explorer.exe, or explorerframe.dll

Extract Files from Windows 7 Installation DVD

A Repair install may also fix that. I assume the /verify will show the same files as /scannow?

A Guy
My System SpecsSystem Spec
08 Jan 2014   #9

Win-7 Home Prem 64-bit 7601 Free SP1
 
 

Quote   Quote: Originally Posted by DiracDeBroglie View Post
I scanned the HDD using Instant Savings App
That's a new one ?
My System SpecsSystem Spec
08 Jan 2014   #10

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
I would expect a rouge security suite or virus something is tagging windows search as a risk,
What security suite do you have installed ?
Review Jacee’s instructions to run Adwcleaner here,
Ignore the title of the thread,
Instant Savings App


You can use these free tools to see if they find anything,
Manually Update them before running full scans,
Try not to use your computer while the scans are running, (one at a time of course).
Uncheck the box to Activate the Free trial from the final install options,
http://www.malwarebytes.org/products/malwarebytes_free
http://www.superantispyware.com/?tag=SUPERANTISPYWARE
This one is the longest up to 4 hours, the others are only about 45 minutes,
http://www.microsoft.com/security/scanner/en-us/default.aspx

Post any text reports from the scanners for more suggestions,
Cheers.
Quote   Quote: Originally Posted by ThrashZone View Post
Quote   Quote: Originally Posted by DiracDeBroglie View Post
I scanned the HDD using Instant Savings App
That's a new one ?
Possibly referring to the title of the other thread?
My System SpecsSystem Spec
Reply

 Address bar in Aero theme just disappers for no reason.




Thread Tools



Similar help and support threads for2: Address bar in Aero theme just disappers for no reason.
Thread Forum
Out of sudden , aero theme it switches to basic theme General Discussion
Aero Theme visually similar to Classic Theme Themes and Styles
Windows 7 Home Premium basic theme is slow but aero theme is fast? Performance & Maintenance
Aero Theme/Aero system files Crashed.. basic theme only.. plzz help.. Themes and Styles
How to place theme under the Aero theme section Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:21 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33