Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Black desktop icons and no "IconCache.db" in local folder?

03 Aug 2015   #1
TOOTHLESS

Windows 7 Ultimate x64
 
 
Black desktop icons and no "IconCache.db" in local folder?

EDIT:
Okay, I've solved the problem simply by creating a file named iconcache.db "using notepad" and marked it as "read only" via properties menu.


Hi all, and thanks for this site that I always use to solve my problems..

Every time I boot my computer the icons of programs and folders on desktop are black squares. After each startup I have to use a "rebuildiconcache.bat" file made by someone here to restore them -see attachment-.

When I navigate to appdata/local there is no IconCache.db "I enabled hidden files view".
I wish I could elaborate more.

could be a service that I disabled? here a list of them:



and thank you




Attached Files
File Type: bat Rebuild_Icon_Cache.bat (738 Bytes, 1 views)
My System SpecsSystem Spec
.
03 Aug 2015   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Why in the Sam Hello do you disable all those Services??

If I had to fix this computer I would do a Repair Install.
This tutorial by Brink should help.

Repair Install
My System SpecsSystem Spec
04 Aug 2015   #3
TOOTHLESS

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Why in the Sam Hello do you disable all those Services??

If I had to fix this computer I would do a Repair Install.
This tutorial by Brink should help.

Repair Install
I don't care about sharing/ /printing /remote/security services and never needed them. that's why!

Could someone help me in this matter?
My System SpecsSystem Spec
.

04 Aug 2015   #4
UsernameIssues

W7 Pro SP1 64bit
 
 

Restart your computer.

Do not run rebuildiconcache.bat

See if IconCache.db is there.
My System SpecsSystem Spec
04 Aug 2015   #5
TOOTHLESS

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Restart your computer.

Do not run rebuildiconcache.bat

See if IconCache.db is there.
yes! it's there now 've atItached it. link to file:
ClicknUpload - Easy way to share your files

also this is how my desktop looks
My System SpecsSystem Spec
04 Aug 2015   #6
UsernameIssues

W7 Pro SP1 64bit
 
 

Thanks for running that test.

I noticed that you have Windows Update service disabled. Is your computer up to date on patches? Videodrivers get updated to match changes in the operating system. You will need to keep them both updated.
My System SpecsSystem Spec
04 Aug 2015   #7
TOOTHLESS

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Thanks for running that test.

I noticed that you have Windows Update service disabled. Is your computer up to date on patches? Videodrivers get updated to match changes in the operating system. You will need to keep them both updated.
I'm on a very limited bandwidth, but the latest update was at 19th of past month, most are on the 18th of same month. So it can't be that old


I have the latest nvidia driver for windows 7. The problem happend out of nowhere.
and thanks for trying.
My System SpecsSystem Spec
04 Aug 2015   #8
UsernameIssues

W7 Pro SP1 64bit
 
 

I spent some time looking thru those disabled services and I don't see any that should impact the icons.

While the icons are black, what happens if you run just this one line from that batch file:
Code:
ie4uinit.exe -ClearIconCache
Please run it from a regular command prompt window.
Did that fix the icons?
My System SpecsSystem Spec
04 Aug 2015   #9
TOOTHLESS

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
I spent some time looking thru those disabled services and I don't see any that should impact the icons.

While the icons are black, what happens if you run just this one line from that batch file:
Code:
ie4uinit.exe -ClearIconCache
Please run it from a regular command prompt window.
Did that fix the icons?
sorry I went for meal.

It refreshed the desktop but didn't fix it. Any new shortcut I made is not affected I forgot to mention that.
My System SpecsSystem Spec
04 Aug 2015   #10
UsernameIssues

W7 Pro SP1 64bit
 
 

I'm not sure hot to find what is corrupting the Icon Cache database file.

As best I can tell, Explorer writes info to that database when Windows closes Explorer (like for a restart). Perhaps at other times too.

Do the icons mess up if the OS Theme is classic?

Have you tried uninstalling as much of the Nvidia software as possible (e.g. 3D stuff)?
My System SpecsSystem Spec
Reply

 Black desktop icons and no "IconCache.db" in local folder?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
"Local Disk" folder in Music Library
If I go to the music library, then Sample Music, which has 3 sample files, it also has a folder named local disk. Its empty, but right clicking and viewing properties shows it has 3 files and 4 folders, and is 400 bytes in size. It was created during the OSs install date, and is shared. ...
General Discussion
What is this folder - "Apps" in appdata/local/
This folder was created a little over two weeks ago. The folder extends this far, with no folders having any files. Appdata/local/Apps/2.0/NN3MAOW.TB8/OTAHHLPM.5KM/manifests All the sub folders were created at the same time. What causes these folders to created? I read that its something...
General Discussion
Duplicate "local" folder in "AppData"
After Avast did a full scan it listed some files it could not find. They were in the /appdata/local/opera mail/opera mail folder/ So I went to check and found 2 identical "Local" folders. I have a full backup copy of the hard drive which is only a month old and it has only 1 local folder. ...
General Discussion
""Local Area Connection" Doesn't have a valid ip config "
i Recently bought and hp windows 7 computer 64 bit and it was fine but two weeks later it does this it was working few hour ago and now it saids this ""Local Area Connection" Doesn't have a valid ip config" what does that mean? i couldnt fix it, i turned off the router, modem did a pc recovery...
Network & Sharing
[HELP] Red "x" on disk icons, desktop icons changed!
Hey, guys. Finally I have found the place where my problem might get solved. Thing is: 1.There is a big "X" on 3 out of 4 disks I got(except "C" disk) as shown in the picture below: http://i42.tinypic.com/15fssas.jpg 2.Desktop icons are changed as well but not all of them.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App