Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't install Ricoh FW chipset drivers.


24 Sep 2010   #1

Windows 7 32bit RC
 
 
Can't install Ricoh FW chipset drivers.

Don't know what's going on! The IEEE 1394 controller has an ! in device manager and windows can't find drivers for it. I can't find the legacy drivers either so i'm completely stuck.

Just bought a firewire soundcard and was hoping to use this 'til i get an expresscard but i'm completely stumped. I have the correct driver on my resources cd and have installed it but nothing has changed. Could it be a fault or something i've disabled (it's enabled in the bios)? Really have no idea what to do here. I may have to install Vista!

I'm on a Dell XPS M1330 running Windows 7 Ultimate.. Where on earth can i find the legacy driver???

RT

My System SpecsSystem Spec
.

24 Sep 2010   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by RoverT View Post
Don't know what's going on! The IEEE 1394 controller has an ! in device manager and windows can't find drivers for it. I can't find the legacy drivers either so i'm completely stuck.

Just bought a firewire soundcard and was hoping to use this 'til i get an expresscard but i'm completely stumped. I have the correct driver on my resources cd and have installed it but nothing has changed. Could it be a fault or something i've disabled (it's enabled in the bios)? Really have no idea what to do here. I may have to install Vista!

I'm on a Dell XPS M1330 running Windows 7 Ultimate.. Where on earth can i find the legacy driver???

RT
Hi RoverT download the vista driver Drivers & Downloads and install in compat mode Compatibility Mode
My System SpecsSystem Spec
24 Sep 2010   #3

Windows 7 32bit RC
 
 

Hi pebbly. Tried it but no difference. The drivers install but the device properties tells me no drivers are installed for that device! That makes no sense at all. Seems like something's missing from the equation and i don't know what it is.

It's the first time i've used firewire on this laptop, maybe there's a fault with it. I've read a few accounts of people having problems with firewire on windows 7, could that be what's happening here?

And why is it so hard to find the legacy drivers for windows 7?
My System SpecsSystem Spec
.


24 Sep 2010   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by RoverT View Post
Hi pebbly. Tried it but no difference. The drivers install but the device properties tells me no drivers are installed for that device! That makes no sense at all. Seems like something's missing from the equation and i don't know what it is.

It's the first time i've used firewire on this laptop, maybe there's a fault with it. I've read a few accounts of people having problems with firewire on windows 7, could that be what's happening here?

And why is it so hard to find the legacy drivers for windows 7?
Unfortunately Dell don't update the drivers frequently , I will do a search for you on Dells support site to see if I can find any information for you
My System SpecsSystem Spec
24 Sep 2010   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Have you tried installing the driver manually by pointing the device to the driver files in Device Manager? Try that.

Another thing you can try is to uninstall the device in device manager, then reboot, Windows 7 should find and install the driver for you.
My System SpecsSystem Spec
24 Sep 2010   #6

Windows 7 32bit RC
 
 

I tihnk the legacy driver is from microsoft. I've googled every possble variation i can think of and searched the microsoft website (where you think they'd be!) but nothing. This is what i'm talking about: Konnekt / Impact Twin in Windows 7

The legacy driver is not on my system, or at least i can't find it. Windows, for some reason, cannot recognise the firewire port. What a palava! Should have stuck with USB! Actually, it's quite a good interface and fortunately runs as a standalone preamp so i can just route the audio from my laptops onboard audio until i figure this out.
My System SpecsSystem Spec
24 Sep 2010   #7

Windows 7 32bit RC
 
 

Quote   Quote: Originally Posted by Bill2 View Post
Have you tried installing the driver manually by pointing the device to the driver files in Device Manager? Try that.

Another thing you can try is to uninstall the device in device manager, then reboot, Windows 7 should find and install the driver for you.
No but i just did and was informed that windows could not find drivers for my device! They are the latest ricoh chipset drivers but they are from '07.

I tried uninstalling and rebooting also but to no avail. I think the legacy firewire driver will work if i could just find it. It must be available to download somewhere...
My System SpecsSystem Spec
25 Sep 2010   #8

Windows 7 32bit RC
 
 

Anyone know where i can find these legacy drivers? Or where the actual driver would be on my hd?
My System SpecsSystem Spec
25 Sep 2010   #9

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

RoverT try re installing the chipset driver, the IEEE1394 driver is usually contained in the Ricoh driver ,but sometimes it is in the chipset driver !
My System SpecsSystem Spec
25 Sep 2010   #10

Windows 7 32bit RC
 
 

Quote   Quote: Originally Posted by pebbly View Post
RoverT try re installing the chipset driver, the IEEE1394 driver is usually contained in the Ricoh driver ,but sometimes it is in the chipset driver !
I actually ran a Windows 7 upgrade repair last night thinking that i may have disabled something or an update i installed had somehow caused this. I reinstalled the chipset drivers and ricoh drivers last night but it's still got a yellow mark next to it!

From what i've read the legacy driver is something that comes with windows. I can't understand why it's so hard to find it. It must be available somewhere! I'm sure that will give me a working firewire port until i get a bus card.
My System SpecsSystem Spec
Reply

 Can't install Ricoh FW chipset drivers.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:02 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33