Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LAN driver issue...


30 Sep 2010   #1

Windows 7 Ultimate x86
 
 
LAN driver issue...

For some reason, every time I unplug/plug in an Ethernet cable to my laptop, I have to reinstall my Realtek LAN driver in order for my computer to recognize being plugged in and connect to the wired network. Any ideas on why this may be? I'm doing some research on it and I'm not finding anything useful. It's not hardware-related either, as on my home network, wireless gives me a 300kb/sec download and wired gives me a 500kb/sec. That tells me the hardware is working fine. There is a chance it could just be my OS. There are many odd things that happen with my OS (another reason why one of these days I'm switching it back to 7 Ultimate, or switching to another 3rd party variation I've been testing in a VM) and I'm just not sure if it's that, or something else. I'm thinking it's OS-related though.


My System SpecsSystem Spec
.

01 Oct 2010   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Considering you are running a hacked and slashed version of 7 (won't bother with the legalities of such), I would install a clean, legit and untouched copy before even trying to diagnose it any further.
My System SpecsSystem Spec
01 Oct 2010   #3

Windows 7 Ultimate x86
 
 

For the record, I did purchase a genuine serial from Microsoft.

But okay.
My System SpecsSystem Spec
.


01 Oct 2010   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by Benjamin Hall View Post
For the record, I did purchase a genuine serial from Microsoft.

But okay.
Hi Benjamin , As stormy13 states running a hacked version of any operating system causes too many problems that make it look as though Microsoft are supplying faulty software that is one reason this forum does not support that type of installation, Even thopugh you bought a key off Microsoft, it will not magically create a silk purse out of a sow's ear
follow stormy's advice and install a genuine ,non hacked version of the OS
My System SpecsSystem Spec
01 Oct 2010   #5

Windows 7 Ultimate x86
 
 

Okay Lol, I can do that. I'm gonna lose a LOT of mods, but I suppose I can always make them again.

*searches* now where did I put that 7 Ultimate disc??? *finds it* Oh cool!
*wonders* Can I transfer my genuine activation from my current OS back onto Ultimate? (my activation is for Ultimate anyway)
My System SpecsSystem Spec
04 Oct 2010   #6

Windows 7 Ultimate x86
 
 

Not to bump the thread or anything, but...
I took your advice and reinstalled Windows 7 Ultimate, and I'm still having the exact same issue with my LAN driver. Every time I plug in an Ethernet cable, I have to reinstall the driver.
My System SpecsSystem Spec
04 Oct 2010   #7

Dual Booting Windows 7 64-Bit Ultimate Edition and Fedora 16.
 
 

Quote   Quote: Originally Posted by Benjamin Hall View Post
Not to bump the thread or anything, but...
I took your advice and reinstalled Windows 7 Ultimate, and I'm still having the exact same issue with my LAN driver. Every time I plug in an Ethernet cable, I have to reinstall the driver.
Hi BH,

I had the problem once i figured that it is a temporary thing.
Goto>Device Manager>Network Adapter>Enable it(If it is Disabled) else Disable it and then Enable it again.
This worked for me
You dont have to reinstall the driver at least.

Also do you have the latest drivers after i updated my drivers i didnt have any problem.


YBL.
My System SpecsSystem Spec
04 Oct 2010   #8

Windows 7 Ultimate x86
 
 

It is enabled, and my drivers are all up to date. Thanks for the attempt though
My System SpecsSystem Spec
05 Oct 2010   #9
Microsoft MVP

Win 7 Ultimate x64
 
 

Seeing as it is the only non-wireless driver shown on HP's download page for your laptop,

Software & Driver Downloads HP Pavilion dv4i-2100 CTO Entertainment Notebook PC - HP Customer Care (United States - English)

I'll assume that it is the Realtek driver that is causing the problem. If so have you tried the latest GBE driver directly from Realtek (which is almost a year newer than the one from HP)? If not and to make it a little easier than searching and getting it from Realtek (not necessarily the most user friendly site, not too mention slower than molasses most of the time) here it is,

Driver_WIN7_7026_09212010.zip


My System SpecsSystem Spec
05 Oct 2010   #10

Windows 7 Ultimate x86
 
 

Ahh, thank you very much! I will certainly give this a try.
My System SpecsSystem Spec
Reply

 LAN driver issue...




Thread Tools



Similar help and support threads for2: LAN driver issue...
Thread Forum
driver issue Drivers
Win 7 HP Driver issue HELP! Drivers
Can anyone help with this driver issue? Drivers
Driver issue ? Graphic Cards
8800GT Driver issue? Or maybe its a bios issue. Drivers
USB DAC issue - bad driver? Drivers
Please help with driver and RAM issue Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:46 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33