Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X1950 working driver

13 Jul 2009   #11
Corpsecrank

Win7 64bit Ultimate
 
 

I ended up finding some x1950gt pcie catalyst 9.3 drivers on the sapphire page. Win7 compatible.

Here are some links:

x86: http://us.sapphiretech.com/driver/508.zip
x64: http://us.sapphiretech.com/driver/509.zip


My System SpecsSystem Spec
.

13 Jul 2009   #12
Danilo

Windows 7 RTM
 
 

Thanks! I will try them to see if they work...
My System SpecsSystem Spec
14 Jul 2009   #13
Corpsecrank

Win7 64bit Ultimate
 
 

Quote   Quote: Originally Posted by Danilo View Post
Thanks! I will try them to see if they work...
I am using them right now actually in RC1 7100 they are working great for me.
My System SpecsSystem Spec
.


14 Jul 2009   #14
BuKoHm

Win7 7100 64bit
 
 

hi, maybe it's a bit unrelated, but i need some kind of software to control the fan speed for my 1950pro radeon card... smart doctor worked fine in winXP, but in win7 it misses some kind of dll, i tried to find it n internet and install it, but windows started to complain that it is not compatible with win7.

ps. i don't need to actually control the speed, just put it at max, because it's summer atm and any game i play shuts down PS after like 5 mins. i just opened the case and put a big fan in there (it was supposed to cool me not my VGA) and it kinda helped, but PC still turnes off after a while.
My System SpecsSystem Spec
15 Jul 2009   #15
Corpsecrank

Win7 64bit Ultimate
 
 

RivaTuner 2.24 is what I use to overclock my 1950 gt and it has a fan control panel for adjusting fan performance. It works in RC1 7100 and should work great for your 1950 pro.

On a side note you should try to get some type of case setup for your computer with a side fan directly over the card bringing air in on the card or a slot mount cooler that helps drag hot air off of the card and directly out the back of the case. Either solution would help a lot.

If you have any unused fan slots such as an open area in the back of the case where a fan could be mounted or one in the front make sure to put a fan in that fits the maximum size the case can fit for that slot. It sounds to me like your not getting good airflow. You want air coming in from any slot you can force it in through except for the rear of the case which should be forcing air out.

The object is to keep air coming in from the sides and front and out through the top and back no matter what your case may be. And always use as many fans as the case has mounts for. The mounts were put there on the case for a reason so take advantage of them when you can.
My System SpecsSystem Spec
15 Jul 2009   #16
akash3656

Windows 7 32-bit; no 64 coz its a P4 478
 
 

Yo, guys, for me 9.1 works 9.2 doesn't but who cares coz i dl-ed the official latest "VISTA" Driver from ATI's site... (um, now AMD's site?) (damn cant help but say ATI)!!
The latest version is 9.3.1
I dunno whats changed from 9.3 coz the changelog still points to the 9.3 URL...
But anyways, I downloaded it, ran it IN win 7 7260, custom, DAMN no entry for display driver!!!

So I went to 'C:\ATI\......\....' bla bla bl till i found setup.exe; right click it, properties, compability mode, VISTA SP1 (used SP1 coz i didnt use Vista SP2 in my life with ATI drivers...)... Ran setup (the 1 i compability mod-ed). CUSTOM, BINGO, NOW I CAN INSTAL DISPLAY DRIVER+CCC [usefull for me ONLY WHEN connecting my TV... (though i rarely hook the TV; i need that functionality for movies)]

PS: My specs.... I should be ashamed telling you guys my specs:
Pentium 4 HT 3.0 GHZ
1GB DDR 400
MSI PM8M-V (Via chipset)
HIS ATI X1650 AGP
My System SpecsSystem Spec
15 Jul 2009   #17
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Yeah, I'm running an ATI X1600 and saw that driver update too.

From their site, it looks like the only component that has changed is the WDM stuff -- for TV usage. Since I'm no doing that, I haven't upgraded the drivers.
My System SpecsSystem Spec
15 Jul 2009   #18
BuKoHm

Win7 7100 64bit
 
 

to akash3656:

i downloaded the rivatuner of specified version, but have no idea how to set up dan speed. the "power user" tab is too confusing for me. i will be happy if i just put in on maximum.

ps. i just opened the case and put a bib fan in there, so should be good enough air flow. besides that, i have one fan in front, one on sade (well a little bit higher then VGA), one on VGS, one on CPU and one blowing out near power block, and one in power block itself. i (mostly, especially after buying a better power block) had no problems with VGA on winXP when i used SmartDoctor.
My System SpecsSystem Spec
15 Jul 2009   #19
Corpsecrank

Win7 64bit Ultimate
 
 

Quote   Quote: Originally Posted by BuKoHm View Post
to akash3656:

i downloaded the rivatuner of specified version, but have no idea how to set up dan speed. the "power user" tab is too confusing for me. i will be happy if i just put in on maximum.
Stay out of the power user tab you could cause damage changing settings if you are not experienced in this type of thing.

What you need to look for is the following little tab in the general section of the program.



Clicking the tab brings up another selection with "Low-level system settings" which is where you will find your fan controls to crank the fan speed to the desired amount. This is done as follows:

[IMG]file:///C:/Users/CORPSE%7E1/AppData/Local/Temp/moz-screenshot.png[/IMG][IMG]file:///C:/Users/CORPSE%7E1/AppData/Local/Temp/moz-screenshot-1.png[/IMG][IMG]file:///C:/Users/CORPSE%7E1/AppData/Local/Temp/moz-screenshot-2.png[/IMG]



Once this is done your fan will be set to maximum speed and you should be fine.
My System SpecsSystem Spec
16 Jul 2009   #20
Nauscar

Windows 7RC (Build 7100) 32-bit
 
 

I have a PCI-E problem with my Radeon X1300. I have posted a forum here: Windows 7 & ATI Radeon X1300
So far even 9.1 has failed for my situation..
My System SpecsSystem Spec
Reply

 X1950 working driver




Thread Tools





Similar help and support threads
Thread Forum
m17x R3 6970m driver. Whats best working ccc driver for switchable gr.
i have a m17x r3 having trouble keeping the switchable graphics working. specs: m17x r3 proc. 2630qm gpu: 6970m with switchable intel graphics screen: 1920 by 1080 non 3-d hard drives: kingston hyperx ssd os / stock 750bg dell harddrive as second. but have the ssd in the second slot and...
Drivers
ATI Radeon x1950 pro Windows 7 Driver?
Hi, I seem to be having issues with my display driver. The default one that installed when I installed Win7 was causing graphics glitches, and when I visit AMD and install this driver: ATI Catalyst software applications tell me that my driver is out of date and to update via that site. The...
Drivers
Windows 7 & x1950 problems!
Hi all! Had this problem for ages and never got round to posting for help, but cannot for the life of me figure it out so hopefully one of you guys can! My x1950 was working fine with Win7 upto a month (or more?) ago, when the system refused to boot into the OS. After...
Graphic Cards
x1950 agp, nforce3, x2 athlon 4000 -problem
http://i42.tinypic.com/1yajib.jpg
Graphic Cards
ATI radeon x1950 (agp) problem
Hi ! I have installed Windows 7 and everything was fine, but it says that my graphics card does not support 3d hardware acceleration. I downloaded drivers for Vista (because there is no drivers of my graphics card for Windows7) from official ati site and installed them but I always get an error...
Drivers
ATI Radeon x1950 - ATI has dropped the support
Hi all, As we had read in this forum, ATI has dropped the support for the DirectX 9 graphic cards like mine, the Radeon X1950. This means no working Windows 7 drivers and no longer support for OpenSuse! I had installed the Catalyst x64 drivers 9.1 on Win7 RC x64 but the driver is quite...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App