Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ati x1600 drivers not working on Windws 7

04 Jun 2009   #1
crys18

Windows 7
 
 
Ati x1600 drivers not working on Windws 7 - Solved

Code:
I tested al new driver from ati site but none worked on my x1600 512 mb
It failed to install the video driver.
Only one that worked was 9-1_vista32_dd_ccc_wdm_enu_74233 but has a  few bugs:(
Any other solution?
Solved with 9.8 version driver !


My System SpecsSystem Spec
.
04 Jun 2009   #2
bansh

Windows 7 Professional x64 (Build 7600)
 
 

More details please?

What happens exactly? You get an error message?
My System SpecsSystem Spec
04 Jun 2009   #3
crys18

Windows 7
 
 

Don't remember exactly the error but after Drivers installs along with catalyst center at finish it says installation ok but some error ocured.
i just installed 9.1 and is not working very well.
My System SpecsSystem Spec
.

04 Jun 2009   #4
anthonyvigh

Windows 7 RC build 7100
 
 
drivers

dont use windows 7 drivers at this stage, best to manually download ati drivers for vista from ati official website and use them, I had similar problems reverted back to old vista drivers everything works perfectly on 7 now
My System SpecsSystem Spec
28 Jun 2009   #5
dgood

Windows 7 64bit
 
 

I am using windows 7 64 bit RC1 and have an X1600Xt and the built in windows driver causes the computer to run so so slow like everything is lagging. if I use the driver for standard vga adapter however it works fine. If I try to use the drivers it gives me from ATI.com it gives me drivers for HD2000 and above even when I tell it to give me x1600 drivers. if I use older vista x64 drivers or XP x64 drivers they either don't install or have the same sluggish effect. I know the graphics card is good and works fine in windows xp and vista. Why is it the driver system for this card is broken in windows 7 x64? also I have not tested it in 32bit windows 7 but seriously why do they still make 32 bit operating systems.
My System SpecsSystem Spec
28 Jun 2009   #6
screwballl

Win7, XP, Vista x64, Ubuntu 9.04
 
 

question... is this a AGP based video card? if so then I found that you will be out of luck for the most part due tot he structure that the 3rd party companies started using the PCI-to-AGP bridge chip on the X1000 series ATI cards. Most of the time, the only way to find a proper driver is to try either manufacturer of the card itself, or I found VisionTek's drivers work well for almost any card... but since they tend to be 2000/XP only, or maybe include Vista, W7 support will be next to none until the individual companies update their drivers officially.
My System SpecsSystem Spec
28 Jun 2009   #7
dgood

Windows 7 64bit
 
 

PCI-E Card from Gigabyte (Silent Pipe II) was mine I do not know the card the original poster had. I just wanted to add that I have an issue with X1600 Series drivers in windows 7 also. I am going to try gigabyte x64 drivers tomorrow.
My System SpecsSystem Spec
29 Jun 2009   #8
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

As previously reported here, AMD/ATI has dropped support for the older videocards, of which yours (and mine, too, since I'm using the same card) is one of those affected. Should work with Catalyst drivers up through 9.3. But, 9.4 and newer are only for the newer "HD" cards.

I've heard a rumour that v9.7 is going to include support for the older cards, but until that comes out, can't confirm it.
My System SpecsSystem Spec
03 Nov 2009   #9
crys18

Windows 7
 
 

The newer version 9.8 worked well on my x1600 512 mb for Windows 7 ultimate x86 RTM
My System SpecsSystem Spec
13 Nov 2009   #10
mtcjustin

Windows 7
 
 

I am having some of the same problems. I have an X1600 and i tried downloading the latest drivers. I went through the entire installation, and at the end it said it was completed successfully. But the driver version did not change. I tried uninstalling the old driver so that i could start fresh. But now in the device manager it doesnt list the card as an X1600 anymore, it says "Standard VGA Graphics Adapter" and it will not let me update the driver manually, it just says "The best driver software for your is already installed."
My System SpecsSystem Spec
Reply

 Ati x1600 drivers not working on Windws 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Need help with CatalystATI Mobility Radeon X1600 drivers
i have an hP compaq nc8430 which had windows 7 installed onto it and everything deleted from it. i tried installing ATI catalyst and it didn't install, i had to go into ATI\Support and install each msi individually. I right click on the desktop and the 'ATI CATALYST' tab is on, when i click it on...
Graphic Cards
Help. windws explorer keeps on crashing
Windows explorer keeps on crashing and i can't find the cause of it. I tried to do a system restore and for some days the problem was gone, but then it came back again. Please, can anybody help me with this problem. Here I have the logfile of HijackThis. Logfile of Trend Micro HijackThis...
BSOD Help and Support
ATI Radeon x1600 (x1650) series
so i just wanted to know is it x1600 or x1650... and what kind of cooling is it? bad quality pics i know, but should be clear enough to tell whats on the pic. EDIT: gonna put better pics when i get my cam back (these ones are made with SE G502)
Graphic Cards
ATI X1600 drivers
Hi, I'm not the most technical person in the world so you'll have to bear with me. I've recently upgraded my desktop PC from XP to Windows 7. I have an ATI radeon x1600 card which always worked fine. Whenever I try to load and run games, everything works ok for about 5 mins. After that, the...
Graphic Cards
ATI mobility x1600
When I installed Windows 7 it installed driver version 8.333.0.0. I tried installing the new 9.3 Catalyst drivers. When I run the install it goes through and says that it installed successfully. But I can find no new drivers installed, and no catalyst program either. I have tried uninstalling...
Graphic Cards
Windws 7 32 bit or 64 bit
I have a dell inspiron 1545 dual core 2.1ghz - 4gb ram - intel gma 4500mhd laptop. Should I install windows 7 32 bit or 64 bit considering how powerful it is and which one would perform best? p.s. I have windows vista and windows 7 32-bit installed on different partitions but since the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App