Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics Card Showing up as "Unknown Device"


30 Oct 2010   #1

Windows 7 Enterprise 32bit
 
 
Graphics Card Showing up as "Unknown Device"

My ATI Mobility Radeon 9600 is showing up as a unknown device in device manager and i can't install the driver because it wont install a standard VGA driver



Attached Thumbnails
Graphics Card Showing up as "Unknown Device"-unknow-device.png   Graphics Card Showing up as "Unknown Device"-unknown-device.png  
My System SpecsSystem Spec
.

30 Oct 2010   #2

 
 

Hi, welcome to the forums

Are you sure it's a 9600 GFX card? The ATI/AMD site has no mention of anything above the 5xxx series of Mobility drivers?

It seems all info I find on the 9600 relates to XP as the latest OS for it, how old is the machine?


OS
My System SpecsSystem Spec
30 Oct 2010   #3

 
 

You may want to try downloading the drivers from Here and running them in Compatibility Mode for XP
My System SpecsSystem Spec
.


30 Oct 2010   #4

Windows 7 Enterprise 32bit
 
 

Thanks But im have tryed that it comes up with a error saying that "There is no VGA driver installed" and i am dual booting with XP and the driver works with that
My System SpecsSystem Spec
30 Oct 2010   #5

Windows 7 Enterprise 32bit
 
 

The Computer is about 5 or 6 years and its a HP Compaq nc8000
Dual Booting Windows 7 Enterprise x86 and Windows XP Professional
My System SpecsSystem Spec
30 Oct 2010   #6

Windows 7 Enterprise 32bit
 
 

Thanks, Managed to fix problem but i needed to reinstall Windows 7 .
My System SpecsSystem Spec
31 Oct 2010   #7

 
 

Quote   Quote: Originally Posted by griyt View Post
Thanks, Managed to fix problem but i needed to reinstall Windows 7 .
Glad you got it working
My System SpecsSystem Spec
Reply

 Graphics Card Showing up as "Unknown Device"




Thread Tools



Similar help and support threads for: Graphics Card Showing up as "Unknown Device"
Thread Forum
Solved Unknown router showing under "Network Infrastructure" Network & Sharing
Solved ASUS GT240 graphics card "ERROR CAN NOT FIND GRAPHICS CARD" Graphic Cards
New Build Vid Card showing as "Standard VGA Graphics Adapter" Graphic Cards
Built-In Webcam Not Working - "Unknown Device" USB Code 43 Hardware & Devices
Random BSOD, "Unknown Device" error in perfmon BSOD Help and Support
Saitek X45 "Unknown device" when plugging in. Windows 7x64 Hardware & Devices
Solved Some programs on start menu showing the "unknown" icon General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:01 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33