Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows can't install any keyboard/mouse

01 Nov 2010   #1

Windows 7 Ultimate x64
 
 
Windows can't install any keyboard/mouse

My desktop is running Win 7 Ult x64, and I had Logitech SetPoint 4.80 for my wireless DiNovo Edge. I recently tried to upgrade from SetPoint 4.80 to 6.15, but ran into some major issues. After downloading and installing, SetPoint didn't recognize my keyboard or mouse, which the previous version recognized just fine, though the keyboard still worked in Windows. I decided to try and uninstall SetPoint, then do a clean install, however, SetPoint wouldn't uninstall (I went to Programs & Features, clicked uninstall, nothing happened; tried manually running the uninstall program, again it did nothing). I performed a System Restore to before I installed 6.15, but SetPoint seemed completely broken then and wouldn't even run. I was able to uninstall it, however.

Now, Windows is unable to use any keyboard or mouse (logitech or otherwise). Windows will detect it when plugged into the USB port, but when it tries to install the drivers, it fails. It says "Searching preconfigured driver folder" for about ten minutes, then just says failed. Device manager shows any keyboard or mouse as "Unknown Device". At this point, SetPoint is unisntalled, so Windows should just be able to use the default generic drivers, but seems unable to do even that, meaning I can't connect any new keyboard or mouse to my computer (I seem to have gotten lucky with one small, cheap USB mouse that was already plugged in, as it works despite Windows saying it has no driver installed, so I'm using that w/ the On-Screen Keyboard right now to use the comptuer!). I've tried using CCleaner to clean out any left over registry entries from SetPoint, but that didn't help. I also can't manually choose the generic keyboard driver in the Update Driver Wizard, because I'll get an error that says "The system cannot find the file specified". Can anyone suggest a solution to this problem?

I know reinstalling SetPoint might fix it, and I have the disks, so that's not an issue, but since it's not just Logitech hardware that's not working properly, it seems to me that its indicative of a larger issue in windows that SetPoint left behind, so I'd prefer to get that fixed first. I've searched high and low with Google, but can't seem to find anybody that's had a similar issue before, or at least that has a solution to it.

Thanks for the help, and sorry for such a long post!


My System SpecsSystem Spec
.

01 Nov 2010   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

My System SpecsSystem Spec
Reply

 Windows can't install any keyboard/mouse




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33