Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trouble installing ATI drivers

21 Nov 2010   #31

Windows 7

Quote   Quote: Originally Posted by Fumz View Post
Quote   Quote: Originally Posted by Fatbob View Post
Yes I'm curious as well.

As for the Windows update, can't you simply download the latest and point Windows update to it as opposed to it going online looking for the latest drivers? I tried doing that but in this case the one online was the same as the one I pointed it to.
Windows Update doesn't work that way. You can do that with the device manager, but not WU.
My apologies, I wrote Windows Update when in fact I used the device manager to install the new driver.

My System SpecsSystem Spec
28 Nov 2010   #32

Windows 7 64Bit

Ok I'm having similar problems and having used windows update it claims to have installed the latest version fo teh driver for my HD5700 but device manager says it's like version 8.791.0.0 when it should be 10 shouldn't it? I know the versions often don't correlate but it's still concerning.

Anyway even trying to revert to the previous v10.10 failed. Something is different...

Anyone know of an update which was applied within the last week which would cause this?

Oh and I've tried the whole compatibility route. It suggested running as XP SP2 and that failed too. I'm wondering if AMD has screwed with their installer and have retroactively changed their driver history to use the new installer. Far fetched but matches the problem.
My System SpecsSystem Spec
28 Nov 2010   #33
Microsoft MVP

Win 7 Ultimate x64

device manager says it's like version 8.791.0.0 when it should be 10 shouldn't it?
Catalyst version and driver or packager version are always different. This is for the 10.10,

Trouble installing ATI drivers-cat1010.png

which if you go by the package version (which is what you posted) I believe you have the 10.11. If you didn't download it directly from AMD then you got the one that came out through Windows Update a week or two ago. If you did get the WU one then to uninstall it check the installed updates in windows Update instead of Programs and Features. If you can't find it or it won't uninstall then do a system restore to before it was updated (that driver showed up on or around the 12th).

Once you get back to the 10.10 or whatever it was you had previously, only ever get driver updates for your video card from AMD and never through WU. Check this thread every once in a while,

if you want to keep the driver up to date as someone always posts when the new one comes out .

My System SpecsSystem Spec

28 Nov 2010   #34

Windows 7 64Bit

Quote   Quote: Originally Posted by stormy13 View Post
Once you get back to the 10.10 or whatever it was you had previously, only ever get driver updates for your video card from AMD and never through WU.
Thanks for the driver version info, nice to know it's not reverted to an ancient driver, but you've hit the problem right there. The damn thing won't install the AMD drivers. It keeps stopping just after you select install driver. Even the old driver which previously successfully installed does it now.

I'dmlove to only install drivers from AMD but it's just not playing ball right now.
My System SpecsSystem Spec
18 Aug 2011   #35
Ahmed Fathi

Windows 7 Ultimate x64

I've the same problem when i tried to install the new driver -11.8- for my HD 6850, and i tried to install the previous -11.7- which i had install One week ago and it doesn't work with me too, WU gave me version 8.850.0.0 ,
There any solutions?
My System SpecsSystem Spec

 Trouble installing ATI drivers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Having trouble installing any and all Nvidia drivers.
I've seen this problem all over the internet, and after a day or two of following every step I've seen on this forum and others, I'm still standing at a giant brick wall. Here's my problem. Yesterday I went to the nvidia website and did a scan for a graphics driver update on my integrated Geforce...
Graphic Cards
Trouble installing gaming receiver drivers
As stated in the title I can't find the gaming receiver drivers, they are NOT in windows controllers class all that's there is the 360 controller driver, which doesn't work when downloaded I NEED THE RECEIVER DRIVER and it does not show up, contacted Microsoft and received the "sure we'll fix it...
Anyone having trouble with the new AMD drivers
I have a Gigabyte 6950 which ran exceptionally well with the 11.11 drivers. After installing the 11.12 drivers I have some problems with the graphics not showing right in places and the screen jerking in certain games. Battlefield 3 when in the helicopter the screen was like showing every 3rd...
Graphic Cards
Trouble installing Win 7 x64 on Aspire 4750G - No Device Drivers Found
I recently bought an Acer Aspire 4750G with no Windows pre-installed (i.e DOS). I downloaded Windows 7 x64 Professional Edition .iso from the official MSDNAA website. I used Windows 7 USB/DVD Download Tool (run on Windows XP SP3) to create a bootable USB flashdisk (Sandisk Cruzer Blade 8.0GB)....
Installation & Setup
trouble installing drivers
I'm trying to install a drive so that i can use an FTDI made cable that converts a TTL data port to a RS232 data. But i've run into trouble. when i install it it comes up in my hardware manager as a Com3 which is good but I'm lacking a com1 and an LPT1 which i assume i need. The FTDI guys say i...
trouble installing drivers
I recently bought an Nvidia 7200 GS graphics card for my computer, but it is causing problems. I plugged in the card and booted up, and it somehow found a driver for it (maybe on the driver cd I had inserted). I then enjoyed 20 minutes of dual monitors, but then I had to restart the computer. Ever...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:24.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App