Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Leadtek Winfast DTV2000H, works in 7100 but not 7201

03 Dec 2009   #11

windows 7

Thanks alexb411 - after weeks of trying to find a driver and almost going back to xp you have saved me a lot of time and frustration. THANK YOU - your tip worked!!!!!!

My System SpecsSystem Spec
06 Dec 2009   #12

windows 7 home premium 64-bit

no problem ^^ glad to help
My System SpecsSystem Spec
21 Jan 2010   #13

Windows 7 Home Premium 64 Bit
Didn't work for me...

I had the DTV2000H working ok on the Win 7 RTM version - never had any issue. Yesterday I installed Win 7 Home Premium and got the same block as others report. I did the download from the Taiwanese site described OK. But when trying to load the new driver my PC froze and wouldn't reboot. Had to use F8 on reboot and use the Win 7 rescue protocol. The new drivers hadn't loaded and the Leadtek board remains unusable. Damn.
My System SpecsSystem Spec

29 Jan 2010   #14

Win 7 32bit

Problem Solved guys. The solution is here.
My System SpecsSystem Spec
15 Sep 2010   #15


Quote   Quote: Originally Posted by alexb411 View Post
eyz i found out how to make it work, and im using windows 7 home premium 64-bit..

Heres how to get it to work perfectly for Win 7 64 bit, download this driver:
After that, extract that file. You will get a "Windows7_Build7232" folder.
Now go right click "My Computer" and select "Properties".
Select "Device Manager" and under "Sound, Video and game controllers" right click "Winfast DTV 2000H" and then select "Properties"
Go to "Driver" tab and then select "Update Driver" and then "Browse my computer for driver software"
Select "Let me pick from a list of device drivers on my computer" and then select "Have disk"
Browse for the "Windows7_Build7232" folder, and then select the file in that folder (sorry i cant remember which file to select out of the 2 files).
(!!!NOTE!!! should probably restart the PC before you try the tv tuner out)

this worked for me and i think you have to install winfast pvr2 in the x86 folder.. i hope this helps
Errr... This only works if the card shows up in the device manager in the first place. For me, I can't even get it there, even with the drivers you suggest. The card was not detected during the windows install

Any other ideas?
My System SpecsSystem Spec
15 Sep 2010   #16

Windows 7 Home Premium x64

Yanta, open the case and check if the card is properly placed. Maybe it budged a bit when you were cleaning or something.
My System SpecsSystem Spec
16 Sep 2010   #17


Quote   Quote: Originally Posted by Gornot View Post
Yanta, open the case and check if the card is properly placed. Maybe it budged a bit when you were cleaning or something.
Me not that silly.

I tried the card in an XP machine, works no probs. Put it back in the Win7 machine (in different PCI slot for luck), still no go...

But... I found the DTV Gold Dongle.. $33 each, USB and works like a charm. SO I'think it's time to eBay the old DTV2000H card... Maybe it has value as an antique
My System SpecsSystem Spec
30 Sep 2010   #18

win 7 32bit
Cannot found Digital channels

i ve used the drivers and the alalog channels are perfect . Unfortunatelly i m not able to tune digital channels , any help?

thank you for your support
My System SpecsSystem Spec

 Leadtek Winfast DTV2000H, works in 7100 but not 7201

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Leadtek WinFast TV 2000 XP (Deluxe), Windows 7 Pro 64 B
Hello everyone and thanks to take a little of your time ;) First, please excuse for my english i'm french but i will try to explain the best i can. I know there are already few subjects on this problem and i read them all in fact i read dozen of pages (on this forum and on others) since 2...
Leadtek Winfast PVR2000 rtm driver
Hi all I have the Leadtek winfast pvr2000 tv card and it works under vista 32b without problems. I installed the seven rtm 32b and I met problems with this card.:cry: Windows 7 freezes with a black screen during channel scan. All is locked, no mouse, and keyboard led doesn't work respond...
Leadtek Winfast TV2000XP RM Drivers ?
Is there any way to make TV2000XP RM to work on Windows 7 64-bit Build 7600 ? Drivers for Global and Expert got out but that's another chipset. RM is BT878. If anyone knows how to make this thing started, well, please share that with us :cool:
Leadtek winfast a280
anyway I can get my old graphic card to work on windows 7? Ive tried the search and nothing is really showing up. thanks
Graphic Cards
Upgrade HELP!!! from 7100 to 7201 x86
I've got windows 7 V7100 running on my dell D600 and when i attempt to upgrade it to 7201 x86 it fails saying it can find winload.exe. i have my drive setup like this 100mb windows parition. ( from the orginal 7100 install on a blank hdd) 58G OS drive where win7 is installed ( 7100) 239G...
Installation & Setup
Upgrade from build 7100 to 7201?
Hey, just wondering how I should upgrade from Build 7100 to 7201? And uhh what exactly is the difference? Kind Regards
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:28.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App