Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI Mobility Radeon x1300 Driver Download/Install Error

09 Nov 2009   #21

win 7 64
Hello, what do you say?

Hello nighthawk, kev, killerkris, woger and deckard

I run W7 64-bit on an acer laptop with a x1300 mobility radeon card. I have never managed to make the 3D card work optimally in W7. ( RC7100)
The status was this:

-full resolution
-no video problem (regular avi, mpg video )
-3D acceleration problem, -the acceleration would never work in fullscreen apps, there would be image, but with an ultra-frequent flickering between application-image and just black.

However they work in windowed mode. (As for example quake live)

Reading woger's post I thought I would give the mod-tool from driverheaven a go. The mod and installation of ati drivers worked but I have the same problem. I used the latest catalyst 8.12. drivers

Maybe I should have used some other drivers?
Woger: You mention two different drivers, which did you end up using ?
( maybe I should try the 7.11 nighthawk mentioned)

Have anyone had the same problem?

I am sorry if I am 'imposing' on your thread but this really seem related...

My System SpecsSystem Spec
09 Nov 2009   #22

Windows 7 Home Premium x32 SP1

I have x1250 ATI graphic card, but the drivers for it are identical as for x1200 or x1300 models.

Here is a little tutorial, also at the end of this thread I post step-by step screen instructions how to install new drivers:
Hibernate issue - cause by ATI Radeon X1200 Series (Microsoft Corporation - WDDM) driver

My System SpecsSystem Spec
09 Nov 2009   #23

win 7 64

thanks I'll check it out
My System SpecsSystem Spec

09 Nov 2009   #24

win 7 64

Hi again

I checked out the site you (Creer) referred to and tested it..

---Before doing this I ran into a problem with the catalyst package making it impossible to install any drivers. (it just got stuck somewhere in the installation no matter which driver version it was. -I have quite a few on the drive now ) ---

I attempted earlier to install the drivers manually, but unsuccessfully. I didn't realize W7 could not distinguish which drivers were x64 or not!

Reading the post helped in that I saw you needed the exact folder to manually install.

The same problem I mentioned earlier with screen flicker in full screen 3d remains though..

I used the catalyst 8.12 this time around. Could there be a difference with the legacy 9.8 drivers?

My experience so far with ATI drivers seem to be they work or they do not.
-Maybe I will try installing the 9.8 too just for the hell of it and to make sure I have tried everything.

thanks anyways!
My System SpecsSystem Spec
10 Nov 2009   #25

Win7 32-bit

Hi kokosbolle,

now i have installed the driver "9-3_vista64_win7_64_dd_ccc_wdm_enu" from
But so far I didn't test much programs.
What is screen flicker? Maybe I can install this program and test something?

My System SpecsSystem Spec
19 Nov 2009   #26

Many XP versions and 7 home premium

Has there been any resolution on this issue yet?
could this work? I'll try it if I install 7
I bought 7 but I am reluctant to install it yet
The upgrade advisor pointed this out as well

I'll share my two cents on it anyway
When I bought a new hard drive for the same computer by the way
I had a lot of problems and i guess i still do even installing XP again
I have learned to deal with it, but the only resolution that works is the highest one
anything else is a fuzzy very bad quality

I went and installed 7
I'm not certain but I believe I have those aero effects
I'm not sure what worked really
It downloaded a driver but it was dated from sept 09
I used the ones recently past 2 weeks were updated
I did use that website above but I don't know if I had to
My System SpecsSystem Spec
03 Dec 2009   #27

win 7 64
Ati X1300 Working on Windows 7

Hello!! I finally managed to make my problem go away !!

The driver I used was


from guru of course.

If anybody else (poor souls out there like me) has a problem with SCREEN FLICKER IN FULLSCREEN 3D ON W7 WITH ATI X1300 mobile radeon this should work!

First I ran "driversweeper" which is a downloadable exe app from 3d guru which cleans out all remains of older drivers. ( just run the exe, check "ati" and click clean)

Then I ran the mobility modder on said drivers (mobility modder and installation is described earlier in this thread, it looks complicated at first but is really simple)

then I did a simple manual install of the driver (CH_76829.msi) using windows device manager. And now it finally works. Maybe it is possible to use older or newer drivers but this is the first that has worked in my case. If anyone else has the same problem with x1200 or x1250 I hope this can be helpful for you. I usually never follow up posts like this but this has been a real skull-tearer.

but it works... in the end.. yayyyy.

never give up,
never surrender.
My System SpecsSystem Spec
03 Dec 2009   #28

win 7 64

forgot to thank Woger for the driver tip!

My System SpecsSystem Spec
04 Dec 2009   #29

Many XP versions and 7 home premium

i forgot about this

that must have helped because i used it when i first installed it
i never had any problems
My System SpecsSystem Spec
29 Dec 2009   #30

Windows 7
ATI Mobility Radeon X1300 and Windows 7

When I installed Windows 7 on my Acer TravelMate 6460 laptop (which had been running on Windows XP) it did not recognise the ATI card and instead it saw a Generic PnP Monitor on a Standard VGA Graphics Adapter.

Doing some digging around the web and on this forum I saw that, while no Windows 7 driver will be released by ATI for the Mobility Radeon X1300, the Vista driver should work, albeit without access to some Win 7-specific graphics features.

Has anyone been able to make it work?

I downloaded a Vista graphics driver (VGA_ATI_8.31.100.3_VistaX64) from the Acer website. This appeared to install and said the installation was complete. The installation program said the driver would be installed at C:/program files/ATI Technologies.

An 'AST Technologies' directory was created, but there was nothing in it. A separate 'ATI' directory was also created, with a subdirectory called CIM with very little data in it. That subdirectory had two further subdirectories: Config and Reports.

The Reports folder had a log of the installation, and its Error Messages section contained dozens of entries that all said 'Catalyst® Install Manager could not find path'.

I haven't tried it yet but I saw suggested on this forum that the Vista legacy driver could be obtained from AMD's Catalyst Display Driver site here. Has anyone tried these, and are they generic enough that they would work on a particular model of laptop?

Also, here are two drivers there, - the Catalyst Software Suite and WDM Integrated Driver. I have no idea which would be the best to try. The first is much bigger than the Vista driver I got from the Acer website and the other is much smaller.

Also - the website mentioned above is run by AMD. Are their drivers specific to computers with AMD processors? My machine has an Intel Core 2 T7200 2.0Mhz processor.
My System SpecsSystem Spec

 ATI Mobility Radeon x1300 Driver Download/Install Error

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
ATI Mobility Radeon HD 6550 driver fix (Working)
If you have a laptop with switchable graphics and ATI Mobility Radeon HD 6550 (AMD Radeon HD 6550M) graphic card there is one line solution to the problem of graphic card drivers not updating or working, which is: "DO NOT INSTALL UPDATES FROM AMD OFFICIAL WEBSITE" Part 1: Understanding the...
Graphic Cards
Mobility Radeon X1300 not working on Windows 7
Hi all, I have upgraded to Windows 7 Ultimate 32 bit, I am having problems with my Dell Inspiron E1505 / 6400. The Mobility Radeon X1300 can't be detected at all. I cannot run games such as World of Warcraft, or Mass Effect, unless the drivers work. I have installed Catalyst 8.12 drivers...
ATI Mobility Radeon X2300 Modded Driver Help
Hello, I have another older laptop from 2008 I use from time to time. Anyways, it comes with the ATI Mobility Radeon X2300 GPU. The Graphics driver it has is version 8.x. Although the latest driver version for ATI GPU's is 11.x. I can't install this version as it is supposedly not supported by...
Graphic Cards
Radeon Mobility 9000 IGP driver for 7?
Hey all. I recently upgraded a friend's old laptop (Toshiba Satellite A70) to Win7, but there are no drivers available for his graphics chip/card. Does anybody know where I might find one and how to properly install it? I'm aware that the 9000 series only supports up to DX8.1 and thus can't run...
ati mobility radeon 9600 driver on windows 7
Hi, I have just upgraded (clean install) an asus m6ne notebook from windows vista to win7. Now I can't seem to install the graphics card drivers. I have downloaded the ati catalyst software, but I have the feeling I'm running in circles. The catalyst software installs but then nothing...
ATI® Mobility Radeon™ X1400 Driver
does any1 have the latest driver for mobility radeon X1400? i cant find it anywhere yet. (d) post here it here, including the Catalyst Control Center! thanks very much. :thumbsup:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:09.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App