Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI Mobility Radeon x1300 Driver Download/Install Error

12 Jan 2010   #51

Windows 7

That's the sort of thing I do!

Now you've reverted to the laptop screen, is it behaving itself properly?


My System SpecsSystem Spec
12 Jan 2010   #52

Windows 7

It's working like a charm.
Glorious 1650x1080 resolution, Aero effects, smooth system performance.
It's like I have a new computer.
really happy now that it is working.
I hope you are able to get your working.
As a side note, before I realized the problem I had installed the modded 9.11 Legacy drivers and CCC. So those are the ones I have installed on now.
Perhaps that might help you if you are still having problems?
Thanks again.
My System SpecsSystem Spec
15 Feb 2010   #53

windows 7
ATI mobility radeon x1300 problems on windows 7

i had a DELL INSPIRON E1505 ON vista ultimate running on a ATI mobility radeon x1300 and i decided to upgrade to window 7. before doing this i checked the compatibility and it said my card would be compatible. i installed it and on device manager it said the display driver was the Slandered VGA GRAPHICS ADAPTER and the graphics were really gay. i went to the dell web site and downloaded the mobility radeon x1300. it then told me to restart my computer when installations were done and i did, BUT THEN WHEN MY COMPUTER GOT PASTED THE COLORFUL BUBBLES ON THE START UP MY BACK LIGHT STOOPED WORKING BUT U COULD STILL SEE THE WINDOW STARTING UP TO THE HOME MENU. I WENT TO SYSTEM RESTORE AND AND RESTORED IT AND THE LIGHT CAME BACK ON. I DON'T KNOW WHY IT IS DOING THIS. BUT CAN SOME ONE HELP ME IN COMPLETE DETAILS FROM START TO THE END ON HOW TO MAKE YOUR ATI MOBILITY RADEON X1300 WORK WITH WINDOW 7.
My System SpecsSystem Spec

16 Feb 2010   #54

Windows 7 ultimate 64 bit / XP Home sp3

I know thi si an old thread, read through the whole thing and never saw anyone mention using a midigied .inf flie for here ATI MobilityModder - Give ti a try it has had sucess befre. Good luck. Fabe
My System SpecsSystem Spec
15 Mar 2010   #55

Windows 7

Hi, i had installed this modtool from hardwareheaven and the 9-11_legacy_7_vista_32-64_dd_ccc_mobility too. In both of then, aero runs ok and resolution as well, but when i play games (bfme2 or mythology and others) it reduces the resolution and don´t get full screen. My laptop is wildscreen, but only work games like a none widscreen monitor. Have anyone the same problem after install this mods?
My System SpecsSystem Spec
29 Mar 2010   #56

Microsoft Windows XP Proffesional

Quote   Quote: Originally Posted by woger View Post
Hi killerkris14,

maybe i have a solution for your problem.
I also have a notebook with ATI Mobility X1300 and I installed Win7-64 in the last days. And first there was no posibility to change to 1280x800.

But I found a tool to solve the problem.
I hope it is ok in this forum to post the link, it is ATI MobilityModder -

And i used "ATI Catalyst 7.11 Vista (64-bit)" from

Good luck,
Thank you woger, it's really works!

This is the resolve for Windows 7 ATI Radeon Mobility driver problem.

Thank you very much.
My System SpecsSystem Spec
29 Mar 2010   #57

Windows 7 Home Edition X64

ATI Card X1xxx Driver Series are a pain to install

look for version 8.1 of the catalyst (complete package or just drivers) the lastest 10.2 only updates certain video cards and the x1 series cards are no longer supported since version 8.1 but the 10.2 catalyst updates need to be done after installing 8.1 driver because it updates the main catalyst software ad ensures proper working functions.

I have a XPS400 with a x1300 and a HP nx9420 with a x1600 that this procedure ensure proper drivers installed and full functionality

let me know if you need more information
My System SpecsSystem Spec
27 Feb 2012   #58

Windows 7 x64

Thank you woger!!!! Thank you so much for providing access to that Modder!! It really helped, although with me, I had to reinstall the latest desktop driver (the ATI Catalyst 8.12 - Windows Vista 64 bit sufficed for me) to get the install manager to install that CH_76829.msi file. But yeah, thanks so much for your help man. I've literally spent the equivalent of like 10 hours over the past 2 days (okay maybe not 10) trying to figure this out.

And thank you kokosbelle for laying out the instructions. For me the windows device manager didn't work so I had to use the ATI install manager.

For anyone else here's what I did after I ran the modder on that 9-3_vista64_win7_64_dd_ccc_wdm_enu file

(it looks like a lot but seriously it will take you like 3 minutes, not even, and yeah I was installing windows 7 on my dell inspiron E1505 which needed an ATI Mobility Radeon x1300 driver):

I went to back to that 9-3_vista... file,
(2. click the Driver folder
(3. click Packages folder
(4. click the Drivers folder you see there
(5. click the Display folder
(6. click the LH6A_INF folder
(7. in that folder you'll see the CH_76829 file with a computer icon next to it, right click that and press install. (I said yes to the option of using the install manager, saying no didn't work for me).

(note: for me it said that I needed the install manager. If you get an error message with the install manager, just go back to the modder website and do what I did reinstall the latest desktop driver (i.e. ATI Catalyst "something something" - for me I used 8.12)).

Then go back to the CH_76829 folder and right click it again and then install.

Then reboot your computer and jump for joy.

You have no idea how happy I am right now, like when it first started working I almost cried
My System SpecsSystem Spec
27 Feb 2012   #59

Windows 7 x64

Quote   Quote: Originally Posted by kokosbolle View Post

Hello!! I finally managed to make my problem go away !!

The driver I used was


from guru of course.

If anybody else (poor souls out there like me) has a problem with SCREEN FLICKER IN FULLSCREEN 3D ON W7 WITH ATI X1300 mobile radeon this should work!

First I ran "driversweeper" which is a downloadable exe app from 3d guru which cleans out all remains of older drivers. ( just run the exe, check "ati" and click clean)

Then I ran the mobility modder on said drivers (mobility modder and installation is described earlier in this thread, it looks complicated at first but is really simple)

then I did a simple manual install of the driver (CH_76829.msi) using windows device manager. And now it finally works. Maybe it is possible to use older or newer drivers but this is the first that has worked in my case. If anyone else has the same problem with x1200 or x1250 I hope this can be helpful for you. I usually never follow up posts like this but this has been a real skull-tearer.

but it works... in the end.. yayyyy.

never give up,
never surrender.

yeah, and anyone for whom the windows device manager doesn't work peep my earlier post where I go thru the step by step instructions.
My System SpecsSystem Spec
23 Jan 2014   #60

Win7 Home Premium 32bit and Win7 Ultimate 64bit

Hi there. I replied to a similar thread too.

To whomever is experiencing the same issue,I had the same problem too and could finally work it out.

Lots of exe files and catalyst versions (11.x 12.x for xp, vista, 7 32 bit) on lots of web sites just to have my ATI Mobility Radeon X1300 recognized and working properly with win7: none of them working. I always got just catayst install manager and SKD development kit installed, but no driver at all, then nothing changed and happend on the resolution of my monitor.

After a few days of research in the web (googling properly) I found this out.

Last catalyst exe file and version for ATI Mobility Radeon X1300 seems to be 6.11. It has been delivered for xp and vista 32 bit and you can find and download it here:

AMD/ATI Mobility Radeon X1300 mobility drivers for Microsoft Windows Vista 32bit

the following step is: how do you get a vista software and driver work properly with win7? Here you go. It's just about running this exe file from win7 but in Vista mode as per what reported here:

Drivers - Install Vista Drivers on Windows 7

Using just these couple of steps I could finally make it: anything is fine now with my ATI Mobility Radeon X1300 fully available and working with win7.

Hope this can help anyone who does not believe that there is no way to have tech things work properly and does not give up.

Bye anyone.
My System SpecsSystem Spec

 ATI Mobility Radeon x1300 Driver Download/Install Error

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
ATI Mobility Radeon HD 6550 driver fix (Working)
If you have a laptop with switchable graphics and ATI Mobility Radeon HD 6550 (AMD Radeon HD 6550M) graphic card there is one line solution to the problem of graphic card drivers not updating or working, which is: "DO NOT INSTALL UPDATES FROM AMD OFFICIAL WEBSITE" Part 1: Understanding the...
Graphic Cards
Mobility Radeon X1300 not working on Windows 7
Hi all, I have upgraded to Windows 7 Ultimate 32 bit, I am having problems with my Dell Inspiron E1505 / 6400. The Mobility Radeon X1300 can't be detected at all. I cannot run games such as World of Warcraft, or Mass Effect, unless the drivers work. I have installed Catalyst 8.12 drivers...
ATI Mobility Radeon X2300 Modded Driver Help
Hello, I have another older laptop from 2008 I use from time to time. Anyways, it comes with the ATI Mobility Radeon X2300 GPU. The Graphics driver it has is version 8.x. Although the latest driver version for ATI GPU's is 11.x. I can't install this version as it is supposedly not supported by...
Graphic Cards
Radeon Mobility 9000 IGP driver for 7?
Hey all. I recently upgraded a friend's old laptop (Toshiba Satellite A70) to Win7, but there are no drivers available for his graphics chip/card. Does anybody know where I might find one and how to properly install it? I'm aware that the 9000 series only supports up to DX8.1 and thus can't run...
ati mobility radeon 9600 driver on windows 7
Hi, I have just upgraded (clean install) an asus m6ne notebook from windows vista to win7. Now I can't seem to install the graphics card drivers. I have downloaded the ati catalyst software, but I have the feeling I'm running in circles. The catalyst software installs but then nothing...
ATI® Mobility Radeon™ X1400 Driver
does any1 have the latest driver for mobility radeon X1400? i cant find it anywhere yet. (d) post here it here, including the Catalyst Control Center! thanks very much. :thumbsup:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:15.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App