Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HT Omega CLARO Not Functioning

13 Jun 2009   #1
ordonator

Windows 7
 
 
HT Omega CLARO Not Functioning

So I'm guessing the new HT Omega drivers for Windows 7 may have been released a little prematurely. I can install the drivers but as soon as the audio service is initialized the whole system locks up, requiring a hard reboot. Anyone else have this problem?

By the way, I have the regular CLARO, not the +.


My System SpecsSystem Spec
.
15 Jun 2009   #2
musashiken

Windows 7 RC
 
 

Hi, I'm using the normal Claro as well. On Windows 7 RC x64. The drivers work like a charm. I have no problems with the drivers. Using a 2.1 analog setup though.

I was using the Vista x64 drivers before. I uninstalled those, restart Win7, installed the Win7 drivers, restart and everything works.


I'm not sure why your's isn't working
My System SpecsSystem Spec
15 Jun 2009   #3
ordonator

Windows 7
 
 

I'm not sure why, but it seems to have resolved itself. Works great now.
My System SpecsSystem Spec
.

19 Jun 2009   #4
spliff

7600x64 RTM
 
 

Mine's working fine as well on 7100 x64 w/ the new driver and optical out. Clear as a bell in DTS!
My System SpecsSystem Spec
Reply

 HT Omega CLARO Not Functioning




Thread Tools




Similar help and support threads
Thread Forum
Claro Chrome Toolbar
Many years since I fell for the trick bag, but here I am. A program that I can't shake. I was looking for help. I was feeling safe with "Windows SevenForum". Just looking for help when I came across, led to it by this forum, a program called Claro Chrome Toolbar. Just can't get it uninstalled. ...
Browsers & Mail
Claro toolbar infection?
I think I may have an infection from downloading a Shockwave Flash player although I UNchecked all of the add on in its program. I got a "Claro Toolbar" installed and IE opened to a Claro search as my home page. I uninstalled this Claro toolbar but I think something remains. I have downloaded NBRT...
System Security
Experience with HT Omega Striker 7.1?
Hey guys, So - I just built a new computer and upgraded my sound card from the Creative Soundblaster to the HT Omega Striker 7.1. Im using Windows 7 64-bit and have downloaded the newest drivers (from Omega's website) for the card. However - so far I have concluded that (to my ears) the $24...
Sound & Audio
HT Omega Claro Plus... XP w/SP3
Guys, I know this is a Windows 7 forum but I feel so at home here that I decided to turn to my brethren for an XP question as well. So I am trying to help a friend with this card but I can not get the speakers to work with it. This is what I have done so far, but first his Specs. EVGA ...
Sound & Audio
HT Omega Claro Plus Installation Problem
My OS is Windows 7 Ultimate 32 bit. Firstly, I installed SW and drivers from the CD. Then, I downloded sw package from yor web page, and updated drivers. However, the utility sw does not appear in the programs section of windows. There is a folder "HT Omega Claro" under C:\Program Files...
Sound & Audio
HT Omega - Claro Plus+
kind of sux , no win 7 beta driver yet from ht omega.control panal applet freezes my pc-if i try to open it:mad:
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App