Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WD MyBook Essentials 2.0 1TB worked - but not anymore

14 Jun 2009   #1

xp & osx
 
 
WD MyBook Essentials 2.0 1TB worked - but not anymore

Hi,

I've read numerous posts in the forum and tried a few things without any luck.

My Western Digital MyBook Essentials 2.0 1TB have been working for a week now with Windows 7 RC1 (clean install), but today all of a sudden it won't be recognized.

The funny thing is that it is recognized just fine on a winxp laptop.

By the way, windows 7 is installed on an Acer Aspire One if that matters.

How can I maybe uninstall the driver for MyBook (if there is any?) ?

My System SpecsSystem Spec
.

14 Jun 2009   #2

xp & osx
 
 

By the way, after enabling administrator account and logging into it (as per the guide on this forum), I noticed three 'Base System Device' under Unspecified, together with one icon saying 'SH Host Controller'. They had a warning sign on them, and after troubleshooting and installing CardReader_J_Micro_V1.00.1.4.03_Vista32x64 the little yellow warning sign disappeared from all of them.

I don't know much about this, but are the three 'Base System Device' my USB ports? Anyways, my logitech cordless mouse is using one of the usb ports.


EDIT: Now the entire 'Unspecified' category in Devices and Printers with the three 'base system device' and 'SD host controller' are all gone. No idea why or what happened.
My System SpecsSystem Spec
08 Dec 2009   #3

Windows 7
 
 
solved

I fixed that problem with a WDC My Book Home 1TB in Windows 7: (and also in vista as i have a dual boot)

The drive was recognized in computer management and in device manager but no drive letter was allocated while connected with a e-sata cable.

1.in computer management > storage > disk management
2.rightclick drive 1 or wathever the number of the WDC drive (which should be basic at this time)
3.select 'convert to dynamic disk'
4.drive should get a drive letter
5.format (warning: all data get lost, but you can download original software from wdc.com)

Succes!
Olivier
My System SpecsSystem Spec
.


Reply

 WD MyBook Essentials 2.0 1TB worked - but not anymore




Thread Tools



Similar help and support threads for2: WD MyBook Essentials 2.0 1TB worked - but not anymore
Thread Forum
[Dropped] WD MyBook Essentials and Acer Aspire 4715 Z Hardware & Devices
mybook drivers for repair from image Drivers
Backup files on WD MyBook NAS to Ext USB Drive Backup and Restore
MyBook Drive Upgrade Question Hardware & Devices
Help... WD Mybook is causing problems on boot up Hardware & Devices
MyBook recognition issue Hardware & Devices
WD MyBook USB HDD completely ignored by Windows 7 Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33