Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Mobility X1400 on Windows 7 64-bit


19 Dec 2010   #1

Windows 7 Ultimate x64
 
 
ATI Mobility X1400 on Windows 7 64-bit

Hey all, first post here.

I just updated to Windows 7 X64. I'm having trouble finding the right drivers for my video card. The computer is a Dell e1505, and Dell doesn't officially support Windows 7. And by the looks of it, neither goes ATI, for this particular model at least. I'd appreciate any insight on what driver to get and how to install it, because until then, I'm stuck at 1024 X 768 resolution...


My System SpecsSystem Spec
.

19 Dec 2010   #2

windows 7 x86 ultimate
 
 

Hey !

Have you tried manually installing VISTA 64 bit drivers?
In most cases they are compatible.
My System SpecsSystem Spec
19 Dec 2010   #3

Windows 7 Ultimate x64
 
 

What do you mean by manually? Yes, I've tried to install the 10.12 drivers for Vista 64bit. I can go through the installation process, but nothing really happens.
My System SpecsSystem Spec
.


19 Dec 2010   #4

windows 7 x86 ultimate
 
 

Hey

Go to "Device manager" -> right click on your graphic card and select "update driver software".
Then choose "browse my computer for driver software"
Now direct it to the folder where you extracted the driver. (usally c:\ATI\Support)
Click next, and let it install the drivers.

Restart your computer when its done, and it should work.
My System SpecsSystem Spec
19 Dec 2010   #5

Windows 7 Ultimate x64
 
 

So, in the device manager, it's only showing "Standard VGA Graphics Adaptor", not my actually card.
My System SpecsSystem Spec
19 Dec 2010   #6

windows 7 x86 ultimate
 
 

Hey

try it on the VGA
My System SpecsSystem Spec
19 Dec 2010   #7

Windows 7 Ultimate x64
 
 

I did, with no avail. It keeps showing that all drivers are up to date.
My System SpecsSystem Spec
19 Dec 2010   #8

windows 7 x86 ultimate
 
 

Hey

well a quick search in the forums i came up with this: Windows 7 not detecting radeon mobility x1400
read the final post.
My System SpecsSystem Spec
19 Dec 2010   #9

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by TheStig22 View Post
Hey

well a quick search in the forums i came up with this: Windows 7 not detecting radeon mobility x1400
read the final post.
Thanks, I'll look into it when I have time tomorrow.

(By the way, assuming you're a Top Gear fan, new special out on Tuesday WOOO!)
My System SpecsSystem Spec
19 Dec 2010   #10

Windows 7 Ultimate x64
 
 

I used the mobility modder as described on its site, still with no success.

Does anyone else have any ideas?
My System SpecsSystem Spec
Reply

 ATI Mobility X1400 on Windows 7 64-bit




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:51 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33