Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound & Playback drivers not working?

17 Jun 2009   #1
RyeRye

Vista
 
 
Sound & Playback drivers not working?

Hey I am a total noob with this stuff, and I upgraded to windows 7, and now my sound drivers and my playback (recording) drivers aren't working.

In Device manager it says I have High Definition Audio Device
And Sigmatel High Definition Audio CODEC

And i'm guessing it's realtek? already downloaded it, it didn't work. and i'm on a gateway 32 bit.

Thanks. I know this isn't much help, but i'm not good with sound drivers and stuff.

Anything helps

-RyeRye


My System SpecsSystem Spec
.

17 Jun 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by RyeRye View Post
Hey I am a total noob with this stuff, and I upgraded to windows 7, and now my sound drivers and my playback (recording) drivers aren't working.

In Device manager it says I have High Definition Audio Device
And Sigmatel High Definition Audio CODEC

And i'm guessing it's realtek? already downloaded it, it didn't work. and i'm on a gateway 32 bit.

Thanks. I know this isn't much help, but i'm not good with sound drivers and stuff.

Anything helps

-RyeRye
Hi and welcome to SF. Have you graded your audio driver to win 7 driver? You can download them here. Sigmatel Audio Driver Downloads - Official Drivers
If after you install them you still dont have audio just reply and I will get an email.

Hope this helps somewhat

Ken
My System SpecsSystem Spec
17 Jun 2009   #3
RyeRye

Vista
 
 

What do I do with that?
It says for sound, video game controllers,
Sigmatel High Definition audio Codec theres no driver there, and when I click "Next" it says I have to enter a registration key.
My System SpecsSystem Spec
.


17 Jun 2009   #4
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by RyeRye View Post
What do I do with that?
It says for sound, video game controllers,
Sigmatel High Definition audio Codec theres no driver there, and when I click "Next" it says I have to enter a registration key.
On the download page there is a button for driver dective. it will find out what driver you need download and install it. its right where my cursor is on the picture.

Hope this helps

Ken
My System SpecsSystem Spec
17 Jun 2009   #5
RyeRye

Vista
 
 

isn't that just what I downloaded?
My System SpecsSystem Spec
17 Jun 2009   #6
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by RyeRye View Post
isn't that just what I downloaded?
Might be but I dont know. what was the driver you downloaded? did it install correctly? did the computer re-boot? In device manager what does the driver tab say?


Ken
My System SpecsSystem Spec
17 Jun 2009   #7
RyeRye

Vista
 
 

I downloaded the first download link. The one in the box.

It keeps saying I need a key though for the Driver Detective thing.
It says No drivers are installed for this device.
My System SpecsSystem Spec
17 Jun 2009   #8
RyeRye

Vista
 
 

Oh well. I'm going to sleep. get back too me, and ill check it in the morning .
My System SpecsSystem Spec
17 Jun 2009   #9
zigzag3143

Win 8 Release candidate 8400
 
 
sigmatel audio driver

Quote   Quote: Originally Posted by RyeRye View Post
I downloaded the first download link. The one in the box.

It keeps saying I need a key though for the Driver Detective thing.
It says No drivers are installed for this device.

Ok lets try something different

download it from here there is only one driver listed. SigmaTel SigmaTel AC'97 Driver Download. When it is installed go into device manager and see what the driver listed is . Just let me know if it doesn't work.

This is the only driver I can find for that. If this doesn't work you may ahve to do a clean re-install of windows 7. I know win 7 has AC97 drivers built in.

Good luck

Ken
My System SpecsSystem Spec
17 Jun 2009   #10
RyeRye

Vista
 
 

Oh noes, a clean install?
My System SpecsSystem Spec
Reply

 Sound & Playback drivers not working?




Thread Tools





Similar help and support threads
Thread Forum
Sound, networking, USB drivers all not working on HP G71 Windows 7
The other night I had noticed that the sound, networking, and USB drivers have failed on my laptop. I ran a full system virus scan on my comp, but nothing came up as malicious. Anyone know how to resolve this issue? I would prefer not to reformat my hard drive at all costs. Thanks guys!
Drivers
Sound card drivers show as working but still no sound
Hi, as stated in the subject, I am unable to hear any sound from my speakers since upgrading to the windows 7 64 bit. I followed the other post that I found on this but I still cannot hear any sound. I have a dell inspiron 531. The hardware ids from the device manager are ...
Sound & Audio
sound not working at all drivers
I have had this problem before and I fixed I just don't remember how. I'm working on an old computer and when I installed windows 7 for the 1st time on it, windows 7 installs all the drivers auto and it's wrong drivers and the sound doesn't work, I need to know how to disable windows 7 from...
Sound & Audio
Issues with sound and playback
About a week ago, I had a problem with sound on my computer. It started off when Windows Media player would not play files on my playlist (This is not a codec problem, I have CCCP installed). It would say: "cannot play the file because there is a problem with your sound device." It would go through...
Sound & Audio
No Sound on DVD playback
I have a creative xfi xtreme gamer, which works fine, I get all sound and features I should in Win 7...that is that I use or am aware of :-) I seriously just put another hard drive in my system and closed the case. Fired it up and BAM, no sound when playing DVD's. I have looked everywhere...
Sound & Audio
PCI Sound Card drivers not working
Hey guys, I recently upgraded to Windows 7 Prof 32bit, after installing it I relised I can't get surround sound with my onboard sound like I was able to with XP. I went out and bought be a genius 5.1 surround sound PCI card. Now the thing is...before installing the genius drivers, Should I...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App