Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Don't install recommened driver for a Network adapter


18 Jun 2009   #11

64-bit Windows 7 Ultimate Build 7100
 
 

Haha, it was not really a diagnostic. Just a caveat.

Besides from this problem, 7 has been awesome. Installed it on the my new system I just built cause I didn't want to pay for anything else!


My System SpecsSystem Spec
.

18 Jun 2009   #12

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Until July you will still have time to try out both RCs while they are available for download. Most are running the 64bit 7 since even the Vista 64bit updates will work on 7. But I'll be taking a look to see if knocking out the drivers for the nic card solves the problem of adding on a router. Seems like a good find there!
My System SpecsSystem Spec
18 Jun 2009   #13

64-bit Windows 7 Ultimate Build 7100
 
 

Quote   Quote: Originally Posted by Night Hawk View Post
Until July you will still have time to try out both RCs while they are available for download. Most are running the 64bit 7 since even the Vista 64bit updates will work on 7. But I'll be taking a look to see if knocking out the drivers for the nic card solves the problem of adding on a router. Seems like a good find there!
Nice! I hope that fixes the problem!
My System SpecsSystem Spec
.


18 Jun 2009   #14

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

It would be a big help if it works out. Both routers have a wireless usb adapters. They also can be hard wired with one having the RJ11 type for the old dsl line. The other offers the RJ45 ethernet in use here for the host pc.

The solution you found for your own situation will likely be a big help for others with similar setups. It never hurts to take notes when you find a solution for something.
My System SpecsSystem Spec
19 Jun 2009   #15

Windows 7 Ultimate RC 7229
 
 

Quote   Quote: Originally Posted by zeppoleon View Post
Hey guys, I just wanna let you know that if you have a "Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)" don't install the driver recommended by windows update. It will disconnect you from the internet. I tried Windows 7 troubleshoot option, but it could not solve the problem. So I just rolled back to my old driver, and my connection was fine again. Just letting you know.
I have already mentioned this problem in this forum, There were no fixes for it though by the looks of it.
My System SpecsSystem Spec
19 Jun 2009   #16

Windows 7 Ultimate, Ubuntu
 
 

Quote   Quote: Originally Posted by zeppoleon View Post
Hey guys, I just wanna let you know that if you have a "Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)" don't install the driver recommended by windows update. It will disconnect you from the internet. I tried Windows 7 troubleshoot option, but it could not solve the problem. So I just rolled back to my old driver, and my connection was fine again. Just letting you know.
I installed it.
Everything is fine.

I think what you really wanted to say is "I had a bad experience installing etc"
To come out and say "Don't install" on the strength of one instance is a bit overheated.
My System SpecsSystem Spec
19 Jun 2009   #17

Windows 7 Ultimate RC 7229
 
 

Quote   Quote: Originally Posted by Charles Kane View Post
I installed it.
Everything is fine.

I think what you really wanted to say is "I had a bad experience installing etc"
To come out and say "Don't install" on the strength of one instance is a bit overheated.
Thats interesting, The update does not work on my system either, I use the driver from the Realtek site and it works fine.
My System SpecsSystem Spec
19 Jun 2009   #18

Windows 7 RC1
 
 

I had a similar problem with a Realtek RTL8168B/8111C NIC

The recomended updated driver is from June 2007 which is an earlier driver then the one that is installed by Windows 7 RC1 which is from 2008

I only noticed a problem with it when I connected a 10/100 router & could only connect at 10 megabit & not 100 megabit

I downloaded an updated driver from Realtek from 2009 but when I tried to update the driver windows refused to install the driver saying that the current driver was the correct one or words to that effect

I got around the problem by overwriting the Realtek driver in the windows/system32 folder with the updated one & I was able to connect to the router at 100 megabit

I later realised that the original driver installed by windows 7 had been updated & when I rolled back to the original driver I was then able to update the driver with an even later driver specifically for windows 7

Windows update still has the 2007 driver as an optional update for the Realtek NIC
My System SpecsSystem Spec
19 Jun 2009   #19

Windows 7 Ultimate RC 7229
 
 

Quote   Quote: Originally Posted by Rolond View Post
I had a similar problem with a Realtek RTL8168B/8111C NIC

The recomended updated driver is from June 2007 which is an earlier driver then the one that is installed by Windows 7 RC1 which is from 2008

I only noticed a problem with it when I connected a 10/100 router & could only connect at 10 megabit & not 100 megabit

I downloaded an updated driver from Realtek from 2009 but when I tried to update the driver windows refused to install the driver saying that the current driver was the correct one or words to that effect

I got around the problem by overwriting the Realtek driver in the windows/system32 folder with the updated one & I was able to connect to the router at 100 megabit

I later realised that the original driver installed by windows 7 had been updated & when I rolled back to the original driver I was then able to update the driver with an even later driver specifically for windows 7

Windows update still has the 2007 driver as an optional update for the Realtek NIC
Pretty similar to me, But I get no connection at all with the 2007 driver.
My System SpecsSystem Spec
19 Jun 2009   #20

64-bit Windows 7 Ultimate Build 7100
 
 

Quote   Quote: Originally Posted by Charles Kane View Post
I installed it.
Everything is fine.

I think what you really wanted to say is "I had a bad experience installing etc"
To come out and say "Don't install" on the strength of one instance is a bit overheated.
My mistake, I will make that more clear in the OP
My System SpecsSystem Spec
Reply

 Don't install recommened driver for a Network adapter




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:13 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33