Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: alfa AWUS036NH RT3070 USB WLAN

26 Jan 2011   #1

7 ult 32
 
 
alfa AWUS036NH RT3070 USB WLAN

Hello everybody,

I've tried all I can think off, browsed the net but without any succes. So I hope maybe some genious here can point me in the right direction.
Here we go:

I've bought an alfa AWUS036NH USW-Wlan adaptor. Inside there is a RT3070.
I am unable to install it in windows 7.

What have I tried?
- installed in linux: works fine - so no hardware problems.
- installed the driver from the install CD : it shows in device manager, but it doesnt work (also the Ralink UI shows disconnected an gives errors on trying to put radio on)
- installed drivers from alfa site: no luck
- installed the dirvers fom ralink site : no luck
- installed older drivers : no luck

Also, after every failed attempt I: uninstalled device, driver an UI and rebooted (I mean I worked clean)


Other possible (hopefully!!) helpfull info:

Windows 7 installs a driver on plugin' in but also no success ...

my pc is a acer laptop 1825PTZ (the internal adaptor is a 1000 BGN)
my windows is window 7 ultimate 32-bit, totally legal

drivers I tried:
sta_rt2870_d-1.4.9.0_va-2.3.9.0_w7-3.0.9.0_ru-3.1.4.0_au-3.0.5.0_120109_1.5.6.0

sta_rt2870_d-3.1.8.0_va-3.1.8.0_w7-3.1.8.0_ru-4.0.4.0_au-4.0.4.0_123110_1.5.11.0

sta_rt2870_d-3.1.3.0_va-3.1.3.0_w7-3.1.3.0

STA_RT2860_D-3.1.0.0 (I found this hint on a forum altough it is for different chipset)

Ralink_RT2870_drv3.1.3.0

the installation disk calls it : AWUS036NH.exe. It installs driver version 3.1.3.0 This is the only one that prompts me to insert the USB. But I've tried installation of all the drivers above once with plugged in device and once without ...

The blue led on the adaptor is blinkin' AS IF it is workin'

So, I have tried really all I can think off...

anybody with some hint? ALL help is welcome!

thank you very much!
Kjoere


My System SpecsSystem Spec
.

26 Jan 2011   #2

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Some hardware unfortunately just isn't Windows Seven compatible. On the sites where you downloaded the drivers if they were not Windows Seven 32 bit drivers you'll need to use compatibility mode to install them.
Compatibility Mode.

It appears you have tried just about everything you can I'm thinking it's just not Windows Seven compatible.

Have you tried anything else in your USB ports to make sure they're working properly? I know you said the light blinks but no joy. This is why I'm leaning toward's it not being 7 compatible.
Sorry Fabe
My System SpecsSystem Spec
26 Jan 2011   #3

7 ult 32
 
 

Hi Fabe,

First of all: THANK YOU very much for taking the time to look at my problem.
This product is indicated on vendors site as Seven compatible and in drivers Windows 7 is also mentioned. there is even an installing vid (ALFA Network WLAN, WiFi phone, ADSL, KVM, Bluetooth, PoE Products -- AWUS036NH)

that is why i find this all very strange.

anyway, thank you for your suggestion!
i'll try experimenting with the compability mode
the troubleshoot comability suggested XP SP2, but that is not working either.
I'll try vista later ...
could it be an idea to download older OS (e.g. vista) drivers and run them in Windows 7 incompability mode?

Bye 4 now
Kjoere
My System SpecsSystem Spec
.


26 Jan 2011   #4

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Your welcome.
At this point anything is worth a try. IMO
Fabe
My System SpecsSystem Spec
27 Jan 2011   #5

7 ult 32
 
 
no luck ...

I tried ALL compability modes but nothing ...

New info:
I am very sure that the sites indicate 32 and 64 bit Windows 7.
I plugged it in on a Windows 7 Home premium 64 bit and it worked like a charm (just by pluggin it, win detected and installed functioning drivers !)

changing my own system to 64 bit is not an option since I would have to much incompatible soft ...

GRRRRRRRRRRRRRRRRRRRRRRRRR!

You think it could be an idea to install drivers for other usb wlan products (different brands) als using this chipset (rt3070)

PS: what does IMO mleans?

Kjoere
My System SpecsSystem Spec
27 Jan 2011   #6

Windows 7 ultimate 64 bit / XP Home sp3
 
 

In my opinion
Fabe
My System SpecsSystem Spec
28 Jan 2011   #7

7 ult 32
 
 

Hello Fabe,
Hello Everybody,

First off : thx again. My problem is SOLVED! Since it came about in a bizar way, I think it is worth mentioning here, maybe somebody else can profit from it:

Frankly, I gave up on Windows 7 32 bit and started experimenting with virtualisation (virtualbox and vmware player)
On setting Up my virtual OS (linux ubuntu) the vmware player installed some virtual new connections (also showing in win config).
at the same time windows showed to "driver not found" error icon in taskbar.
On next boot (with alfa plugged in). Windows went on installing the driver ...
but... but ... but .....
this time it didn't install the 3.1.5.0 version but the 3.0.0.61 version of the driver !
and all is well now!

So thx again for helpin' me and for the fast replies.
I hope someone else can profit from my experience!

bye
Kjoere
My System SpecsSystem Spec
28 Jan 2011   #8

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Your welcome, that's what were here for.
Glad to here you figured it out but mostly thanks for posting back.
Fabe
My System SpecsSystem Spec
29 Jan 2011   #9

Windows 7 Ultimate x64
 
 

The problem actually lays in the security software. if you repair or reinstall whatever you are using (zone-alarm, eset, kaspersky ... or whatever else) and let the software start from fresh settings, it will work just fine. (by the way ... i recommend you get the drivers from RaLink ... rather than using those from Alpha's site).
My System SpecsSystem Spec
15 Feb 2011   #10

7 ult 32
 
 

hi chris, interesting idea, doesn't sound logical to me BUT I will try this idea on an old vista laptop later this week.
so, I plug it in, let install the drivers by windows and then reinstall my zone-alarm, right?

bye
kjoere
My System SpecsSystem Spec
Reply

 alfa AWUS036NH RT3070 USB WLAN




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33