Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sigmatel Audio drivers won't install

24 Jun 2009   #1
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 
Sigmatel Audio drivers won't install

Have a tablet PC that I just installed Seven onto. Even though it's an old box, Windows update found nearly all of the drivers. The one it didn't find is for the AC97 Sigmatel audio.

So, I grabbed the drivers I used for Vista (they're actually XP drivers) and tried to install them. Did this again and again, using different compatibility modes every time. Got no indications of failure, but never worked, either.

Tried removing the device and having Windows Update search for a driver. No luck.

Tried installing driver from selecting from list. Only Sigmatel driver in the list is for HD -- which I don't have.

Even tried the MS WDM driver -- and it refused to install it.

I read in another thread that there are supposedly generic AC97 drivers --but I can't figure out how to install them.

The relevant driver files from Vista are STAC97.sys and staco.dll -- which tells me this is a STACS AC97 audio chip. But I just can't figure out how to get a driver installed.

Can someone please help?

Thanks in advance


My System SpecsSystem Spec
24 Jun 2009   #2
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Looks like I lucked out and stumbled upon the solution. After trying over a half dozen different drivers, I went to the Fujitsu site, downloaded the old XP driver, set it up in VXP SP2 compatibility mode, and it worked!

Never could get the XP driver to work on Vista; had to use a Vista driver for another model machine.

Another plus for Seven!!
My System SpecsSystem Spec
20 Oct 2009   #3
rpk2012

Windows 7
 
 

Sorry to bother you, but which notebook on their site has the drivers you found?
My System SpecsSystem Spec
20 Oct 2009   #4
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

It's been a while since he posted this I contacted him thru his veiw public profile and left a message that someone else needed his help on this, Hopefully he'll check back soon with a reply. Fabe
My System SpecsSystem Spec
21 Oct 2009   #5
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

My tablet PC is a Fujitsu T4020. The XP drivers for Sigma-tel audio installed in XP compatibility mode and work fine.

The working version is v5.10.4469.0, dated 4/15/2005.

Good Luck.
My System SpecsSystem Spec
21 Oct 2009   #6
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Quote   Quote: Originally Posted by thefabe View Post
It's been a while since he posted this I contacted him thru his veiw public profile and left a message that someone else needed his help on this, Hopefully he'll check back soon with a reply. Fabe
On other forums, when I get a PM, I get a popup when I login telling me that.

When I logged in today, I got no such popup here. Should I have?
My System SpecsSystem Spec
21 Oct 2009   #7
rpk2012

Windows 7
 
 

Thank you, it did install... BUT, when I restart, and check the hardware profile there is no longer anything in the sound card section..... just under system devices and all it is, is the controler.
My System SpecsSystem Spec
22 Oct 2009   #8
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Quote   Quote: Originally Posted by rpk2012 View Post
Thank you, it did install... BUT, when I restart, and check the hardware profile there is no longer anything in the sound card section..... just under system devices and all it is, is the controler.
Is your tablet a T4020? Did you install the drivers in XP compatibility mode? I did that and they work fine for me.
My System SpecsSystem Spec
Reply

 Sigmatel Audio drivers won't install




Thread Tools





Similar help and support threads
Thread Forum
sigmatel c-major audio
I have a dell latitude laptop D610 and I absolutly cannot get my audio to work after i installed windows 7. I have went everywhere and checked every forum i could find and i cannot find any solutions. i have installed and uninstalled and restarted my comp dozens of time with no results. so i was...
Sound & Audio
Sigmatel Audio Nightmare...
Hello all, I have a frustrating problem with my Dell M1530 laptop. Switched it on this morning and the audio had completely gone. The speaker icon has a red cross next to it and when hovering the mouse over, it says "No Audio Output Device is installed". Went to device manager to see what's...
Sound & Audio
Onboard audio not working and audio drivers won't install
Hello everyone, I'm having a problem using my motherboard’s onboard HD audio instead of my video card’s audio, so without further ado here is the situation; I have an Asus maximus iii gene motherboard which has a SupremeFX X-Fi built-in sound card (this is a very nice card provided you can...
Sound & Audio
SigmaTel Audio
Hi all. I built myself a pc about 3 years ago, and just upgraded it to windows 7. my pc specs: mobo: intel D975XBX2 desktop board i bought this new in some store, i dont remember, and have no link to it, there is a very similar model, D975XBX2kr, on newegg:
Sound & Audio
New IDT/SigmaTel HD Audio Drivers 6230
Windows Vista/7 32-bit Windows Vista/7 64-bit hust download that cab file extract it with winrar, the update the driver in the device manager manually.
Drivers
I have a Sigmatel audio onboard no sound!
I have a Dell XPS 410 with Sigmatel onboard soundcard and I installed the newest drivers that Driver Detective found for me which was Intel® Desktop Board DG33TL Audio: IDT* 92XX Driver But I still have no sound working could somebody please help me to get the sound to work on my computer!!
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App