Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WinFast TV2000 XP Expert driver problem

04 Apr 2010   #31

windows 7

Quote   Quote: Originally Posted by Micha View Post

I can't find this version winfast pvr2 2. 0. 3. 22 on this link...

I have same problems with sounds... I can watch tv but no sounds.

I try reinstal sound driver, but no works.

my sound card is realtek high definition audio.

PVR2 no see sound card... what can to do about that?

My System SpecsSystem Spec
08 May 2010   #32

windows 7
New beta version

Here is link to new beta version:
My System SpecsSystem Spec
09 May 2010   #33

Windows 7 Ultimate 64 bit

Hi luckasta,

Check your drivers for the realtek HD card. My guess is that they are the Microsoft drivers and NOT the realtek ones that came with your motherboard.

Try updating these and let me know how you went.

My System SpecsSystem Spec

21 May 2010   #34

Windows 7

I'm using Realtek High Definition Audio Card and WinFast TV2000 XP Expert on a Windows 7 Ultimate 32-bit (Built 7600) with the default drivers and had the same audio problem. To resolve this problem go to Control Panel > Hardware and Sound > Sound > Recording Tab and right click on the window, check "Show Disabled Devices", then enable CD Audio, right click on it and select Properties, go to Listen Tab and check "Listen to this device" then go to Levels Tab and adjust volume, next... make all the advanced settings you want, what I've wrote here worked for me.
Sorry for my english.Cheers!
My System SpecsSystem Spec
24 May 2010   #35

Windows 7 Ultimate 64-bit

This page has links to a lot of Leadtek drivers (Win 7 and 64-bit):

Good luck!
My System SpecsSystem Spec
27 May 2012   #36

Windows 7 Home Premium 32bit.

Here is link to new beta version:

I have the same problem with the sound, I've tried to get the version pvr2 2. 0. 3. 22 from your old link, but it tells me that the page is unavailable, the same story with the link from the new beta version, I've also tried to find the version on the internet, but nothing succesfull. If you can give me another link for pvr2 2. 0. 3. 22, it will be great

My System SpecsSystem Spec

 WinFast TV2000 XP Expert driver problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Leadtek Winfast PVR2000 rtm driver
Hi all I have the Leadtek winfast pvr2000 tv card and it works under vista 32b without problems. I installed the seven rtm 32b and I met problems with this card.:cry: Windows 7 freezes with a black screen during channel scan. All is locked, no mouse, and keyboard led doesn't work respond...
Need expert for difficult computer problem - random crash/lockups
I've been building PCs for my personal use for almost 20 years, and my latest HTPC I built about 8 months ago. It's fairly basic, a Gigabyte motherboard with 8GB RAM (2 sticks), a Sandy Bridge i3, a BD drive, and a RAID card with 3 attached HDs in a case with an Antec Earthwatts 380W PSU. It ran...
BSOD Help and Support
Need driver help with WinFast TV2000 XP Deluxe
Ok so its a while Windows 7 released and i installed it on my Windows XP Professional Computer (Not Laptop). So eversince then i could watch TV with my WinFast TV2000 XP Deluxe Card. Now that i have Windows 7 Home Premium x86 (32bit) i dont find drivers. I only find for WinFast TV2000 XP Global and...
what is the winfast screen i get??
hello folks,this is my first post with a problem i am looking for a solution for,so please bare with me! im running windows 7 hp and thanks to this forum have reduced my boot up time from eleven mins to a respectable 2 mins something. however,when i hit the power button to turn on my...
Performance & Maintenance
winfast pvr 2000 expert windows7 64 bit problem
I just installed winfast pvr 2000 expert on windows7 64bit and when i turn tv on, its say "cannot find any video capture device" if you guys know the answer for that slagin problem. Send answer on gmail and thank you very much, take care all !

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:40.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App