Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: win 7 doesn't recognize NEC usb 3.0 driver


24 Mar 2011   #1

Windows 7 Professional x64
 
 
win 7 doesn't recognize NEC usb 3.0 driver

Hi! New to this forum and hope someone can help.

Just installed WD My Book 3.0 (usb 2/3). Followed user guide, installed NEC usb 3.0 driver v.1.0.18 first from cd, then NEC usb 3.0 pci-e card in empty pci-e slot on Rampage Formula mobo - yes, I know this is not a usb 3.0 mobo, but according to multiple sources a usb 3 pci-e card should work ok with the correct driver. Connected to ext. drive using supplied 3.0 cable and booted. Win 7 x64 recognized ext. drive but installed its generic ms usb 2.0 driver (dated 6/21/06, vers. 6.1.7600.16385) without giving me an opportunity to select/load the 3.0 driver I had installed from cd. Checked, and the cd installation did correctly install 2 driver files (nusb3hub.sys & nusb3xhc.sys) to windows\system 32\drivers folder. Moreover, there is usb 3.0 hub controller showing in start menu. But according to usb properties window, the above ms usb 2.0 driver is the one being used. If I try to update driver and point win to usb 3 driver, it tells me the current driver (i.e. usb 2.0) is best driver and won't let me go further. If I try to uninstall this driver then when I reboot win again installs the same usb 2.0 driver without giving me option of selecting the 3.0 driver from cd. Tech support at WD really couldn't help, told me to "ignore" the info about generic ms driver installed, and that my ext. drive was operating at 3.0 speed. I did a check, copying 13 GB file from int. hd to ext. drive. Took 4 min, 20 secs. If I did the math correctly, this is approx. 400 Mbps, which is 2.0 speed and not anywhere close to "theoretical" 3.0 speed of 5 Gbps. I have tried reinstalling the NEC 3.0 driver, with same results. By the way, the ext. drive otherwise works just fine!
So, basically, the ext. drive and the usb 3.0 pci-e card are recognized, but for some reason win 7 doesn't recognize/allow loading the usb 3.0 driver and I'm still at usb 2.0 speed.
Anybody had a similar problem, or can suggest a solution?

Just checked again in device mgr. Under "disk drives" > My Book 3.0 > driver, it is showing the generic ms usb 2.0 driver. But under "USB Controllers" > NEC USB 3.0 Host Controller and also under NEC USB 3.0 Root Hub both locations show the NEC USB 3.0 driver. So was the WD techie correct? Do I just ignore the usb 2.0 driver listed under the disk drive itself, and is this the best speed (400 Mbps) I can expect under 3.0 (I know the 5 Gbps 3.0 spec is just theoretical)? Or should the drive itself in device mgr also be showing the usb 3.0 driver?


My System SpecsSystem Spec
.

24 Mar 2011   #2

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by drtim View Post
Hi! New to this forum and hope someone can help.

Just installed WD My Book 3.0 (usb 2/3). Followed user guide, installed NEC usb 3.0 driver v.1.0.18 first from cd, then NEC usb 3.0 pci-e card in empty pci-e slot on Rampage Formula mobo - yes, I know this is not a usb 3.0 mobo, but according to multiple sources a usb 3 pci-e card should work ok with the correct driver. Connected to ext. drive using supplied 3.0 cable and booted. Win 7 x64 recognized ext. drive but installed its generic ms usb 2.0 driver (dated 6/21/06, vers. 6.1.7600.16385) without giving me an opportunity to select/load the 3.0 driver I had installed from cd. Checked, and the cd installation did correctly install 2 driver files (nusb3hub.sys & nusb3xhc.sys) to windows\system 32\drivers folder. Moreover, there is usb 3.0 hub controller showing in start menu. But according to usb properties window, the above ms usb 2.0 driver is the one being used. If I try to update driver and point win to usb 3 driver, it tells me the current driver (i.e. usb 2.0) is best driver and won't let me go further. If I try to uninstall this driver then when I reboot win again installs the same usb 2.0 driver without giving me option of selecting the 3.0 driver from cd. Tech support at WD really couldn't help, told me to "ignore" the info about generic ms driver installed, and that my ext. drive was operating at 3.0 speed. I did a check, copying 13 GB file from int. hd to ext. drive. Took 4 min, 20 secs. If I did the math correctly, this is approx. 400 Mbps, which is 2.0 speed and not anywhere close to "theoretical" 3.0 speed of 5 Gbps. I have tried reinstalling the NEC 3.0 driver, with same results. By the way, the ext. drive otherwise works just fine!
So, basically, the ext. drive and the usb 3.0 pci-e card are recognized, but for some reason win 7 doesn't recognize/allow loading the usb 3.0 driver and I'm still at usb 2.0 speed.
Anybody had a similar problem, or can suggest a solution?

Just checked again in device mgr. Under "disk drives" > My Book 3.0 > driver, it is showing the generic ms usb 2.0 driver. But under "USB Controllers" > NEC USB 3.0 Host Controller and also under NEC USB 3.0 Root Hub both locations show the NEC USB 3.0 driver. So was the WD techie correct? Do I just ignore the usb 2.0 driver listed under the disk drive itself, and is this the best speed (400 Mbps) I can expect under 3.0 (I know the 5 Gbps 3.0 spec is just theoretical)? Or should the drive itself in device mgr also be showing the usb 3.0 driver?
Hi and welcome to SF!
Correct me if I'm wrong. You said to have used the pci-e connection to install your hdd. However, it seems weird that you mention "usb" driver in device manager?! I suppose you were to look under "System Devices", don't you?!
My System SpecsSystem Spec
24 Mar 2011   #3

Windows 7 Professional x64
 
 

Hi & thx for your reply, Wallonn 7. Sorry if what I posted confused you (I know it was long-winded, but tried to cover all the bases).

I installed a dual-port usb 3.0 card (which came bundled with the external WD My Book 3.0) in an empty pci-e slot, as per the requirements for this card. Even though it has to be installed in a pci-e slot, it shows up on dev. mgr. as a (external) hd under "Disk Drives", and when you go to properties under the My Book drive, then driver, it lists the generic ms usb 2.0 driver. But if you go down further in dev. mgr., under "USB Controllers", there are entries for the NEC USB 3.0 Host Controller and also for the NEC USB 3.0 Root Hub, and both of these entries (under properties>driver) show the NEC USB 3.0 driver (which is correct). But why doesn't the first entry, under disk drives>My Book>properties>driver, show the same usb 3.0 driver? Instead it's showing a 2.0 driver which it appears win 7 "defaulted to", and my file transfer speed to the external drive seems to confirm it's operating as a usb 2.0 drive. So win 7 seems to recognize there is something called a "NEC USB 3.0 driver", but it failed (won't let me) assign that driver to the external hd.
My System SpecsSystem Spec
.


24 Mar 2011   #4

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by drtim View Post
I know the 5 Gbps 3.0 spec is just theoretical?
Hello drtim The actual speed you can expect from usb3 tends to be very similar to sata speeds.

See the attachment

Actual speeds will vary depending on type of data being transferred and types of HDD, SSD etc

It is however clearly faster than usb2 my set up rarely got over 25MB/Sec
I hope this helps


Attached Images
 
My System SpecsSystem Spec
24 Mar 2011   #5

Windows 7 Professional x64
 
 

Hey Pooch -

Thx for your comments. Yeah, I know a lot of factors can affect usb 3/2 speed, and my current est. speed of 400 Mbps is definitely faster that I was getting with an older, usb 2.0 drive. But my internal drive that I was copying from in the test referenced has a transfer rate of 3 Gbps, and the nec usb 3.0 card by definition has a theoretical limit of 5 Gbps -- plus I'm using AHCI interface. It just bugs me that in device mgr. the driver for the external hd appears to be a ms legacy usb 2.0. Maybe I'm being stupid, but it still seems to me that win 7 should have used/accepted the usb 3.0 driver I "supplied" for this drive.
My System SpecsSystem Spec
24 Mar 2011   #6

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by drtim View Post
Hey Pooch -

Thx for your comments. Yeah, I know a lot of factors can affect usb 3/2 speed, and my current est. speed of 400 Mbps is definitely faster that I was getting with an older, usb 2.0 drive. But my internal drive that I was copying from in the test referenced has a transfer rate of 3 Gbps, and the nec usb 3.0 card by definition has a theoretical limit of 5 Gbps -- plus I'm using AHCI interface. It just bugs me that in device mgr. the driver for the external hd appears to be a ms legacy usb 2.0. Maybe I'm being stupid, but it still seems to me that win 7 should have used/accepted the usb 3.0 driver I "supplied" for this drive.
Could you post an attachment from Device manager showing the driver?

Edit it should look something like this one


Attached Images
 
My System SpecsSystem Spec
24 Mar 2011   #7

Windows 7 Professional x64
 
 

Pooch -

I attached a shot of device mgr. open to disk drives > My Book 3.0 > properties > driver, showing what I believe is a legacy ms usb 2.0 driver.

Let me know what you think. Gotta go now, but I'll check back on the thread tomorrow. Thx.

Attachment 145350
My System SpecsSystem Spec
24 Mar 2011   #8

Win 7 ultimate x64 sp1
 
 

renesas took over from nec, i have a similar nec based usb3 pci-e card, works fine in Windows 7 x64.


you can download the latest Windows 7 x86/x64 drivers at:

Code:
http://www.station-drivers.com/page/nec.htm
my 8gb usb flash drive runs at almost 3x what it does in a usb2 port.

edited: noted 2.0.34 is latest, i also just updated mine to that from 2.0.32 within the last few minutes. added new screen shot...


Attached Images
  
My System SpecsSystem Spec
24 Mar 2011   #9

Windows 7 Professional
 
 

Here are the latest drivers for NEC USB 3.0 chipset compatible with Windows 7 32/64-bit:

NEC USB 3.0 Host Controller | Catalog - News, articles, free drivers and firmware catalog: X-DRIVERS.COM

I should uninstall the old USB 3.0 drivers first either via Windows Unistall Manager (Control Panel > Programs and Features) or manually (Control Panel > Device Manager) select and device and right click uninstall and remove driver from computer. Then proceed to install the new driver once your sure you've completely uninstalled the old one.

My System SpecsSystem Spec
24 Mar 2011   #10

Win 7 ultimate x64 sp1
 
 

same drivers as in my post mine also has the latest firmware update to build 3027. see release notes (generated when you run the exe - an archive self extracter)
My System SpecsSystem Spec
Reply

 win 7 doesn't recognize NEC usb 3.0 driver




Thread Tools



Similar help and support threads for2: win 7 doesn't recognize NEC usb 3.0 driver
Thread Forum
Solved WG111 OS doesn't recognize driver Network & Sharing
Solved How do I reformat a HDD that W7 doesn't recognize? Hardware & Devices
My computer doesn't recognize my usb. Hardware & Devices
0xc0000428 Windows doesn't recognize driver signature. BSOD Help and Support
Repair doesn't Recognize my Win 7 OS BSOD Help and Support
Seven doesn't recognize my microphone Sound & Audio
Windows 7 Doesn't recognize USB HD Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:38 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33