Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AHCI-mode on Marvell 9128 controller in Windows 7 Ultimate x64

23 Jul 2011   #31

Windows 7 64 bit SP1
 
 

Windows MSAHCI drivers will work with the Marvell chipset. You don't need drivers. I have run with both the Marvell and Microsoft drivers and the Marvell are slightly faster for a SATA 3 SSD.

Also, you are using very old versions of the Marvell drivers. Try the 1.2.0.1002 at Marvell drivers I have been running them for months.

Having said that, your SATA 2 SSD will not see any benefit from The Marvell port. You will get better performance using one of your board's Intel SATA 2 ports and the Intel iastor drivers.


My System SpecsSystem Spec
.

23 Jul 2011   #32

Windows 7 64 bit SP1
 
 

Quote   Quote: Originally Posted by RickVB View Post
Guys, sorry, new to this forum, but rather than start a new thead I believe my question is pertinent here. As you can see from my system specs, I'm running a Gigabyte mb with the Marvell 9128. I can't find the "1051 driver" you guys are referring to. The Gigabyte website has only "Marvell Console Driver (SATA3) vers. 1.0.0.1027" and "Marvell RAID Utility (SATA3) vers. 4.1.0.1700" available. I'm assuming the "Console Driver" is what we're talking about here.

The French website cited earlier in this thread doesn't have any "1051" version; rather it has "drivers" vers. 1.2.0.1003 and "Marvell Storage Utility 4.1.0.1915". Has anyone tried these, or do you have another location for "1051"?
Use the 1.2.0.1002 drivers from that French site. The 1.2.0.1003 drivers have a bug in that a unchecking "Enable Safely Remove Disk" has no effect and all of your internal drives will appear as hot swappable and removable in the "Safely Remove Hardware" system tray utility.
My System SpecsSystem Spec
05 Oct 2011   #33

Windows 7 Ultimate 64-bit
 
 

Yesterday I clicked update driver in Device Manager and Windows 7 updated my 9128 driver from v1.2.0.1002 to v1.2.0.1003. I can confirm the 1.2.0.1003 drivers for the Marvell 9128 have the bug GeneO mentioned.
I just noticed Station Drivers now has a v1.2.0.1006 driver on their site.
I will give it a try when I get time.
My System SpecsSystem Spec
.


05 Nov 2011   #34

Win7 Pro 64-bit sp1
 
 

Both of these are from station-drivers' website where I downloaded them:

APRIL 25, 2011 - - - - marvell_91xx_1.2.0.1200_1.1.0.6(www . station-drivers .com).exe

Today, Nov 5, 2011 - marvell_91xx_1.2.0.1006-WHQL(www . station-drivers . com).exe

(w/out the spaces of course)

Am I crazy or does the previous release have a higher number? (I suppose both could be true )

I saved both on my HDD so I know I typed their names correctly.

I finally gave up on the Marvell 91xx back in April, switched to the msahci driver.
I really hope you have better experiences with them than I did.
My System SpecsSystem Spec
06 Nov 2011   #35

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by rcanino View Post
Both of these are from station-drivers' website where I downloaded them:

APRIL 25, 2011 - - - - marvell_91xx_1.2.0.1200_1.1.0.6(www . station-drivers .com).exe

Today, Nov 5, 2011 - marvell_91xx_1.2.0.1006-WHQL(www . station-drivers . com).exe

(w/out the spaces of course)

Am I crazy or does the previous release have a higher number? (I suppose both could be true )

I saved both on my HDD so I know I typed their names correctly.

I finally gave up on the Marvell 91xx back in April, switched to the msahci driver.
I really hope you have better experiences with them than I did.
I'm using the driver v1.2.0.1006. It still has the "Safely Remove Hardware" icon in the system tray but it doesn't let me disconnect my SSD accidentally - says "drive in use" so I have just left it. I'm used to it now.
My System SpecsSystem Spec
07 Nov 2011   #36

Win7 Pro 64-bit sp1
 
 

Good to hear it's working for you Z -

I guess I'm the only one bothered by the numbering scheme.
My System SpecsSystem Spec
01 Dec 2012   #37

Windows 7 Ultimate x64
 
 
New: trying to install Win 7 on Marvell 9128 RAID-1 SSD array.

I'm frustrated at how it seems that they never try the obvious configuration, and then say that their stuff is "compatible".

My board is a Gigabyte GA-P55A-UD6
I've disconnected all other hard drives. Only working with the Marvell 9128.
On the Marvell, I have two SanDisk Extreme 120GB SSD, set as RAID-1.

I figure that should give some serious throughput - two 6 GB/s drives/channels in RAID 1 should be VERY fast for read, and decent for write but I don't expect that much writing will happen.

But... Windows 7 won't install. I would NEVER leave a customer site with my software not working. Yet, windows 7 won't install on this obvious win of an installation. Nor an error message except "Doesn't work. Try something else." Why is it that all the cutting edge technology is great for promises and sales, yet doesn't work? And how do they get away with that? Sigh.
My System SpecsSystem Spec
06 Sep 2013   #38

Win8 x64
 
 

can somebody tell me the max (write) speeds you ever had with the marvell controller?
i can't get out more than about 180mb/s write speed (max i ever saw was 185 in crystal disk mark).
on intel i've got +/- 300mb/s with my 2hdd raid 0.

with my kingston hyperX ssds i saw more read speed but even less write speed, even if they are much faster!

thanks for your infos!
My System SpecsSystem Spec
Reply

 AHCI-mode on Marvell 9128 controller in Windows 7 Ultimate x64




Thread Tools



Similar help and support threads for2: AHCI-mode on Marvell 9128 controller in Windows 7 Ultimate x64
Thread Forum
How do I disable a Marvell Controller? General Discussion
change storage controller to AHCI mode post install (win7 64-Ultimate) Performance & Maintenance
Asus P6x58D-E Marvell 9128 SATA 3 problems Hardware & Devices
Marvell 9128 Problem? Hardware & Devices
Intel ICH10R vs Marvell 9128 raid 0 performance Hardware & Devices
Marvell 9128 Sata 3.0 [6Gb/s] manifesting as IDE Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33