Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless Card TP Link TL-WN951N

10 Jun 2011   #1
beauparc

Windows 7 64 bit
 
 
Wireless Card TP Link TL-WN951N

I've just been having trouble trying to update the drivers for this card.

The latest drivers have been downloaded and unzipped into a folder on the desktop. In Device Manager I click on the card's properties and select "Upgrade Driver" and point it to the correct location. Windows 7 thinks about it for a while and then tells me that "The latest driver is already installed".

It's not, the older driver is still showing.

I tried running the setup file in the driver folder which seemed to install OK.

Restart and check but still the old driver is showing.

I was thinking of uninstalling the old driver and then trying again, but not sure if this will work.

Anyone got any ideas, please? I'd be very grateful.


My System SpecsSystem Spec
.

10 Jun 2011   #2
Wallonn7

Windows 7 Ultimate x64 SP1
 
 

Hi beauparc.
Try running the setup instead of installing it via the device manager as you did. Another thing to take into account is that there are probably other files that need to be updated and not just the driver, which would explain Windows behavior - "the best driver is already installed".
Hope that helps.
My System SpecsSystem Spec
11 Jun 2011   #3
beauparc

Windows 7 64 bit
 
 

Hi Wallonn7 and thanks for your reply.

I've tried running the setup file which came with the driver. Everything seemed to install properly and it told me to restart, which I did. Having done so, I found that the older drivers were still installed.

I'm going to dig a bit deeper over this weekend and see what's going on. Hopefully I'll get it sorted and let you know on Monday.

Have a good weekend and thanks again for replying.
My System SpecsSystem Spec
.


11 Jun 2011   #4
Wallonn7

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by beauparc View Post
Hi Wallonn7 and thanks for your reply.

I've tried running the setup file which came with the driver. Everything seemed to install properly and it told me to restart, which I did. Having done so, I found that the older drivers were still installed.

I'm going to dig a bit deeper over this weekend and see what's going on. Hopefully I'll get it sorted and let you know on Monday.

Have a good weekend and thanks again for replying.

My pleasure.
Try these guidelines:
  1. Turn off the PC.
  2. Disconnect the device from the motherboard.
  3. Completely uninstall the drivers.
  4. Reboot and reinstall the drivers.
  5. Turn off the PC and reconnect the device.
  6. Turn on the PC again and see if it worked.
My System SpecsSystem Spec
Reply

 Wireless Card TP Link TL-WN951N




Thread Tools





Similar help and support threads
Thread Forum
D-Link DWA-123 Wireless N 150 USB Adapter
Where can download D-Link DWA-123 Wireless N 150 USB Adapter ? Version : B1
Network & Sharing
Can't connect to wireless on D-Link DIR-600
Hi guys. Need your help with this. Since two days ago, I have not been able to connect through WiFi to my dlink router. The computer that's connected to the router through the lan cable is fine and able to connect to the internet. But when I try to connect my laptop wirelessly, it says...
Network & Sharing
TP-LINK TL-WN350G Wireless card problem
Hi, ive got a new computer with windows 7 and i recently brought a TP-LINK TL-WN350G Wireless card and it seems to turn off and on sometimes.eg. when i am talking to my friend on skype, i cant do anything on the internet or else it will stop the conversation. Also sometimes when i download files...
Network & Sharing
TP-Link TL-WN620G wireless card issue
FYI. I had a problem with my TL-WN620G card and Windows 7 releases 7000, 7100 & 7127. The drivers would install fine, however, Win 7 was unable to connect to the internet without me setting up my wireless connection. After a reboot Win 7 would not connect unless I either reconnected the card or...
Network & Sharing
D-link Wireless DWA-547 probelm!
Hello! I'm using windows 7, and I can't get DWA-547 to work. It can't find any connections. I used D-links newest driver I could find. I have older ZyXel 302-v3, which works. Any ideas? My setup: Intel P67-Motherboard, SATA 6Gbps, USB 3.0 Intel Core i5 2500K -CPU, 3.3GHz 8GB DDR3 1333MHz...
Network & Sharing
Wireless DI-524 D-link router
Hello Dear friends... How are you? I have experienced certain problems with that router, DI-524 150MB D-link router... It works just fine with windows seven except for the fact that it requires me to switch it off at every 6 or 10 hours (as suggested by win 7's troubleshooter) Unplug...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App