Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Focusrite Saffire problem

11 Jan 2009   #1
gingercat

Windows 7
 
 
Focusrite Saffire problem

Has anyone managed to get their Focusrite Saffire to run with Windows 7 X64? The drivers installed OK, but the DSP won't boot. The saffire entries in device manager showed a failed driver load, so I manually pointed it to the saffire driver, but still the DSP fails to boot. Any ideas? The box does boot fine if I reboot into Vista.


My System SpecsSystem Spec
.
11 Jan 2009   #2
slowass

Windows 7
 
 

Im in the same confused position. Impossible to use Windows 7 if these drivers dont work. Guess the problem lies in the hands of Focusrite.
My System SpecsSystem Spec
12 Jan 2009   #3
kimster

Windows 7 x64 build 7000
 
 

Have you guys gotten the audio part of of your Saffires to work, just not the DSP? I have a Saffire LE i can't get a sound from. I installed the latest driver (v1.3) no problems and then connected the LE. Now it shows up as a "61883 Device Class" instead of under "Sound, video and game controllers". Windows insists the "Device is working properly" but it doesn't show up in Control Panel / Sounds. And the lights on the LE stay amber instead of turning green.
My System SpecsSystem Spec
.

12 Jan 2009   #4
grimreaper

Windows 7 Ultimate X64
 
 

Welcome to the forums

You checked this link out?
Focusrite Audio Engineering | US Site | Support | Updates & Drivers: Saffire
My System SpecsSystem Spec
12 Jan 2009   #5
kimster

Windows 7 x64 build 7000
 
 

Yup. I've also mailed Focusrite support with this. I'll report back here if i hear anything. They might not be very interested in supporting a beta-version of Windows but i figured it can't hurt to ask.

edit: and thanks
My System SpecsSystem Spec
12 Jan 2009   #6
kimster

Windows 7 x64 build 7000
 
 
pix pix pix

My System SpecsSystem Spec
14 Jan 2009   #7
slowass

Windows 7
 
 

Might be a stupid question, but have anyone tried to use the AC power plug? I cant try this out myself cause I dont know where I've put mine, and only used FW-power to this date.

Also going to mail Focusrite to have them agnolige we want it fixed.
My System SpecsSystem Spec
15 Jan 2009   #8
gingercat

Windows 7
 
 

I've tried with the power adapter connected, no difference
My System SpecsSystem Spec
20 Jan 2009   #9
spazbob

Windows 7 x64
 
 

THE SOLUTION!

Unplug your Saffire LE

Open Computer Management, go to Device Manager.

Expand IEEE 1394 Bus host controllers

At this point you probably see Texas Instruments OHCI compliant controller or something

Right click on it and click Update Driver Software

Then click Browse my computer for driver software

Then click let me pick from a list

You should get at least three options.

Select 1394 OHCI Compliant Host Controller (Legacy)

Let that install.

Once it's done, reinstall the Saffire LE 1.3 drivers (this step possibly optional)

Now plug the device back in
My System SpecsSystem Spec
20 Jan 2009   #10
gingercat

Windows 7
 
 

Many thanks spazbob - that worked perfectly. Now to get Hauptwerk up and running!
My System SpecsSystem Spec
Reply

 Focusrite Saffire problem




Thread Tools




Similar help and support threads
Thread Forum
BSOD - Focusrite USB2 audio interface is the suspect
Hi guys, recently bought a digital audio workstation from Scan (UK based company) with a Focusrite audio interface. Been getting BSOD SYSTEM SERVICE EXCEPTION when running the sequencing software Cubase 7. The main culprit when the crashes occur is obviously the Focusrite interface but I can't be...
BSOD Help and Support
Focusrite Saffire Pro 24 Problem (Clicks - Pops)
I have a Focusrite Saffire Pro 24 sound card that has been tested on Windows XP (with a relatively old system : Intel Core 2 Duo, 2GB RAM etc) and it works perfectly fine. I bought a new PC a few weeks ago (Intel i5 -750 @ 2.66 GHz, 4GB RAM) and I have installed Windows 7 Professional 32-bit on...
Drivers
BSOD installing focusrite external Soundcard, ntoskrnl.exe error
Hi There! I have a new PC from an online Audio-Shop, and have problems when installing my external Soundcard. The Pc works fine untill i Plug-In the usb cable of the Soundcard. After i have plugged in the usb Cable windows search for drivers in windows Update and then the pc crashs. Here is...
BSOD Help and Support
Focusrite Saffire Pro 24 DSP
Hi all I have been building my own computers for years, a new one about every two years. Each time I buy a new sound card, and have spent a lot in doing so. So now I have decided to use an audio interface, the Focusrite Saffire Pro 24 DSP as my main sound device. This way I can use it from computer...
Sound & Audio
BSOD with new Saffire Radeon HD 7850 2GB doing anything
BSOD with new Saffire Radeon HD 7850 2GB doing anything Hi, I'm new. I recently added 4x4GB of PNY ram to my Dell Studio XPS Core i7 system and replaced my Nvidia GT220 card. Then I started getting frequent bsods, about 8 a day. driver_irql_not_less_or_equal stop bsods in netio.sys...
BSOD Help and Support
Saffire Radeon HD 4350 hardware interrupts
Hey guys, i have just decided to turn my old computer into my media center so i decided to do a bit of upgrading, like up the ram, format and install Win7. all was fine with that. then i decided to get the HDMI crankin as well and have had nothing put problems. i tried a pci-e ATI HD...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App