Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No memory cards working (sd, micro sd etc)


11 Jul 2011   #1

Windows 7 Ultimate 64bit
 
 
No memory cards working (sd, micro sd etc)

Hello.

Iam having an issue that is relay starting to annoying.
The problem is that no kinds of storage cards are currently working perfect on my computer.

For an example no phones can be connected, have tryed 2 htc's with microsd cards, and a sony ericson with an m2 card, and same problem. Also if i try to open any SD cards, like camera it dosent work.

The thing is that it comes up as removable drive, but when i try to open it it just says please insert card. I have tryed deleting, installing reformatting drivers, and cards like crazy and its the same. I have also tryed changing the drive letters around but the issue is the same.

The only thing that makes the work is the following:

If i leave the card in the cardreader, or a phone connected, then restarts the pc whitout removing the card or phone, then it works when its rebooted. but asoon as i remove the card/phone and reinsert them the issue is still there "please insert card"

I have even changed the motherboard, cpu, and memory, and formated the computer 3 times but still same issue. So im thinking that windows is installing wrong driver or something?

Any new drivers to motherboard, phone or cardreader dosent help, It must be windows related?

Also all the cards and phones works 100% on my 3rd computer also running windows 7, But my old 1, and this 1 have the same issue.

The specs on current pc are:

Motherboard: Asus P8P67 Deluxe
CPU: Intel I7 2600+
Memory: Corsair Vengance 6gb 1600MHz (spesific made with 1.5v for the sandybridge motherboards)

Also the issue was the same on my old computer also running windows 7 that had a socket 775 build.

Any1 been having the same issue?

Regards: Daniel

My System SpecsSystem Spec
.

11 Jul 2011   #2

Ubuntu 12.10
 
 

Could you tell me the make and model of your card reader?
My System SpecsSystem Spec
11 Jul 2011   #3

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by SlasherIT View Post
Could you tell me the make and model of your card reader?
Its some all in 1 hdd docking station nonbranded, However the card/docking station is not the problem, since phones, cameras, ++ everything that used a card got the same issue, if i connect the phone with usb, camera with usb etc etc, or the card into a reader (got 2) it's the same,
My System SpecsSystem Spec
.


11 Jul 2011   #4

Ubuntu 12.10
 
 

Hmmm, how about if you plug a USB Memory Stick into the USB port, does it work or not?
My System SpecsSystem Spec
12 Jul 2011   #5

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by SlasherIT View Post
Hmmm, how about if you plug a USB Memory Stick into the USB port, does it work or not?
a standar usb stick works, but everything that uses some kind of sd/micro sd card does not work, regardless of what form they are entered, like usb, adapter, cardreader etc maks no diffrence, but as i said in the first post, if i put the card/phone whatever in the pc, reboots the pc, it works untill i put them out and in again... rly strange
My System SpecsSystem Spec
12 Jul 2011   #6

Ubuntu 12.10
 
 

Hmmm,

Is your BIOS updated to the latest version?
My System SpecsSystem Spec
12 Jul 2011   #7

Windows 7 Ultimate x64
 
 

I have similar problems using a USB card reader if I remove the card from the card reader and then reinsert it nothing happens, however if I remove the card reader insert the card and reinsert the card reader it works.
I haven't found an answer yet, but logging out and back in also works for me and its a lot faster than a new start.
My System SpecsSystem Spec
13 Jul 2011   #8

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by SlasherIT View Post
Hmmm,

Is your BIOS updated to the latest version?
yes it is, and as i said, this problem was also on on my old computer, so its not hardware related at all. It seems that windows are loading the wrong drivers except when i boot up the first time or something
My System SpecsSystem Spec
13 Jul 2011   #9

Windows 7 Ultimate x64 SP1
 
 

That sounds typical for a generic card reader. I had similar issues with one and ditched it for a Rosewill from Newegg.
My System SpecsSystem Spec
13 Jul 2011   #10
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

How is the card reader attached?
My System SpecsSystem Spec
Reply

 No memory cards working (sd, micro sd etc)




Thread Tools



Similar help and support threads for2: No memory cards working (sd, micro sd etc)
Thread Forum
Remove read only write protection on micro sd 2GB memory card General Discussion
Remove read only write protection on micro sd 2GB memory card Hardware & Devices
Rocketfish Micro-USB Bluetooth Adapter Not working. Hardware & Devices
windows corrupting my memory cards!! Music, Pictures & Video
SSD or Micro sdHC cards ?? Hardware & Devices
Why my memory cards Mhz's are low? Hardware & Devices
vaio-vgn-cr205e webcam and memory cards are not working Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33