Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Driver Issue! Please Help!

20 Jul 2011   #1

Windows 7 64bit
Driver Issue! Please Help!

Im probably just missing something small here but my computer was running very slow so i decided to wipe the hdd clean and install a fresh copy of windows 7 64bit. I formatted it through the cd at boot and installed windows 7. Went smoothly until i logged in and noticed i had no drivers at all. My ethernet driver isnt working so no internet. Hybranate isnt available for some reason. It just seams like windows 7 didnt install any drivers with the OS and when i try to install them through the device manager, it tells me it couldnt find a driver for the device and obviously, i cant check online. Please help. Im not at all new to installing OS's but this has never happened before. Thanks in advance for any tips

My System SpecsSystem Spec
20 Jul 2011   #2

Windows 7 Pro x64 SP1 and Mac OS X 10.8.3

OK, please fill in your motherboard specs in your profile so that we know what you have so we can help you. We can not help you if we do not know what you are running.
My System SpecsSystem Spec
20 Jul 2011   #3

Windows 7 64bit

Thank you for responding so quickly, im not sure however on the specs of my motherboard. I know its a Gigibyte mb, and i have 8gigs of ddr3 ram, a GTX 560ti, and a i5 760 processor and the hdd is a 1tb 7200rpm. I wish i could tell you more but thats all i know..
My System SpecsSystem Spec

20 Jul 2011   #4

Windows 7 Ultimate SP1 64-Bit

Who made your computer? If we knew that we could point you to the manfacturer's support page.

Do you have a factory restore partition and/or factory recovery disks?

It sounds as though you've carried out a clean install of Windows 7 and now your system is lacking drivers.

You can get all the drivers you need from your manufacturer's support site so let us know who built your computer as even a model name would help us.
My System SpecsSystem Spec

 Driver Issue! Please Help!

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Driver issue
I have a graphics card usr5699b that was working for a short time on win 7 but after 2 days it caused my video cards to mess up possible driver issue or irq conflict. Is there anyway to make the drivers compatible with win 7? thx
2 new NIC's driver issue
Hi, Older system, upgraded from XP to Win7 (32bit) a while back - has been working fine. Have been having issues with internet "dropping out" fairly regularly. ISP says problem on my end, so decided to install a new NIC. Disabled onboard NIC and pop'd in new PCI NIC. Windows 7 sees the new...
Hardware & Devices
driver issue
The other day I had to re-install my XP OS. For some reason, the CD my drivers came with didn't like the audio driver for some reason. Every other time I used this CD before, it always worked. I am getting an error of "Intel audio doesn't support the board listed. I went to the intel site to...
Can anyone help with this driver issue?
I was checking my drivers for current and found this coprocessor driver error. I've disabled the onboard Nvidia chip for the PCIe BFG GTX260 card, could this be it disabled or something else? This is the PCI bus 0, device 1, function 3 position and it's being called MSI-Nvidia ram controller....
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...
Driver issue?
After installing a windows 7 upgrade on my acer aspire 7535G my powerxpress no longer works - it thinks my onboard HD3200 is primary and my Mobility HD 4570 is powering another display - which it is not. any ideas how i can swap primary adapters back and get it so it thinks i have only 1...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:00.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App