Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Texas Instruments Multi Card Reader

26 Jul 2009   #1
ZonariAn

 
Texas Instruments Multi Card Reader

So I have an older laptop, an HP Pavillion DV5215us, that initially came with XP on it. That's fine. I put Windows 7 RC 32bit, runs fine. I installed all drivers from HP for my specific model computer, for Vista 32 bit, and ALL work just fine, except for one.

I installed and checked repeatedly the status of my drivers for the Texas Instruments Multi Card Reader. It says everything works fine. Providing I'm looking at the correct things...

In device manager I see 3 possibly 4 things relating to it (I could be looking at the wrong things, and forgive me for being a nub). I see:
1. Texas Instruments 1394 OHCI Compliant Host Controller
2. Texas Instruments PCIx21 Integrated FlashMedia Controller
3. Texas Instruments PCI-xx21/xx11 CardBus Controller with UltraMedia
4. SDA Standard Compliant SD Host Controller

All of the above are said to be working properly. I don't see the problem here. Searching the internet has done me no good on this issue.

Insert card: "read light" flashes once, as if it recognizes I just put an SD card into it. But then nothing happens. Not showing up in Computer.

Just to see if it worked, and to rule out any thing I "didn't" try, I even tried the XP version of the drivers to no avail. Well, I didn't try any 64 bit drivers, I am skeptical those would work.

What to do???


My System SpecsSystem Spec
.

26 Jul 2009   #2

Win 8 Release candidate 8400
 
 

Its pci or usb?
My System SpecsSystem Spec
26 Jul 2009   #3
ZonariAn

 

I'm assuming PCI considering it's integrated into the laptop itself.....

EDIT: Doesn't the information from the Device manager that I listed above state that it's PCI? Just wondering...

Also, it's not the first time I've installed these drivers, just the first time ever on Windows 7.
My System SpecsSystem Spec
.


27 Jul 2009   #4

Win 8 Release candidate 8400
 
 

yeah dev mange dies say pci just checking. have you tried un installing the driver and letting update find one for you ?

Ken
My System SpecsSystem Spec
27 Jul 2009   #5
ZonariAn

 

Quote   Quote: Originally Posted by zigzag3143 View Post
yeah dev mange dies say pci just checking. have you tried un installing the driver and letting update find one for you ?

Ken

Yeah...I have tried that. But I'm pretty sure this is a more advanced problem that can't be fixed with any sort of automatic update or install. *Sigh*
My System SpecsSystem Spec
27 Jul 2009   #6

 

Is the card empty or faulty? Insert a known good card with data.
My System SpecsSystem Spec
27 Jul 2009   #7
ZonariAn

 

Quote   Quote: Originally Posted by Antman View Post
Is the card empty or faulty? Insert a known good card with data.
No it isn't. I know it works because I've used it several times today on other computers through my handy USB SD card reader stick.
My System SpecsSystem Spec
28 Jul 2009   #8
ZonariAn

 

everyone give me the crown for being the queen of Noob.

My dumbass didn't remember that my card reader does not support SDHC.....

And I never bothered to check it.
My System SpecsSystem Spec
28 Jul 2009   #9

 

Quote   Quote: Originally Posted by ZonariAn View Post
everyone give me the crown for being the queen of Noob...
Queen? I am certain that a significant number of forum members see no need for forgiveness. They know all too well why.

"Dumbass" simply validates that your brains are installed elsewhere.

Welcome aboard.
My System SpecsSystem Spec
29 Jul 2009   #10
ZonariAn

 

Hahahaha, thanks for that....warm welcome. :P
My System SpecsSystem Spec
Reply

 Texas Instruments Multi Card Reader





Please note  Please note
        When your issue is fixed please remember to thank those that helped you and mark the thread as solved.
Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:46 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33