Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Atheros AR5005G "Peaks & Troughs" in download speed

05 Sep 2011   #1

Windows 7 Pro x64
 
 
Atheros AR5005G "Peaks & Troughs" in download speed

Hi,

I have an Atheros AR5005G 54Mbps Wifi card in my Acer Aspire 5051 laptop which runs on Windows 7 64-bit, I have always suffered with this problem and now im getting sick of it.

What happens is if I start a download on uTorrent (a torrent that is heavily seeded with seedboxes etc) the speed goes straight up to my max of 1.8MB/s (15Mbps) , it will stay for about 5-10 seconds then it will drop down to 20kbps and stay there for a short while, then it will quickly climb back up to 1.8MB/s (within 5-10 seconds) and the cycle repeats... when it 'troughs' down to 30Kbps or whatever the internet in Chrome & Firefox becomes extremely slow and sometimes unresponsive, uploads to Mediafire fail, I try the same torrent on LAN and it maxes out at 1.8MB/s and stays there without budging right to the end.. my wifi connection is on G only and is at full 54Mbps sync, I have tested it with file tranfer between another laptop and max speed was 18Mbps, so that is more than enough to cope with my 15Mbps traffic

Ive tried various drivers with varying results...
Microsofts default driver seems to work best but gets BSOD quite a bit, I used the "update" feature in devmgmnt which updated and stopped the BSOD but gives the problem I described, I then downloaded latest INF files from Atheros and tried those, v9 would cease up if you downloaded over 10Mbps and upload would not work, and v8 works fine but still has the problem I describe...

Atheros have many driver versions for the AR5005G so Iam going to back-track from the newest and try them and see if I can get one that doesnt have this problem..

has anyone else had problems like this?

EDIT: I may have solved this, I dropped back a couple of revisions on the driver which made it slightly better but I also change the wifi channel from 11 to 1 and changed from "G ONLY" to "B & G" (even though its a G card in laptop) and since doing so its been perfect, its early days though and I will report back later

thanks

My System SpecsSystem Spec
.

Reply

 Atheros AR5005G "Peaks & Troughs" in download speed





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:12 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33