Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer name in Devices and printer keeps changing every few seconds

13 Sep 2011   #1

Linux Mint 17 Cinnamon | Win 7 Ult x64
Printer name in Devices and printer keeps changing every few seconds


I have an MX850 and an MX870 printer both connected to my LAN.

I also use an application called CD Label Print. When I started that program I noticed that there were 3 MX850 printers listed, the original and a (Copy 1) and (Copy 2).

So I went to devices and printers and saw there was a MX850 and a MX850 (Copy 2). No (Copy 1). So I removed the (Copy 2) printer and fax.

I went back to CD Label print and saw that it still said MX850 and MX850 (Copy 1).

Went back to devices and printers and sure enough, MX850 was gone and MX850 (Copy 1) was present. So I pressed F5. It changed to MX850. Press F5 again, it changed back to MX850 (Copy 1).

It changes non-stop. It alternates betweem the two settings every time I press F5.

How do I fix this?

oh, btw; I've tried uninstall re-install. I've also contacted Canon support who are dumbfounded. I also had to manually remove the registry entries and start menu entries because the canon uninstaller doesn't so it.

And.. I cannot use CD Label print. Each time I try to print a label it insists on asking where to save the file, rather than printing it.


My System SpecsSystem Spec

14 Sep 2011   #2

Linux Mint 17 Cinnamon | Win 7 Ult x64

Found the solution...

For some bizarre reason the port assigned to both printers was FILE: God knows how that happened.

Once I set them to the correct ports that were created at install I could print properly and the alternating name in devices and printers stayed fixed.

My System SpecsSystem Spec

 Printer name in Devices and printer keeps changing every few seconds

Thread Tools

Similar help and support threads
Thread Forum
Printer Not Showing Up in Devices and Printers
Hi Guys, Have noticed others have had this issue but haven't found the answer yet - hence trying with my own thread. PC has Core i7 950 3.1 Ghz X58A-UD3R mobo, Win 7 home premium 64 bit. Printer is Brother HL-2240D mono laser, connected to PC through USB. The printer software loaded...
Hardware & Devices
After installing printer drivers, shutdown time drags on to 30 seconds
Hi, before I start I'd like to thank all of you and say that I'm running a windows 7 64bit system. Before I installed the drivers for my printer, an HP laser jet CP1025nw, my laptop's shutdown time skyrocketed from being 10 seconds usually, to over 30 seconds! Is this a known issue?...
Performance & Maintenance
Can't remove Printer from Devices and Printers
Hey all, Recently installed Win 7 Pro x64 and just trying to iron out some of the kinks. I had my printer installed and it was working fine but all of a sudden I couldn't get it out of "offline" mode. I read elsewhere to re-install the printer so I proceeded to remove the current one from...
Hardware & Devices
Devices and Printer's Blank
Hi, Let me start off by saying I built this computer about 6 or 7 months and had no issues like this until lately. When I try to open Microsoft Word, it hangs at "Connecting to Printer" and then becomes nonresponsive. Then, when I try to go into Devices and Printers, nothing is displayed and it...
Hardware & Devices
Devices and Printer Box Freezes
when I click on devices and printers, the menu freezes. It keeps showing the green loading bar for an indefinite amount of time. Any reason for this? I do not have any printers hooked up directly to the computer, just one I connect to through an ethernet wire. Thanks in advance.
General Discussion
No Devices and Printer Folder
Good day, I use win7 64 bit. I cannot open the folder devices and printer folder. The folder is empty. I can print correctly using MS office or others programs (see attached). Any suggestion please? Thank you in advance. Devcon
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App