Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IoGear GBU321 gives an error after installing updates.

11 Oct 2011   #1
repinscales

Windows 7 Ultimate 64 Bit
 
 
IoGear GBU321 gives an error after installing updates.

IoGear GBU321 USB to Bluetooth device.
Prior to downloading updates my USB - Bluetooth device worked great after the 89 updates then the 5 updates which one was Windows 7 64 Bit service pack 1, my device stops working.
Here is what pops up when i try to use it:
BTWUIEtx has stopped working.
-> Check online for solutions and close program.
-> Close program.
Of course I checked for online solution and nothing happens it just closes the program. I need this Bluetooth adapter to work. My only solution at this point is reinstalling the O.S. and not letting any windows updates in.
Anyone have any suggestions???


My System SpecsSystem Spec
.
11 Oct 2011   #2
sygnus21

Windows 10 Pro
 
 

Hi repinscales

I have an IO Gear GBU421 and it's working fine under Windows 7 x64 SP1 and all other updates.

I would suggest you completely uninstall the IO Gear software and try reinstalling it again. Don't use the drivers from the disk you have get them here - Drivers & Manuals - IOGEAR

Here's a warning for my adapter - IOGEAR TIL Document # 328. Not sure this applies to you but it's something to take note of.

You could also try using the Broadcom drivers as discussed here.... Latest Broadcom Bluetooth Driver

Let us know.
My System SpecsSystem Spec
11 Oct 2011   #3
repinscales

Windows 7 Ultimate 64 Bit
 
 

Thanks for the reply: sygnus21 I have uninstalled, reinstalled, and set the computer back to a date before the updates were installed to get this Bluetooth device to work. All have failed. I let windows install the drivers I used the disk to install the drives and went to the websites you listed too and all have failed. Are there any known hardware issues with video card drivers and this device? My card is an 8800gtx now mind you both were working fine together until the updates were added in. I have a feeling (because of bad luck) i will have to do a new install of windows 7 64bit to fix this problem.
My System SpecsSystem Spec
.

11 Oct 2011   #4
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by repinscales View Post
Are there any known hardware issues with video card drivers and this device? My card is an 8800gtx now mind you both were working fine together until the updates were added in.
There aren't any issues with video card drivers and Windows 7. With that said, one can always argue performance, but as far as working drivers, no.

I can't imagine why things would get so screwy doing updates unless the OS was problematic to begin with. BTW where did you get your OS?

BTW did you do an OS tweaks prior to the updates?

Quote   Quote: Originally Posted by repinscales View Post
Thanks for the reply: sygnus21 I have uninstalled, reinstalled, and set the computer back to a date before the updates were installed to get this Bluetooth device to work. All have failed. I let windows install the drivers I used the disk to install the drives and went to the websites you listed too and all have failed.
Well you can always try the Broadcom drivers. They're what I'm using for my IO Gear Blue Tooth device. You can get them here.... Broadcom.com - Bluetooth Software Download

As for needing to do an OS reinstall you can always try a Repair Install. However If you've installed SP1 and your disk doesn't have SP1 included, then it won't work.

Outside of that, yeah, you might need to do an OS reinstall, especially if you're having other issues as well.

PS> Make sure you're looking for 64-bit drivers since you have a 64-bit OS!
My System SpecsSystem Spec
Reply

 IoGear GBU321 gives an error after installing updates.




Thread Tools






Similar help and support threads
Thread Forum
BSOD when installing windows updates, error 0x019
I recently wiped my hard drive with dban using the autonuke option. It ran fine and finished sucesfully. I then installed windows 7 home premium x64 on that same hard drive. That also ran fine. I then updated through windows update, and some updates did install, inluding service pack 1. The bsod...
BSOD Help and Support
Windows Updates Not Installing : Error Unknown (Sits on Installing)
Hi, To give you some back story, I built my computer the end of August 2012. Ran Smoothly. I decided to get a 60 gig SSD to be the partition that stored Windows. I didnt have much stored on the Main HD so I deleted my original 2TB HD and tried installing on the SSD... found that the SSD was bad...
Windows Updates & Activation
Genuine Validation Error - Installing Updates Fails
I am attempting to correct an issue with Windows stating my copy is not genuine, I am also unable to install Windows updates, which I presume is part of the same issue. What I've done so far: I was able to run slui 3 and enter my key from the sticker and it was accepted. Thought maybe this...
Windows Updates & Activation
Windows 7 Updates Not installing Error TRUST_E_NOSIGNATURE(0x800b0100
Hi I recently Installed Windows 7 Ultimate 64bit and when updates and SP1 try to install i get this error TRUST_E_NOSIGNATURE(0x800b0100). Please don't tell me to re install windows because i only just did after my old hard drive failed.I found a thread on these forums where somone had a very...
Windows Updates & Activation
Windows 7 Updates Not installing Error TRUST_E_NOSIGNATURE 0x800b0100
Hi, I've been trying to update a PC running Win 7 HP x64 to SP1 and it keeps failing giving me the error in the thread title. I've done all the standard stuff for this error (ran System Update Readiness Tool etc...) and nothing is fixing it. I've attached the CheckSUR.log to this post. If...
Windows Updates & Activation
error installing updates
Windows is unable to install latest KB2532531, KB2533623, KB2555917 error configuring...reboots and then keeps asking again and again because of auto update. please help!
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App