Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Tried to update my AHCI drivers

18 Oct 2011   #1
nash04

Ultimate x64
 
 
Tried to update my AHCI drivers

Tried to update my AHCI drivers with Asus but WIN7 came back stating that their drivers were better than the ones ASUS have. Now install: Standard AHCI 1.0 Serial ATA Controller. The ASUS driver that I'm trying to install; AMD_RAIDAHCI_V3315402_V120010269_XPVistaWin7 on my F1A75-V PRO MB
It seems to be working fine but just would like the latest drivers install if possible.


My System SpecsSystem Spec
.
18 Oct 2011   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Get it from here,

AMD RAID/SATA Drivers

Asus may make good hardware, but they are one of the worst about providing driver updates much beyond one or two (if that) past what came on the driver disk. The board has an AMD chipset so just get them from AMD. That and I checked the INF in the one from Asus and the DevID's all match the one's in the reference AMD driver, so it will work on yours no problem.
My System SpecsSystem Spec
19 Oct 2011   #3
nash04

Ultimate x64
 
 

Thanks for the info, did download the files then installed it as an administrator and supposedly everything went fine but when I go back into device manager, it still displays that MS AHCI driver instead of the AMD? Weird!!
My System SpecsSystem Spec
.

19 Oct 2011   #4
nash04

Ultimate x64
 
 

Well! Spoke to MS and the reason that I've seing some hiccups with the software is due to the fact that this was a clean install with an upgrade dvd and not the full version. The upgrade is basically looking for an older OS version and there's none to be seen since this was a "clean" install so now I need to purchase a full version, anybody wants to buy an upgrade version of WIN7 Ultimate? lol!
My System SpecsSystem Spec
20 Oct 2011   #5
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

My System SpecsSystem Spec
Reply

 Tried to update my AHCI drivers




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
cloned C:, installed AHCI drivers, changed BIOS to AHCI, D:'s GPT gone
see second post. I have a 3TB drive D: for data formatted with GPT. Had BIOS OnChip SATA Type set as "RAID" "As SATA Type" from back in the day. When I took out the RAID, I forgot to change this to AHCI when I reformatted and got rid of RAID drives! Changing to "AHCI" "As SATA Type" as...
Installation & Setup
Win 7 64 bit problem with storage drivers AHCI etc.
Hi. I got .ISO file WINDOWS 7 Ultimate SP1 x64 September 2012 and I think each time I got same problem with that drivers, not recognize disk issue. few times I got same problem and each time diferent solution help. On Lenovo IdeaPad I just download THIS driver and all go OK. Than app...
Drivers
How to confirm I properly enabled AHCI and drivers
I went through the process of enabling AHCI on my already installed OS. My intel 520 series SSD had been running obviously slower and CrystalMark & AS SSD benchmarks confirmed it. I think everything went fine: Installed AMD AHCI/raid drivers from the ASUS web site, changed the registry, changed...
Drivers
Where can I get Atheros WNA AR9285 and ATA/ATAPI AHCI drivers
Hi, Have been looking all over the internet for these drivers, but without luck. I think the latest Atheros is 9.93, and I have 8.0.0. In another thread someone suggested PCPitStop - another one of those FREE driver sites, where you can get all the drivers you need; once you "register". I.e...
Drivers
AHCI Drivers Corrupt Windows 7
This happened when I was booting today after turning it of last night after using it successfully since I bought it. The AHCI Drivers are corrupt. Windows won't load, it is stuck on the load screen. Trying to repair windows using the various F8 options doesn't work because they won't load...
Drivers
Does Windows 7 have AHCI drivers at install
I have found on 4 different boards if I install in AHCI mode, Windows 7 seems to "find" the drivers for running in AHCI/RAID mode at install. If I install in IDE mode, it does not and I have no option to switch to AHCI/RAID if needed. In the past you had to press F6 (or whatever) and install them...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App