Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Uninstalled ATI drivers + Used Driver Sweeper = no USB on Restart

19 Oct 2011   #1

Windows 7 64bit
 
 
Uninstalled ATI drivers + Used Driver Sweeper = no USB on Restart

So I've been messing around with varrious driversdrivers to try and get the game "RAGE" working. Which is an exercise in futility but to make this tumultuous process more agravating I've somehow inadvertently uninstalled my USB drivers drivers as well.

This wouldn't be an issue, except that my computer has no PS2 ports.


long version:

I used "GPU caps viewer" to check my driver driver version on my graphics card (ATI Radeon XFX 6790) as I'd not noticed a change in my gaming performance and I was unsure if the "11.10 preview 2" drivers drivers had been installed properly. "GPU caps viewer" said I was still running 11.8 which is what I had before I tried changing drivers last time. So I guessed that my drivers had not changed dispite the fact I uninstalled/reinstalled using the guide on the AMD /ATI site.

So on a bunch of sites I saw people were using "DriverDriver Sweeper" to get rid of the registry files and hidden bits of the ATI/AMD drivers and softwaredrivers. I used this application, it found the drivers left overs and removed it and then asked if i wanted to reboot.

At this point the drivers are "uninstalled" and the generic windows driver is working because my resolution/aspect ratio is stuck at 4:3 and wont go 16:10/16:9. AND more importantly my USB devices were all still working.

I restart the computer and It loads windows and I try to type my password and nothing happens, The mouse cursor is in the middle of the screen and I can not move it, and there are no lights on my keyboard. The optical sensor in the bottom of my mouse also does not light up.

I restart again, and check the BIOS, all USB ports are enabled, so I try booting in to safe mode. I can use my keyboard to work in the BIOS, and to select "Safe mode with networking" (vs safe mode with out).

When safe mode loads, same issue. No power to USB devices.

I tested a bunch of devices; xbox controler; USB memory stick, external HDD etc. and none work.


I don't know what to do; the mouse and keyboard work in the recovery partition installed on my HDD, but I really don't want to lose all that data. Ill probably end up using a live CD of linux to get my files and then format the PC if I can't figure out how to fix this.


Any suggestions?

Thank you

Additional info:

Windows 7 Professional 64bit
HP branded computer
ATI Radeon XFX 6790
AMD 1065T x6 CSU
600watt PSU


My System SpecsSystem Spec
19 Oct 2011   #2

Windows 7 Home Premium 64 bit
 
 

It worked for me before.......boot into the safe mode two or three times.
You may get your USB connectivity back.
My System SpecsSystem Spec
19 Oct 2011   #3

Windows 7 64bit
 
 

So I've figured out that it is the drivers them selves that are the issue with my hardware. I reformatted my computer in order to fix the issue (I had recovery points disabled) and this time round I downloaded the drivers from another source; made a recovery point and installed/uninstalled/restarted and I had the exact same loss of USB power. So I'm stuck using the older drivers (instead of the Beta drivers for RAGE) for now.
My System SpecsSystem Spec
.


Reply

 Uninstalled ATI drivers + Used Driver Sweeper = no USB on Restart





Thread Tools



Similar help and support threads for2: Uninstalled ATI drivers + Used Driver Sweeper = no USB on Restart
Thread Forum
Driver Fusion uninstalled iexplore.exe when removing AMD drivers Drivers
Solved Where is Driver Sweeper Software
A little help with video drivers/Driver Sweeper please. Graphic Cards
Solved Driver Sweeper System Security
Anyone use driver sweeper? Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33