Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problem with install of ati display drivers

27 Oct 2011   #1

Win7 Home Premium x64 SP1
 
 
problem with install of ati display drivers

hi all
2day i started to update my gpu drivers to the 11.10 prev version 3 ready for BF3 2moz. only this time it was slightly differant. when i clicked the bottom option to remove all ati drivers. i got a warning that it may uninstall chipset drivers and somethin else. i havent had this b4. so i used the top option instead.(uninstall manager) checked all boxes as none mentioned chipset n so on. uninstalled, run driver sweeper. rebooted. then when i was installing the new drivers. i clicked select all. not thinking it was differant this time. everythin went fine untill i saw northbridge n usb filter drivers trying to install. then bsod.

i did a system restore. now everythin is ok. but ive stil got to install the new drivers.( unless bf3 runs ok on 11.10 prev version 1) anybody still using this set for bf3?

question ive never changed the chipset drivers b4 so not sure. do i now select express uninstall and remove chipset n usb drivers? (wouldnt of thought this necessary) or just use uninstall manager and uninstall just the display drivers and make sure all the other stuff is not ticked when reinstalling??

sorry for the noobish question but ive never come across this in ccc b4.

as always any help is greatly apreciated,, cheers folks

My System SpecsSystem Spec
.

27 Oct 2011   #2

Windows 8.1 Pro
 
 

When you go to uninstall the drivers through the ATI uninstall manager just do a custom uninstall and choose CCC and the video crad drivers only. Roboot, then do a custom install and just install the CCC and the video card drivers.

Name:  Choose uninstall items.JPG
Views: 16
Size:  61.4 KB

Name:  Cat Custom Install.JPG
Views: 15
Size:  71.8 KB

This of course assumes you don't want to update anything else, like the chipset drivers.

BTW since you have the drivers, just click them and choose uninstall when asked and follow the porcedures I outlined above. No need to go through "Programs and Features"

Name:  ATI Installation option.JPG
Views: 8
Size:  41.0 KB


My System SpecsSystem Spec
28 Oct 2011   #3

Win7 Home Premium x64 SP1
 
 

Hi sygnus21....thanks 4 the screenies
My System SpecsSystem Spec
.


28 Oct 2011   #4

Windows 8.1 Pro
 
 

Hope it helps. Let me know.
My System SpecsSystem Spec
28 Oct 2011   #5

Win7 Home Premium x64 SP1
 
 

ive been informed that the driver im already running is working good with bf3 on my card. so will give it a bash b4 changing them. thanks 4 the help tho. much apreciated
My System SpecsSystem Spec
28 Oct 2011   #6

Windows 8.1 Pro
 
 

No problem.

Good luck
My System SpecsSystem Spec
28 Oct 2011   #7

Win7 Home Premium x64 SP1
 
 

cheers
My System SpecsSystem Spec
29 Oct 2011   #8

windows 7 ultimate x64
 
 
windows donst boot corretly after installing ati gpu drivers

Hi all,

i got problem with installing drivers on my system. after installing win 7x64 ulitmate i installed ati drivers for x64 system ( i tried from windows update also from ati sites, also only drivers and whole package) and still the same problem-after rebooting windows dont boot corretly.

it hangs on the default wallpaper-no taskbar loaded, icons etc-like whole explorer got problem. task manager dont start-after pressing ctrl alt del comes black screen.
i installed windows many times ago and never had this problem before..
pleas give me any tips.

many thanks
Martin
My System SpecsSystem Spec
29 Oct 2011   #9

Windows 8.1 Pro
 
 

Quote   Quote: Originally Posted by martinesku View Post
it hangs on the default wallpaper-no taskabar loaded, icons etc-like whole explorer got problem. task manager dont start-after pressing ctrl alt del comes black screen.
Hi Martin, this sounds like a Windows issue as opposed to a GPU issue. After installing Windows please make sure you install the chipset drivers for the motherboard. Also get your drivers from AMD's website, don't use the Windows Update version since they generally lack other features a full feature set from the manufacturer may have, also the manufacturer may have newer improved drivers.

BTW we need to know your full system specs be be of more help.

Thanks.
My System SpecsSystem Spec
29 Oct 2011   #10

windows 7 ultimate x64
 
 

Thank you Sygnus,

yes, i tried this solution too, i installed drivers for chipset and for hdd, i dont install audio driver-because i use another sound card. But i will try to install this drivers too-to eliminate this possibly solution.
btw: my configuration is core 2duo E8400, asus P5B, Emu 1212m sound card, Ati 5770, 4gb ram, two HDDs,

P.s i tried also to install net framework c++ redistributable direct x and some updates for win before installation ati drivers..
My System SpecsSystem Spec
Reply

 problem with install of ati display drivers




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33