Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't uninstall High Definition Audio Device (Keeps installing)


20 Dec 2011   #11
moojo

Windows 7 64 Premium
 
 

Well my problems, where do i start ? Uhm i recently noticed that after my last Windows reinstall, that when i for example write this text, my screen freezes for about 2 sec every 10 sec or something. Really weird. Doesn't matter what browser i use. It's a new funny problem i just discovered (started to notice it after i update my USB sound card from steelseries).

But my real problem is that i get hard locks in Battlefield 3 and Heroes of Newerth. Can be from 10 min to 1 hour of gaming, then hardlock. When it crashes i can hear my graphiccards shutdown from 80% fan to like default 20% fan speed. I have to manually shutdown the computer. My temps are really nothing to be worried about. I have tried everything so i'm kinda desperate...


My System SpecsSystem Spec
20 Dec 2011   #12
marsmimar

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Quote:
Uhm i recently noticed that after my last Windows reinstall, that when i for example write this text, my screen freezes for about 2 sec every 10 sec or something. Really weird. Doesn't matter what browser i use. It's a new funny problem i just discovered (started to notice it after i update my USB sound card from steelseries).
Have you tried rolling back your sound card?

Might want to consider a Repair Install. Maybe the last install had a glitch of some kind.

Repair Install
My System SpecsSystem Spec
20 Dec 2011   #13
moojo

Windows 7 64 Premium
 
 

No i have just update to newer versions. But i guess i could try that. Thing is, if i use 1 graphic card, i don't crash. It has to be something with my SLI High Defintion Devices in Device Manager that doesn't cooperate. And i can't uninstall them due to the fact that they keeps reinstalling.

Anyways, i have now followed the guide, do i need to reinstall drivers? Seems my graphic driver needs to be reinstalled.
Thanks mate

Here is a screenshot of how it looks in Device manager
http://imageshack.us/photo/my-images...enshotlus.png/

You can see 2 High Defintion Audio devices CONTROL units (in the bottom of the shot).
It's usually 3, but i have disabled my Onboard sound card (Realtek)
And you can see 8 HD Audio Devices (done by the HD control units)
Then i have my Steelseriues USB Sound Card.

Is it good that just 1 of my graphic cards are installed?
My System SpecsSystem Spec
20 Dec 2011   #14
marsmimar

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

I suggest creating a free account with DriverMax and let it scan your system. It may show some related out of date driver(s) contributing to the problem. I've used DriverMax before with good results. As a free account holder you can download and install only 2 drivers a day. But if it points to some other problem areas you can always go to the manufacturer's website for downloads or information.

DriverMax - free driver updates

As always, create a new restore point (even better a system image) before you uninstall/install any software just in case something goes wrong.

System Restore Point - Create
My System SpecsSystem Spec
20 Jan 2012   #15
moojo

Windows 7 64 Premium
 
 

Ok some update.
I did a fresh install (correct this time with diskpart! Feels like a new computer, no stutter)

Anyway, i still can't play BF3 with sound..It freezes after sometime and i can't really figure out what to do. I'm 100% sure that it's because i have SLI and i have 3 HD audio devices controll units.

Any ideas guys?
My System SpecsSystem Spec
05 Aug 2012   #16
SwitchBl4De

Win 7 ultimate 64
 
 

Well I realise this thread is several months old but I was looking around for similar things and this thread was the first time ive come across anything similar.
Basically ive also had some black screens and lockups since sli-ing my gtx 580's, built the system Novemver 2011 and never had any till I added the 2nd 580 in June 2012.
After a few weeks it happened in BF3 where I had a black screen during play, then another then a 3rd which happened on the windows desktop then a 4th on the windows desktop aswell, the 4th was a hardlock not a black screen, all these 4 happened within about 20 minutes of each other.
On this occasion I reseated power cables and the sli bridge and it appeared to fix the issue. A few weeks later I had 2 black screens during Mass Effect 3 multiplayer, as the OP described the graphics card fans spun down when this happened, a few days later again I got a hard lock in ME3 and a black screen in windows, this time I completely removed the video drivers and did a clean install of them, and its been fine since. However its been on my mind since and ive still been looknig around for a solutuion as to what might cause it, this post appears to be it as, same as the OP, it must be related to the sli of the cards and in particular sounds like its these high definition audio devices.
I have now disabled the 2 HD audio controllers in system devices as described and its removed the HD audio devices in sound and game devices ( I also had 8 listed ) so will carry on and see if I get any more.
Has anyone else had similar issues and also has the OP got any further?

Many thanks.
My System SpecsSystem Spec
18 Aug 2012   #17
ericepp24

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by moojo View Post
Hi

So i have tried to uninstall this damn High definition Audio device. I have 8 of them (because i have SLI i guess). So i have tried follow this guide for example:
PROCEEDURE to PERMANENTLY DISABLE THE NVIDIA HD sound device(BLACK SCREEN & LOGIN FIX)

Didn't work. It started to install again when i go to windows.

If you would have installed the nVidia HD Audio drivers, the devices would not show up in the Playback Devices List. The drivers are included in the Nvidia Display Adapter driver package that you would normally download to update your Video cards. The reason all 8 devices were showing up in the Playback Devices List is because it had installed the Microsoft Driver for that device. I had the same issue after reinstalling Windows 7 yesterday. Installing the HD Audio drivers from nVidia removed them from my List. Now it just shows the LG TV that my 480 GTX is attached to via HDMI.
My System SpecsSystem Spec
Reply

 Can't uninstall High Definition Audio Device (Keeps installing)




Thread Tools



Similar help and support threads for2: Can't uninstall High Definition Audio Device (Keeps installing)
Thread Forum
High Definition Audio Device - No Sound Sound & Audio
Low bit rate only available for a high definition audio device. Sound & Audio
high definition audio device not working Sound & Audio
Phantom High Definition Audio Device Sound & Audio
High definition audio device PROBLEM Sound & Audio
No sound (High definition audio device) Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:35 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App