Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Just used @BIOS to update my BIOS, it failed at 50%


16 Dec 2011   #1

Windows 7 Ultimate x64
 
 
Just used @BIOS to update my BIOS, it failed at 50%

Now I don't want to shut down or restart my computer because I fear it won't boot up. This is awful. Is there anything I can do to restore my BIOS whilst my computer still works?

My System SpecsSystem Spec
.

16 Dec 2011   #2

Windows 7 Ultimate x64
 
 

Argh is there ANYTHING I can do? I'm going to have to leave my computer on permanently otherwise.
My System SpecsSystem Spec
16 Dec 2011   #3

Windows 7 Pro x64 -- PCLinuxOS KDE4 FullMonty 2011
 
 

No point leaving it on. If the board has a backup bios you should be able to use that or download the boards bios & reinstall it. Check you manual. You just might get out of it.
My System SpecsSystem Spec
.


16 Dec 2011   #4

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Hipster Doofus View Post
No point leaving it on. If the board has a backup bios you should be able to use that or download the boards bios & reinstall it. Check you manual. You just might get out of it.
That's the really annoying thing. It's a Gigabyte board (GA-K8NXP-SLI) and they have the drivers on their website but they don't install on Windows 7 64 Bit!
My System SpecsSystem Spec
16 Dec 2011   #5

Windows 7 Ultimate x64
 
 

Panic over! It was indeed corrupted and wouldn't boot up at all. Switched it off with the power supply at the back and attempted to fiddle with the motherboard battery (not sure if I succeeded in removing it a bit, maybe) and when I turned it back it told me that the main BIOS had been corrupted and then it proceeded to overwrite it with the backup BIOS. Wonderful backup BIOS. You wonderful creature.
My System SpecsSystem Spec
16 Dec 2011   #6

Windows 7 Pro x64 -- PCLinuxOS KDE4 FullMonty 2011
 
 

Quote   Quote: Originally Posted by roastbeef View Post
You wonderful creature.
Why thankyou!

Yes yes I know. Not me.

Good to hear it was an easy fix.
My System SpecsSystem Spec
Reply

 Just used @BIOS to update my BIOS, it failed at 50%




Thread Tools



Similar help and support threads for2: Just used @BIOS to update my BIOS, it failed at 50%
Thread Forum
Solved Windows 7 Stuck At BIOS Cannot Enter BIOS or Change Boot Media General Discussion
Solved Problems with Nvidia gpu post BIOS system BIOS update. Graphic Cards
HDD Bios Boot Failed Installation & Setup
BIOS Upgrade failed Drivers
Failed BIOS update,HP pavilionG6 won't boot up and only black screen General Discussion
GPU Bios showing up before Mobo BIOS (slowing boot up time) Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:22 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33