Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internet not working after re-installing windows 7 home premium

21 Feb 2012   #1

Windows 7 home premium 32-bit
Internet not working after re-installing windows 7 home premium

Hi Guys,

I had a virus and so had to re-install windows 7 home premium in my laptop. Now, internet is not working. I went to device manager. There, I see a node called 'Other devices' under which 3 items appear.

This is what I see.

Other devices
-Network controller
-PCI simple communications controller
-Unknown device

In their properties, therer is a similar message - Drivers for this device are not installed (Code 28)

I have Dell drivers DVD that I purchased along with the laptop. But, I don't know which drivers to install. Can someone please help?


My System SpecsSystem Spec
21 Feb 2012   #2

Windows 7 home premium 32-bit

Hi Guys,

I made some progress. I went to properties of each of the items and clicked on 'update driver' button. In the new window, I selected to search from my c:/ drive. This installed both 'Network controller' and 'PCI simple communications controller'. But the third missing driver for 'Unknown device' is still an issue.

Please suggest..

My System SpecsSystem Spec
21 Feb 2012   #3

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)

have you tried updating in devices and printers? in the start menu click devices and printers a new window will open scroll down to computers and right click on icon then in context menu click troubleshoot this may help.
My System SpecsSystem Spec


 Internet not working after re-installing windows 7 home premium

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Installing Windows 7 Home Premium
Hey guys, Can someone help me? Do I need to backup my files before installing Windows 7 Home Premium when I'm already using Windows 7 Home Basic?
Installation & Setup
Problem Installing SP1 - Windows 7 Home Premium 64 bit
Hi, I've been trying to install Service Pack 1 on my Windows 7 Home Premium 64 bit system for the last week or so without any joy. I have tried numerous solutions from installing all the current windows updates to performing a full system format - all of which have failed. I'll list below...
Windows Updates & Activation
Asking for username/password while installing Windows 7 Home Premium
Hi. I've got some driver problems so I decided to reinstall the same windows . While installing, The system restarted and showed up the Win 7 wallpaper asking for username and password. From what ? Also i didn't configured username/password before this. Tried the old username/pass but it says "This...
Installation & Setup
Windows 7 Home Premium 64 bit not working
Hello guys I have a problem with my new laptop since Monday. The laptop was working perfectly since bought just before Christmas. On Monday explorer was very slow and I couldn't close it through Task Manager so I restart the laptop manually and since then windows didn't want to start. It was...
Installation & Setup
Windows 7 Home Premium 64 bit is not working . Need help, please.
My os is not working anymore, not working as in it takes forver to open anything, and it cannot be shut down through windows, had to press the power button to shut it down. This doesn't occur when I am using it in safe mode. I am able to post this because I installed ubuntu as an alternative os,...
General Discussion
Installing Windows 7 over Vista home Premium
Hey everyone, I am have a question and would appreciate your help. I now have Windows Vista Home Premium and I want to upgrade to Windows 7 Ultimate 32 bits. Now I know that I have to do a clean install and thus I would like to make a backup file. My computer has 2 drives one called C and the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:14.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App