Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't install new drivers


25 Aug 2009   #1

Window 7 RC 64
 
 
Can't install new drivers

Hi,

I can't install new drivers. I tried to install the new nvidia drivers and logitech setpoint 4.80 and all I get is the next error message:

"The contents of this file cannot be unpacked. The executable you are attempting to run has been corrupted. Please obtain another copy of the file, verify its integrity, and try again" (see attached)

I'm not using any download managers.

I downloaded the drivers with and without firewall or anti-virus, I cleaned my temp directory...

I have tried everything I know... Please Help

===========================================
CPU: AMD64 6400+
MB: M2N-E SLI
RAM: 4GB
VIDEO: 8800 GT
WIN: 7 RC 64 build 7100
===========================================



Attached Images
 
My System SpecsSystem Spec
.

25 Aug 2009   #2

XP, Vista, W7 64bit Home Premium
 
 

Drivers - Download NVIDIA Drivers
This doesnt sound like the message you get when unsigned drivers are installed (w764bit requires WHQL drivers), so to solve whether its something to do with the downloading have you a previous driver, or one on a CD you could start install to see if you get the same message, cancel the install of course after you find out.
Try starting IE 8 with no Add-ons might solve it straight up - start - all programs - accessories - system tools -IE8 (no add-ons) and then download the drivers.
My System SpecsSystem Spec
25 Aug 2009   #3

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ancglovi View Post
Hi,

I can't install new drivers. I tried to install the new nvidia drivers and logitech setpoint 4.80 and all I get is the next error message:

"The contents of this file cannot be unpacked. The executable you are attempting to run has been corrupted. Please obtain another copy of the file, verify its integrity, and try again" (see attached)

I'm not using any download managers.

I downloaded the drivers with and without firewall or anti-virus, I cleaned my temp directory...

I have tried everything I know... Please Help

===========================================
CPU: AMD64 6400+
MB: M2N-E SLI
RAM: 4GB
VIDEO: 8800 GT
WIN: 7 RC 64 build 7100
===========================================
Try getting the drivers from a different site. waht extension is the packed file *.zip, *.rar, etx

Ken
My System SpecsSystem Spec
.


25 Aug 2009   #4

Window 7 RC 64
 
 

Thanks for the replies.

I'm actually using FF 3.5.2. I also downloaded the drivers in safe mode. I tried to use IE without add-ons and got the same annoying message.

Both files ext is .exe, I couldn't find those drivers in other sites, every site just redirect me to the same sites (logitech and nvidia)

I really can't put my finger on what is wrong since I just updated my display drivers from Windows Update and every thing worked just fine...
My System SpecsSystem Spec
25 Aug 2009   #5

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ancglovi View Post
Thanks for the replies.

I'm actually using FF 3.5.2. I also downloaded the drivers in safe mode. I tried to use IE without add-ons and got the same annoying message.

Both files ext is .exe, I couldn't find those drivers in other sites, every site just redirect me to the same sites (logitech and nvidia)

I really can't put my finger on what is wrong since I just updated my display drivers from Windows Update and every thing worked just fine...
This is a long shot but do you either navigate away or close the browser before the download was complete?

Ken
My System SpecsSystem Spec
26 Aug 2009   #6

Window 7 RC 64
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
This is a long shot but do you either navigate away or close the browser before the download was complete?

Ken
Downloaded again this time without touching the computer while it's downloading.... same message...
My System SpecsSystem Spec
26 Aug 2009   #7

Window 7 RC 64
 
 

Damn!!!! FlashGet did it I used flashget download manager and it works...

Now I only need to figure out why it ain't working when I download with a browser...
My System SpecsSystem Spec
26 Aug 2009   #8

windows 7 rtm ultimate build 7600 x86
 
 

if u hav d .exe file of ur driver change its compatibility mode n then try to install.
hope this will work


plz reply
My System SpecsSystem Spec
26 Aug 2009   #9

Window 7 RC 64
 
 

Quote   Quote: Originally Posted by scorpionking View Post
if u hav d .exe file of ur driver change its compatibility mode n then try to install.
hope this will work


plz reply
Thanks for the replay,

Nop, changed it's compatibility mode to Vista SP2 and got the same message...

FlashGet did the trick...

Thanks again
My System SpecsSystem Spec
Reply

 Can't install new drivers




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33