Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 driver won't download


18 Apr 2012   #1

Windows 7 Ultimate x64 SP1
 
 
USB 3.0 driver won't download

Hey, I can't get this driver to install for the life of me. I have a Gigabyte MB (x58a-ud3r) with two USB 3.0 rear I/O's. I was using one of them for my ex HDD (2GB seagate expansion 3.0), that I put my back-ups on. It was working up until a couple of days ago. When I notice it wasn't working anymore I went and got the latest driver for it, but no luck. I use my MB disk to install the driver from there, but didn't work. When I use update driver from device manager it says driver is up to date. The ex HDD will work in a 2.0 USB, but I'd like to use the 3.0 since I have them.

Here's a screen shot if it helps.

Subject title; driver will download, but won't install. sorry about that.



Attached Thumbnails
USB 3.0 driver won't download-dm-driver.png  
My System SpecsSystem Spec
.

18 Apr 2012   #2

Windows 7 Pro-x64
 
 

While it could be just a connection (cable) problem, this is almost always a driver problem. I noticed you don't have a Hub showing for the USB 3.0--Just the controller. This could be an incorrect driver or a driver failed to install. Right click on the controller, select properties then click on the Resources tab. Check to see if there's any conflicts in the lower box. Go back to the controller Properties and uninstall the current driver. Shutdown the PC, plug in your USB 3 device and power it on. Power on the PC and see if Windows finds new hardware.
My System SpecsSystem Spec
19 Apr 2012   #3

Windows 7 Ultimate x64 SP1
 
 

I did as you suggested carwiz, I'm now searching for the correct drivers. thanks for you input. This is what I get now in device manager.


Attached Images
 
My System SpecsSystem Spec
.


19 Apr 2012   #4

Windows 7 Ultimate x64 SP1
 
 

Well this is really starting to confuse me. All of my searches lead me to the same driver (Renesas 3.0). When I uninstalled the driver, I see the device (first screenie), but no driver. When I install the driver, I don't see the device, but I see the driver (second sceenie), but driver won't start code 10. This ex HDD works in a 2.0 port, and was working in the 3.0 port to start with.


Attached Thumbnails
USB 3.0 driver won't download-dm-driver3.png  
Attached Images
 
My System SpecsSystem Spec
19 Apr 2012   #5

Windows 7 Pro-x64
 
 

Here's a link to the "Code 10" explanation: Description of Code 10-related errors that Device Manager generates in Windows-based computers

Is your Windows 7 up to date? (Beyond SP1)

Where are you getting the driver? Nothing works for me at the Gig-o-bites website so I couldn't check for drivers but they are motherboard specific (Gigabyte X58A UD3R). Drivers for other motherboards may not work. Don't use drivers from any other source but Gigabytes. While you're there, check for BIOS updates too.

Here's the link: GIGABYTE - Motherboard - Socket 1366 - GA-X58A-UD3R (rev. 2.0)
My System SpecsSystem Spec
19 Apr 2012   #6

Windows 7 Ultimate x64 SP1
 
 

My Win 7 is up to date. I got the driver from the Gigabyte site, but I had the same results. I didn't see any updates for my bios, and I'm reluctant to flash it since I'm not having any other system issues.
My System SpecsSystem Spec
19 Apr 2012   #7

Windows 7 Pro-x64
 
 

What is the USB Mass Storage device shown in your second pic of Device Manager?
My System SpecsSystem Spec
19 Apr 2012   #8

Windows 7 Ultimate x64 SP1
 
 

Have you checked your BIOS to see if USB3 is enabled, if there is such a setting?
My System SpecsSystem Spec
19 Apr 2012   #9

Windows 7 Ultimate x64 SP1
 
 

@ carwiz, it doesn't show-up after installing 3.0 driver, if I uninstall the driver it returns like in pic one.

@ kegobeer, yes there is such a setting for my MB, and mine is enabled.
My System SpecsSystem Spec
20 Apr 2012   #10

Windows 7 pro 64bit. (SP1)
 
 

is your motherboard Gigabyte X58A UD3R ?
if so please try this driver
http://download.gigabyte.us/FileList...river_usb3.exe

what version is your bios?
My System SpecsSystem Spec
Reply

 USB 3.0 driver won't download




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:23 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33