Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon 9550 Display Driver problem


04 May 2012   #1

Windows XP 32 bit SP2
 
 
ATI Radeon 9550 Display Driver problem

Hellow!

I recently installed an ATI Radeon 9550 HD display driver to my computer, Windows XP SP2 32bit . Before that, my computer was running in VGA mode only. But though, I have downloaded the driver and installed it with the Catalyst Control Center. After rebooting, what I got is a black screen after Windows XP boot screen. I shut down the computer and now I saw the classic WELCOME with the blue background... but nothing more. After rebooting the PC for about 5 times, I got past the WELCOME stuff and to the desktop. As I watched the Device Manager, It says the I Have Installed the ATI Driver and its secondary Driver. But though, if I right-click my desktop and go to Display Properties>Settings>Advanced>Display Adapter I saw that there was no Display Driver and I was still running in VGA. VGA sucks because you can't play any 3D games or even Google Earth won't work. Now everyday I start the PC, I have to reboot about 5 times untill I get it working. It's been almost a month since I'm doing this and it caused me alot of nerves and boredoom.But though, sometimes I think the ATI works since I boot the PC, then I see the black screen and hear that start sound like when you XP starts. I managed to acces the Narator and saw that PC was actually working, except was like blind. I am looking for some fix tips and reply ASAP. Here are also some screenshots:






My System SpecsSystem Spec
.

04 May 2012   #2

Windows 7 Home Premium 64 bit
 
 

Try to do basics first. Uninstall EVERYTHING ATI from add or remove control panel, and then go to device manager and right click all the ATI's and click uninstall.

Then reboot, you'll be in VGA graphics. Install the latest drivers possible fresh install, and reboot. See if that does anything.

If not, turn the PC off and reseat the graphics card in the slot. Try another slot if available. Check BIOS and make sure video settings are set to auto detect whether internal graphics or external graphics (if you have this option)

If nothing finally works I would try updating to SP3 windows xp.
My System SpecsSystem Spec
04 May 2012   #3

Windows XP 32 bit SP2
 
 

Ummm, excuze me but if I unnistall all the ATI drivers am I going to be like Black Screen? I tried that once and I had to reset my BIOS after that. Anyway I'm not very good at computer stuff.
My System SpecsSystem Spec
.


04 May 2012   #4

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Draghy View Post
Ummm, excuze me but if I unnistall all the ATI drivers am I going to be like Black Screen? I tried that once and I had to reset my BIOS after that. Anyway I'm not very good at computer stuff.
you should not have a black screen if you uninstall all the drivers. What should happen is windows should/will temporarily work with it's own extremely basic VGA driver until you can reinstall the specific ATI drivers.

If you've tried this once, I don't see how resetting the BIOS would fix anything. If you experience it again, try hitting F8 at startup to get to the windows boot menu and try to install the drivers under safe mode or VGA mode.
My System SpecsSystem Spec
04 May 2012   #5

Windows XP 32 bit SP2
 
 

Unnistalled the ATI driver and rebooted. Now I'm back to VGA but when I run the AMD autodetect it doesn't find my driver. Any sugestions?
My System SpecsSystem Spec
04 May 2012   #6
Microsoft MVP

Win 7 Ultimate x64
 
 

This is the latest (and last) driver for that card,

ATI Catalyst

Also what is it showing in Device Manager under "Other devices", as those will be any devices that haven't had their driver installed yet? It is quite possible that there is a part of the chipset driver that is missing, and that is why the video card driver isn't working.
My System SpecsSystem Spec
04 May 2012   #7

Windows 7 Home Premium 64 bit
 
 

First of all this is a Windows 7 forum and Microsoft doesn't even support XP anymore. System spec's would help alot so people would know what their dealing with, it's probably an AGP card so the latest drivers don't have support for that card, AMD used to have a page with the AGP hotfix legecy drivers but not sure if they still support those.
My System SpecsSystem Spec
04 May 2012   #8

Windows XP 32 bit SP2
 
 

In the end... after all that strugling . . . .

Couldn't get that crap working. Started to piss me off so I dug up my old Pentium II and got the ATI 3D Rage II card and installed it instead of the 9550. And yeah, I know this is a Windows7 forum but I was hoping I'm gonna get some help so STFU. In the end, that old '96 driver proved to be better than VGA but though... I see it as installed, pluged in and working properly without even downloading some kind of driver. But looks like my PC won't let me play 3D games anyway.... I got the THPS2, old but cool game, open it, see the Intro and BAM! Black screen and music. Blind again. Same things happens to other 3D requiring applications.
My System SpecsSystem Spec
04 May 2012   #9

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Draghy View Post
In the end... after all that strugling . . . .

Couldn't get that crap working. Started to piss me off so I dug up my old Pentium II and got the ATI 3D Rage II card and installed it instead of the 9550. And yeah, I know this is a Windows7 forum but I was hoping I'm gonna get some help so STFU. In the end, that old '96 driver proved to be better than VGA but though... I see it as installed, pluged in and working properly without even downloading some kind of driver. But looks like my PC won't let me play 3D games anyway.... I got the THPS2, old but cool game, open it, see the Intro and BAM! Black screen and music. Blind again. Same things happens to other 3D requiring applications.
I bet you wouldn't say STFU to a moderator..
My System SpecsSystem Spec
04 May 2012   #10

Windows XP 32 bit SP2
 
 

With all respect, but I he/she posted, at least it could be an useful post. I mean no disrespect but I'm not so stupid to not know that this is a Windows7 forum. I'm looking in all the forums for a darn way to fix the problem that slowly destroys my PC. You don't even know how it feels without any video card... You can't play only old, crappy 2D games. You can't experience any 3D. It basically sucks. But I'm not here to argue so fine, I'm sorry for the STFU. BTW: Am I the only one who doesn't see my profile pic and signature pic?
My System SpecsSystem Spec
Reply

 ATI Radeon 9550 Display Driver problem




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:57 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33