Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: TP-LINK TL-WN722NC Driver problem

17 May 2012   #1

Windows 7 Ultimate 32bit SP1
 
 
TP-LINK TL-WN722NC Driver problem

Hello all,

I have just got this TL-WN722NC usb networking stick, but my Windows 7 doesn't at all want to recongize it.

I have tried running the disc that came with the adapter, it installed O.K. without errors, but i do not see the adapter working at all. (no blinking from the green led on it, and it doesnt appear at the Networking adapters either)

So i went to Device Manager, this is what i see there:



If i right click and select Update Driver Software.. and then select Search Automatically.. i get the following message:



Then i have tried to uninstall all the drivers and software that the disc installed, restarted the PC and tried to Update Driver Software.. then Auto search.. it have resulted in this message:



Then i tried to manually point the driver files in the Device manager (the ones on the CD, also the newest driver from their website) and always getting this message:




So anyways.. what the hell? Before this i tried a TP-Link PCI wifi card (TL-WN350GD) and that had these same errors! (Code31 all the time)

Im really out of ideas by now, also tried going in safe mode.. installing it from there.. rebooting many times didnt help also.. even ran CCleaner all the time when trying another driver.

Please help me, i really dont understand why my Windows 7 hates TP-Link products so much.

Many thanks and regards,
Marky

My System SpecsSystem Spec
.

17 May 2012   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

marky0, welcome to the Seven Forums.

Let's try the easy way first. If you haven't yet give this a try,

Hardware devices are not working or are not detected in Windows

Also as far as installing goes, don't bother with the disk and just use the latest from TP-Link,

http://www.tp-link.com/en/support/do...rsion=V1#tbl_a
My System SpecsSystem Spec
17 May 2012   #3

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

i use tplink and used to get this problem. stormy is right dont use the disc or the tplink software windows will work fine without it as stormy said go to tplink and download the latest driver for your pc and install the .inf file using device manager and re-boot the pc. i have the driver here in the zip file for you if you want it.


Attached Files
File Type: zip Windows 7 32bit.zip (637.2 KB, 294 views)
My System SpecsSystem Spec
.


17 May 2012   #4

Windows 7 Ultimate 32bit SP1
 
 

stormy13, i have tried the Fix It prog you have linked, ran it to check and fix all errors.. it just re-installed the driver of the adapter then gave me this page:



brianzion, i have uninstalled, restarted, then installed the one you uploaded and same error while it was installing it:



So the adapter still isn't working..

Regards,
Marky
My System SpecsSystem Spec
17 May 2012   #5

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

right ok, with the adapter plugged in go to device manager and un-install the the driver from the machine pull the adapter out and reboot. after windows is up and running plug adapter in a different usb port if possible and see if windows installs a generic driver. also have a close look at the adapter and check the number is right and if its version 1 etc. and match it on the website for the driver TL-WN722NC - Welcome to TP-LINK

have a read of this >> http://goo.gl/9nvvu

it appears there are two drivers for the adapter For TL-WN722NC and For TL-WN722NC V1
My System SpecsSystem Spec
17 May 2012   #6

Windows 7 Ultimate 32bit SP1
 
 

Right, tried your first advice.
Device plugged in -> Uninstall driver from device manager -> Device plugged out -> Restarted Windows 7 -> Waited till it all started up and plugged it in a different never used before USB port and this is what i've got after some waiting:



I have downloaded the other non v1 driver also, and used the method which you have linked. This is the result of it:



It seems that whatever i do, there is always a Code31 error, always!

Regards,
Marky
My System SpecsSystem Spec
17 May 2012   #7

Windows 7 Ultimate 32bit SP1
 
 

So in my total confusion.. i wanted to try if this adapter would work at another machine..

So here comes my netbook into action, running Windows 7 Home Premium 64bit.
Connected the adapter, then ignored the windows auto install thingy.
Then, used the guide linked above (How to Manually Install Adapters on Windows 7 - Welcome to TP-LINK) to install that exact v0 driver that is mentioned above also.
And i have to say.. it has installed it under a couple of seconds and i instantly saw the adapter in action detecting wifi hotspots and all.
So the device indeed works with Windows 7!

But now again.. why doesn't it work with my main PC? (Windows 7 Ultimate 32bit)
It keeps giving me that same error all over again, even when using the same method that has worked on my netbook.


Could it be some security settings? BIOS settings? (Mobo is ASUS-P5KV)
What the hell could be soooo wrong??

Im starting to beg for this to work.. i really need wireless on my main PC

Please help

Regards,
Marky
My System SpecsSystem Spec
18 May 2012   #8

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

are you in administrator mode? and what security software are you using on the pc? kaspersky has a issue with some tplink products so try and install in admin mode and disable security. have a read here >>> Why cannot I scan any wireless network on Windows 7 nor Vista with Kaspersky installed? - Welcome to TP-LINK
My System SpecsSystem Spec
18 May 2012   #9

Windows 7 Ultimate 32bit SP1
 
 

I'm using ESET Smart Security 5, and it is installed with like the same settings as on my netbook, which installs the driver instantly without errors.

Well i'm the only user on my main PC, and it was installed like that back in the time.
So i guess im indeed the main administrator on it.

Seriously... wth is all up with this Code31 error?

Marky
My System SpecsSystem Spec
20 May 2012   #10

Windows 7 Ultimate 32bit SP1
 
 

Anyone?

Whatever i do, i always get this error message:


But it installs correctly on my netbook (Windows 7 Home Premium 64bit) with the same Antivir/firewall (Eset Smart Security 5).

Or is there any way i could clean every single driver file it installed before for this, and i can start from scrach? (From registry and from anywhere else)

Marky
My System SpecsSystem Spec
Reply

 TP-LINK TL-WN722NC Driver problem




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:55 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33