Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Failed Device-driver Uninstall with "Forcedelete" Loop

15 Jun 2012   #1

Windows (32 & 64 bit) XP, 7, 8CP; Ubuntu 10.10; Android x86
 
 
Failed Device-driver Uninstall with "Forcedelete" Loop

Greetings all.

I monitor installation of apps with Systrace and Comodo Programs Manager. Using the latter, which includes the ability to uninstall Drivers, I've encountered a disastrous problem:

Specs:
-- Dell Inspiron 1525 laptop - 3yrs; Intel 2 x 2.0GHz, 8GB DDR2, 320GB 7200 HDD (20+GB free)
-- Windows 7 Ultimate 64bit, fully patched, updated and maintained; Retail, one yr. installation.
-- Norton IS 2012, Malwarebytes, Mamutu, Windows Firewall (regularly run Kaspersky, ESET,
etc., scanners offline. No malware.)
-- Have 350+ third-party apps installed for reference, testing and troubleshooting others' computers. (haha!)

Problem: Using Comodo Programs Manager (CPM) I uninstalled Windows Mobile 2003 Device Driver which required a reboot to complete and, now, I cannot boot the system. The Windows logon screen appears, a message displays, saying CPM's "Force delete jobs completing...". The system freezes there with a black screen, the mouse cursor responds but there is no other activity. Even the LED showing HDD activity ceases.

Attempted solutions:
-- Safe Mode(s), Last Known Good Config, etc., Startup Repair, (System Restore has been disabled.) To make matters worse, I carelessly began to run Windws 7 installation repair as though it was XP. Before I caught the mistake and cancelled, 7 had already begun to copy files. Now I have the SystemRoot as "windows\windows".
-- BCD rebuild successful but still have the "windows\windows".
-- SFC starts but will not complete from Windows RE Command Prompt. Tried c:, d: and e:.
-- Using Windows RE Command prompt, ran regedit-> File-> Load Hive and navigated to "Comodo Program Manager" installation directory and moved it to another folder on C: drive hoping that would break the call to the "Force delete jobs completing...". No Luck.

I have looked into all the "fixes" suggested on the publisher's Forum/website, including the seemingly non-existent "forcedelete.txt", Registry hacks and "cnat.exe" solutions.

No backup image is available and reinstalling all those apps, updates, tweaks, etc., etc., is not an option. Suggestions would be most appreciated.

Thanks.

P.S.: Before you guys & gals pillory me for no backup, this drive WAS my Acronis TrueImage clone!


My System SpecsSystem Spec
.

Reply

 Failed Device-driver Uninstall with "Forcedelete" Loop




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:44 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33