Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dell Controlvault

12 Jul 2012   #1

Windows 8 Professional
 
 
Dell Controlvault

Restored client's system to factory (Dell Precision M6600 mobile workstation) due to OS corruption. The only driver that wouldn't install was for the biometric scanner. Regardless of the order, version, or medium of the install, it simply won't accept it. Any ideas?

My System SpecsSystem Spec
.

17 Jul 2012   #2

Windows 7 Ultimate x64
 
 

How did you perform the initial OS restore?

Will it install in Safe Mode?
My System SpecsSystem Spec
18 Jul 2012   #3

Windows 8 Professional
 
 

I believe the problem existed somewhere in the order of which the drivers were installed. What drivers does Safe Mode typically restrain? If the drivers that were dependent on the resources provided by the driver package installed after it were restrained, it would be as though they were virtually non existent, and potentially allowing for the effective implementation of the driver in question. However, this is an old issue at this point, yet I'd still like an answer for future reference... How sound is my theory?
My System SpecsSystem Spec
.


18 Jul 2012   #4

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Poimetheus View Post
I believe the problem existed somewhere in the order of which the drivers were installed. What drivers does Safe Mode typically restrain? If the drivers that were dependent on the resources provided by the driver package installed after it were restrained, it would be as though they were virtually non existent, and potentially allowing for the effective implementation of the driver in question. However, this is an old issue at this point, yet I'd still like an answer for future reference... How sound is my theory?
I would've thought more along the lines that if a driver would not install it would be due to dependency on another that has not been installed yet, rather than being due to one that's already installed (unless it's a conflict, you need either one or the other, not both). You would have to know, I guess, everything required to get that device working, uninstalling/reinstalling components until you get them all loaded.

Safe mode won't try to load stuff that isn't required for the basic functionality of the machine; meaning in this case, I think, it wouldn't try loading anything to do with the biometric scanner. Hard to say if it would work.

Is the scanner working? Did you maybe get an alternate driver via Windows Update?
My System SpecsSystem Spec
27 Jul 2012   #5

Windows 8 Professional
 
 

We never got it working. I had the correct drivers according to dell. My thoughts were that it was dependent on another driver fo functionality, but was installed prior to that in which it was dependent. There are even warnings about driver order installation upon reload
My System SpecsSystem Spec
27 Jul 2012   #6

Windows 7 Ultimate x64
 
 

So what kind of initial reinstall was done to begin with? Dell OEM discs, recovery partition, retail disc?
My System SpecsSystem Spec
28 Jul 2012   #7

Windows 8 Professional
 
 

OEM; even used the driver install disk.
My System SpecsSystem Spec
28 Jul 2012   #8

Windows 7 Ultimate x64
 
 

Tough issue it seems. Seems as though you should've been able to get it back to 100% working condition via its own install media, all without an internet connection and no interference with Windows/third party updates.

You know there has got to be a way to get it done as it was manufactured and delivered that way to begin with.

This is where a prior clone or image would've come in handy.
My System SpecsSystem Spec
01 Aug 2012   #9

Windows 8 Professional
 
 

I did image the drive prior to the wipe; but it was corrupted, hence the wipe. I can't even say that it ever worked in the first place.
My System SpecsSystem Spec
01 Aug 2012   #10

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Poimetheus View Post
I can't even say that it ever worked in the first place.
You know, I was thinking about asking you about that a week ago, but thought, nah you've probably already thought that through.

Makes me wonder exactly how it appeared in Device Manager...
My System SpecsSystem Spec
Reply

 Dell Controlvault




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33