Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Canon MX870 Printer - Driver Issues

14 Jul 2012   #1

Windows 7 Home Premium 64 Bit
 
 
Canon MX870 Printer - Driver Issues

Hi all,

OK ... for a few days (maybe a week) now I have had trouble with my Canon MX870 Printer/Fax. I have been using it successfully for the past 16 months now, via USB connection, installed on both my Windows 7 laptop and my Windows XP PC (I just unplug it and plug it in to whichever computer I need to print from).

For some reason, it has decided not to recognise the drivers on my laptop. I have tried to uninstall and reinstall (no go). I also deleted every instance of MX870 from the registry that it would allow me to (some it wouldn't for some reason - no access - yes I am Administrator). Reinstall again ...still no go.

The Windows 7 Updates were failing to update the Fax component which I thought was the problem, then all of a sudden it was successful ... still no printer. Now, it is unsuccessful again.

But ... I don't use the Fax component ... never have ... with no problems for 16 months.

The reinstall from the CD is successful, but when I plug in the printer, it fails. "Device driver software was not successfully installed. Please consult with your device manufacturer for assistance getting this device installed.

CanonMX870 series ... Ready to use (with a green tick) ...
CanonMX870 series FAX ... Failed (with a red cross).

Oh, BTW, the scanner component works fine.

Also, each time I unplug then plugin the USB cable, it attempts to reinstall the device drivers, the printer successful, the fax failing. It never did this before when I was happily printing away from both computers.

Oh, and by the way, I have no problem printing from the XP machine when it's plugged in there ... all is good there.

I have been to the Canon website and downloaded the latest drivers, which installed perfectly, but again when I plug in the printer, it fails to install the fax driver and the printer won't work..

I have also tried all of the various USB ports and ruled that out.

I've also run the Hardware and Devices Troubleshooter ... also without success.

Also, I don't know if this is relevant or not, but I can't even print to PDF. My CutePDF program is also not working. I thought this may have been a workaround until I got the printer working again, but no luck. CutePDF will go thought its processes (it's now ticked as default as my Canon is now longer even listed), up till the point where you need to name the file you're creating (that box doesn't appear) ... all you get to do is print, choose CutePDF, then it disappears ... no file .. or if there is, I have no idea where it's gone or what it's called ... can't find a trace of it.

I have not downloaded or installed any other programs (except Windows Updates) in some time that could have caused this. I am at a loss. This is a business computer and printer and is causing much angst.

I am running Windows7 (64bit) on an Acer Aspire Laptop (only 16 months old) ... Firefox 13.0.1

Also ... running Microsoft Fixit for Printers doesn't even detect the printer and tells me to install one ... it already is !!! As does the Troubleshooter ! Does not detect the printer.

Please help ... I'm about to chuck this out the window !

Thanks in advance
Cheers
Robyn


My System SpecsSystem Spec
.

14 Jul 2012   #2

Windows 7 Pro. 64/SP-1
 
 

Thats a long story. You might of already did this. Start and go to devices and printers. Make sure the printer has a check mark in it. That will make it your default printer. With the printer hooked up to your computer and powered up reboot your computer. Lets see if Windows 7 will pick it up or sometimes it will ask if you want to install the driver. Windows 7 comes with a lot of drivers built in.
My System SpecsSystem Spec
15 Jul 2012   #3

Windows 7 Home Premium 64 Bit
 
 

Yes, thank you for replying. However, when I say Windows doesn't recognise the printer, I mean there is no printer icon to click on. It's just not there. The printer has installed successfuly ... well according to the messages that come up after re-installation with the CD, however there's no printer icon in the printers and devices folder. Nada ... Nothing. which is part of the problem I expect There seems to be a glitch somewhere in between the installation of the printer and the installation of the drivers (if that's possible)

And when I try to install printer "manually" ... it won't work either ... as it's a USB connection, and Windows is supposed to recognise that automatically, which it is not.

Cheers
Robyn
My System SpecsSystem Spec
.


15 Jul 2012   #4

Windows 7 Pro. 64/SP-1
 
 

Can you find the Canon MX870 Printer drive exe to make sure not only has it download but is also installed. Go to Windows Explore and then to downloads and see if you can find it. If you can open it up and go from there.
PS. Make sure it for 64 bit.

Run sfc /scannow from the cmd prompt/admin 3 time booting after each time.
Have you looked in Device Manager for your printer or any indication of problems.
Can you go to a Restore Point before all this happened?
My System SpecsSystem Spec
15 Jul 2012   #5

Windows 7 Home Premium 64 Bit
 
 

Hello Layback Bear,

Yes, the latest MX870 driver is in my download folder. I've tried re-installing it several times already. Yes, it also says that the Fax component hasn't installed ... each time I try. Big red cross against it. It seems to be this FAX component that is screwing everything up. It has worked fine for the last 16 months, why now??? Something to do with a Windows Update ??? Which one ??

The MX870 Printer icon is now appearing in the Devices and Printers Folder, but with the yellow Troubleshooter icon on it. Right clicking, there is NO "make default" printer option.

Run Troubleshoot - "Install a driver for this device. The driver for CanonMX870 series is not installed. Install latest driver for this device"

Apply fix - Device driver installs - "CanonMX870 series Device driver software installed successfully."

Still no printer.

Unfortunately the restore point thing was turned off - have no idea why - I've never touched it. So no restore point to come back to. It's turned on now though.

What does this do ? "Run sfc /scannow from the cmd prompt/admin 3 time booting after each time."

I will try it anyway ...

Thanks
Cheers
Robyn
My System SpecsSystem Spec
15 Jul 2012   #6

Windows 7 Home Premium 64 Bit
 
 

Further notes :

I ran the scannow utility 3 times, rebooted after each one ... nothing found each time.

The Canon My Printer software that installs with the printer has a Diagnose and Repair Tool ... have run that multiple times ... does not detect the printer ... tells me to connect and turn on the printer. It is !!!

Windows Update ... Canon - Printers - Canon MX870 Series Fax ... 17.6 Mb
Update released Jan 2011 ... Published 19/05/11
has been failing since 6th July ... error code 80070704
The actual Printer Update - Canon - Printers - Canon MX870 Series (not Fax) has been successful each time. It's just the Fax Update that fails.
Was there another Windows Update on that date that has screwed everything up I wonder ???

Cheers
Robyn
My System SpecsSystem Spec
16 Jul 2012   #7

Windows 7 Pro. 64/SP-1
 
 

Using sfc /scannow checks and repairs Windows Files if possible. This will help you to understand.
SFC /SCANNOW Command - System File Checker
If I understand you correctly the printer works but the Fax doesn't; is that correct?
Check and see if the driver you installed in this computer matches the driver in one of the other Windows 7 computer that this printer/fax is used on and works. This also may be of help.
USB Driver - General Fix for Problems
My System SpecsSystem Spec
17 Jul 2012   #8

Wds 7 Home Pre. 64-bit SP1
 
 

By any chance you are running Avast AV ...? or any ..?
Uninstall it .... then install your canon driver ..
I had this problem few months back .
My System SpecsSystem Spec
Reply

 Canon MX870 Printer - Driver Issues




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33