Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AMD CCC installing issue; desktop won't load after restart.

05 Aug 2012   #1
Sierra23

Windows 7 Ultimate x64
 
 
AMD CCC installing issue; desktop won't load after restart.

Hey there!

I've just recently bought a new PC, and 2 weeks later I'm having issues with it already. Here's the config.:

Motherboard - LGA1155 H61 MSI H61M-P21 (B3)
Processor - Intel® Core™ i3-2120
RAM - DDR3 8GB (2x4)
HDD - Hitachi Deskstar HDS721050DLE630 500GB 7200rpm
Graphics - VGA AMD Radeon 6770
Power supply - 500W

So anyways, everything worked like a charm first week or so. I was well impressed. Then I had some issues with my 5.1 surround system; after trying everything possible software-wise, I got talked into re-installing Windows 7 to fix the sound problem I was having with the speakers. Foolish decision it turned out to be, not only it didn't help me solve the sound problem, but now I can't even install Catalyst Drivers anymore.

Here's where the problem is: after I re-installed Windows 7 Ultimate x64 (all clean and proper of course), and applied all the updates/fixes through Windows Update Action Center etc - I need to install AMD Catalyst Control Center in order to make my graphics show up on device manager/work. When I install it, and it asks for restart after (so it can complete the install and apply it), my Windows won't load proper. Firstly a black screen appears shortly (intead of standard "Welcome" screen), and then few moments later desktop appears with no taskbar or any icons on it. I'm not even able to opet task manager or anything, my whole computer seems to freeze up.

I have tried installing graphics drivers from the original disc I received with my card, I've tried downloading it manually (and through the Windows Update as well); no matter what way I install it, after the reboot my desktop won't load, my Windows doesn't start proper.

I have installed 3 different versions of Windows 7 Ultimate ever since, I've tried pretty much everything that crossed my mind and I'm still rather clueless about the whole thing. Does anyone know what the problem might be, and/or how can it be fixed? I can't play a single game meanwhile, matter a fact I can't even get my graphics to show up under device manager (until I install AMD CCC).

Sorry for the long text and please pardon my choppy english (it's not my mother tongue). Thanks in advance.


My System SpecsSystem Spec
.
05 Aug 2012   #2
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

what version of the CCC were you trying to install

If it was from the Disc you should have just went to the site and if you got the 12.7 beta you are also better off going 12.6 i have new 7900 cards and they give me some issues in certain games but nothing to problematic

i would go with the 12.6 or 12.5 12.4 isnt a good driver or 12.7 probally end up skipping it and waiting on a 12.8

As for the install issue it happens on the version of the driver used sometimes it finishes in red or goes into yellow indicating it wasnt installed correectly


also im not sure if your conflicting with any intel hd graphics
My System SpecsSystem Spec
05 Aug 2012   #3
Sierra23

Windows 7 Ultimate x64
 
 

Hello Solarstarshines! Thanks for the quick reply!

I have tried installing both from their official web site and the Disc itself. Same problem appears, regardless what way I decide to do it. Also, I believe it was 12.6 version on both sources (web/disc).

The install finishes in green every time, it reports no issue during/after it. The problem shows up after the restart. As I said, Windows doesn't start proper, Desktop appears with no taskbar/icons on it, and my PC sort of freezes. After I restore system from the safe mode (and that way undo the previously installed AMD CCC), I'm able to start Windows 7 normally..

Right now, without AMD CCC being installed, Device Manager reports only integrated Intel graphics. When I install AMD CCC, integ. card disappears and gets replaced with 6770 in device manager. But again, I can't install AMD CCC because my Windows doesn't load normal after it.

Oh and what do you mean by "conflicting with any intel hd graphics"? My knowledge about computers is limited, if you have any ideas/suggestions I'm willing to try 'em out if you think it might help resolve the problem .
My System SpecsSystem Spec
.

05 Aug 2012   #4
DigDeep

Windows 7 SP1 x64 Ultimate
 
 

I had similar problem. I was getting bsod, after CCC installation.

Try to install drivers ONLY. I see what happens.

Maybe this will help too.

Upgrade from 4870 to 6850 BSOD problems
My System SpecsSystem Spec
05 Aug 2012   #5
Sierra23

Windows 7 Ultimate x64
 
 

Okei so.. After running AMD Driver Autodetect - AMD Driver Autodetect
Downloading failed when reaching about 99%, and a window popped up saying:






What does this mean in other words lol? Is this where the issue lays? Sigh this can't be good, what do I do now
My System SpecsSystem Spec
05 Aug 2012   #6
DigDeep

Windows 7 SP1 x64 Ultimate
 
 

AMD Catalyst

Download these
My System SpecsSystem Spec
05 Aug 2012   #7
Sierra23

Windows 7 Ultimate x64
 
 

Hey DigDeep!

I did that previous to writing this thread (as I explained above already). After its' installation and restart that follows it - I don't get the typical blue windows "Welcome" screen -- instead I get all black screen, which later on loads into an empty desktop background with no icons or taskbar on it. Every time. I can't ctrl+alt+del, my computer freezes at that point.

Until I do system restore to undo the AMD CCC install, only then my Windows boots normally again.
My System SpecsSystem Spec
05 Aug 2012   #8
DigDeep

Windows 7 SP1 x64 Ultimate
 
 

Did you try to install video drivers ONLY?

deselect everythig else, and select video driver only. That helped my BSOD.
My System SpecsSystem Spec
05 Aug 2012   #9
Sierra23

Windows 7 Ultimate x64
 
 

Uhhmm.. Not sure. I think I didn't, no. I went for the "Express install" option or whatever it was, you know - the default stuff...

I can try installing drivers only I guess, I assume that's under "custom" option yeah? I'll give it a go right now then, and tell you what's happening.

p.s. Though I will need to install CCC at some point as well however, 'cause I've got HDTV hooked up on my computer too. CCC helps me sort out the overscan resolution etc.

Edit: Huhh there's so many options here, which ones should I/should not install? Honestly I'm affraid I'll have to do system restore again if I install wrong thing, I've downloaded/installed so many things this morning lol.

My System SpecsSystem Spec
05 Aug 2012   #10
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

Re install this Download: Microsoft Visual C++ 2010 Redistributable Package (x86) - Microsoft Download Center - Download Details


and see if it helps you out also

this Search results - Microsoft Download Center


What i noticed Visual c++ was missing the first link is to that also a link to direct x run times and 11 are there its best you install those and see if you can re install the CCC
My System SpecsSystem Spec
Reply

 AMD CCC installing issue; desktop won't load after restart.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
restart issue
when i shut down my windows 8 it will only restart..i have to press start button to shut down
General Discussion
Win 7 won't load after installing GPU
Hello, I'm having trouble installing my graphics card (ATI Radeon Sapphire HD 5670) on a fresh Windows 7 system. I recently had to reformat and start over with this system twice because of virus and HDD issues. On the first reformat, the graphics card and Windows installed perfectly and worked...
Graphic Cards
New SSD install problems - won't load windows on restart
I did a fresh install of windows 7 on my ssd. I unplugged the HDD while this occured. Everything went smoothly. When I plugged in the HDD I noticed a partition is also now on there. Boot priority is set to the SSD and it is set to ahci mode in bios I noticed yesterday that updates had...
Hardware & Devices
re-installing add ons every computer restart
I have to re-install all addons every time I restart the computer. Tabs come up saying a third party program requested the re-installations. Help!
Browsers & Mail
PC restart while installing windows 7
Hello, I was trying to install windows 7 on my computer but something really strange happened. When i boot from the cd, the setup is loading some files (grey bar, bottom of the screen). After that i get a blue background and i enter my language, keyboard layout and my time settings. Then i...
Installation & Setup
Windows 7 keeps installing its own driver restart
Hey guys, I've read a bunch of posts of this happening to people too but it doesn't seem like there was a permanent solution to any of them. I just installed windows 7 on a dell dimension 3000 and im using the onboard video. Everytime i reboot it wants to automatically install the "Standard VGA...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App